Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd April 2009, 01:16
patrickfoley patrickfoley is offline
Junior Member
 
Join Date: Jan 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default How my friend made phpmyadmin work

As some of you have already experienced, after you create a website (or host a domain) and then create a database, you cannot access the database thru phpmyadmin.

When you click on the database icon within ispconfig3, the intended url is redirected and you get either an error or broken link.

The solution my friend implemented was to create a link as follows:

cd /var/www
ln -s /usr/share/phpmyadmin phpmyadmin

this is working for me.

thanks to falko and till etc for all their help.
Reply With Quote
Sponsored Links
  #2  
Old 29th April 2009, 17:30
Thomas Jensen Thomas Jensen is offline
Senior Member
 
Join Date: Apr 2009
Posts: 127
Thanks: 5
Thanked 1 Time in 1 Post
Default

It worked for me too, but only from the main domain.

Is it possible to make it work for each website? like: domain.com/phpmyadmin and domain2.com/phpmyadmin?

It worked before i reinstalled ISPconfig.

I think it's the same problem which bothers me when i try domain.com/webmail

Last edited by Thomas Jensen; 29th April 2009 at 17:47.
Reply With Quote
  #3  
Old 29th April 2009, 17:50
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 95 Times in 60 Posts
Send a message via Skype™ to Horfic
Default

You have to do for every domain this:
Code:
cd /var/www/{your Domain without www.}/web/
ln -s /var/www/phpmyadmin phpmyadmin
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #4  
Old 29th April 2009, 17:54
Thomas Jensen Thomas Jensen is offline
Senior Member
 
Join Date: Apr 2009
Posts: 127
Thanks: 5
Thanked 1 Time in 1 Post
Default

But last time i installed ISPconfig 3, it worked automatically!
Reply With Quote
  #5  
Old 15th May 2009, 11:21
tio289 tio289 is offline
Member
 
Join Date: Mar 2009
Posts: 70
Thanks: 2
Thanked 14 Times in 9 Posts
Default

yes, you not use ln. just add this line to apache.conf

Alias /phpmyadmin /usr/share/phpmyadmin

this can use for webmail too

Alias /webmail /usr/share/squirrelmail
Alias /horde /usr/share/horde
Reply With Quote
  #6  
Old 18th May 2009, 14:28
vogelor vogelor is offline
ISPConfig Developer
 
Join Date: Jan 2007
Location: Wernau, Germany
Posts: 219
Thanks: 42
Thanked 34 Times in 24 Posts
Default let me help you ;-)

Hi,
i am Oliver, the "programmer" of the phpmyadmin link inside ISPC3.

if you click on such a link, i am looking for the SERVER, the database is running at (for example server #1). Then i am looking in the server-configuration for the "name", this server has (for example s001.muv-server.com). Then i create a link to the phpmyadmin at this server.

means (for this example)

http://s001.muv-server.com/phpmyadmin

this means, you only have to "create" a working phpmyadmin under your server (NOT under EVERY doamain!).

if your server is called s1.myserver.com than you need a pypmyadmin under s1.myserver.com -> thats all.

by the way. If you are using SSL with ISPC3, you must have a ssl certificate for your server too -> httpS://s1.myserver.com

if you have any more question->feel free to ask!

Olli
__________________
Der neue Luxus heit Zeit, nicht Geld!

Firma : http://www.muv.com, http://www.computerandservice.de
Privat : http://www.vogelor.de
Reply With Quote
  #7  
Old 18th May 2009, 14:30
vogelor vogelor is offline
ISPConfig Developer
 
Join Date: Jan 2007
Location: Wernau, Germany
Posts: 219
Thanks: 42
Thanked 34 Times in 24 Posts
Default

Quote:
Originally Posted by Horfic View Post
You have to do for every domain this:
Code:
cd /var/www/{your Domain without www.}/web/
ln -s /var/www/phpmyadmin phpmyadmin

NO - NOT FOR EVERY DOMAIN! FOR THE SERVER ONLY!!!! see my post below
__________________
Der neue Luxus heit Zeit, nicht Geld!

Firma : http://www.muv.com, http://www.computerandservice.de
Privat : http://www.vogelor.de
Reply With Quote
  #8  
Old 16th July 2009, 02:13
F4LLEN F4LLEN is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vogelor View Post
Hi,
i am Oliver, the "programmer" of the phpmyadmin link inside ISPC3.

if you click on such a link, i am looking for the SERVER, the database is running at (for example server #1). Then i am looking in the server-configuration for the "name", this server has (for example s001.muv-server.com). Then i create a link to the phpmyadmin at this server.

means (for this example)

http://s001.muv-server.com/phpmyadmin

this means, you only have to "create" a working phpmyadmin under your server (NOT under EVERY doamain!).

if your server is called s1.myserver.com than you need a pypmyadmin under s1.myserver.com -> thats all.

by the way. If you are using SSL with ISPC3, you must have a ssl certificate for your server too -> httpS://s1.myserver.com

if you have any more question->feel free to ask!

Olli
Hi Olli, im relatively new to ISP Config, ive managed to fully install it and have working client sites, but i cant seem to get phpmyadmin or webmail working, all i gte is a not found. Are you able to give me a slightly more detailed explanation of how youve set it up to work, so i can go through how mine is setup and make the neccessary changes. im really not sure where i went wrong as i followed the Debian Perfect Server tutorial perfectly.

Cheers
Reply With Quote
  #9  
Old 18th July 2009, 11:15
cobro cobro is offline
Member
 
Join Date: Apr 2008
Location: Right here
Posts: 43
Thanks: 22
Thanked 2 Times in 1 Post
Default

I get this error when i try to connect to phpmyadmin or webmail -->



Forbidden

You don't have permission to access /phpmyadmin on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the reques



and webmail error -->



Forbidden

You don't have permission to access /webmail on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Reply With Quote
  #10  
Old 18th July 2009, 12:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
 
Default

You can use this only with mod_php or cgi-php without suexec or fcgi-php without suexec. Thats why we did not implement something like that by default, it simply does not work with 50% of the possible settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
phpmyadmin ispconfig3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHPMyadmin not work thenicespider Installation/Configuration 26 11th October 2010 14:59
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Phpmyadmin issue (Virtual Users And Domains With Postfix, Courier And MySQL ) tonkyman HOWTO-Related Questions 2 21st October 2008 15:27
phpMyAdmin goes PHP5 & MySQL5 Hans General 5 28th September 2008 20:46
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52


All times are GMT +2. The time now is 03:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.