Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th May 2011, 23:48
strowi strowi is offline
Junior Member
 
Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Multiserver Install + cron + mta

Hi,

i am currently testing a multiserver install with dedicated web/mail/db/ns1/ns2 setup.
I basically followed the debian-tutorial found on howtoforge... but still got a few questions:

1. during installation it seems there is no cron-daemon installed, would i need to install one on every server (which i would guess) or only on the main-server (which would do some voodoo to update the others)?
2. if i need to install a cron on every server, is sendmail good enough as an mta for the cron (except postfix on the mail-server)?/Is there a specific configuration, so cron-mails do really get delivered to the correct admin-adress and not local root?

thx for the help,
strowi
Reply With Quote
Sponsored Links
  #2  
Old 18th May 2011, 11:10
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,568
Thanks: 791
Thanked 4,979 Times in 3,900 Posts
Default

1) Cron is normally installed on every Linux system by default (e.g. in the basic setup of the perfect server guides that is mentioned in the multiserver setup guides), thats why it is not mentioned separately. If you excluded or removed cron on your base setup, then you will have to install cron before you install ispconfig.

2) Sendmail should be ok. Cron emails will get delivered to the local accounts. But ispconfig dont use cron emails, it uses a logfile instead, so this applies only to your own cron jobs.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th May 2011, 11:40
strowi strowi is offline
Junior Member
 
Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

hi Till,

thx for the quick reply!


1) I thought so too, but couldn't find any cron installed.. maybe i made a mistake with debootstrap or the template i used..

2)thx for clarification! because installing cron manually tried to pull exim-light as dependency.. which seems a little overkill


This morning the questions seem ... silly... maybe it was too late last night, thx again!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPC cron log: "sh: repquota: command not found" in VM nodes of multiserver serup. CSsab Installation/Configuration 3 14th July 2011 09:01
update services on ubuntu kwickcut HOWTO-Related Questions 3 12th February 2011 01:45
Frustrated with ISPConfig Install V2.2.29 bcaza Installation/Configuration 16 10th March 2009 10:39
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
/usr/bin/make install install HTML::Parser -- NOT OK oddo Installation/Configuration 4 14th March 2006 18:32


All times are GMT +2. The time now is 13:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.