Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th May 2011, 15:31
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default Incoming mail stuck in queue

Up until last night, my server has been working beautifully (ISPConfig3, Centos 5 etc).

However today it appears all incoming mail is getting stuck in the queue and is marked "(temporary failure)".

I can't spot anything in the mail logs to identify the problem.

How should I go about solving the problem?

Mail software: postfix & dovecot.

(My users are getting fidgety!)

I have restarted postfix, dovecot and amavisd : all started without problem.
Reply With Quote
Sponsored Links
  #2  
Old 18th May 2011, 16:19
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

I've now found this in my mail logs:

deliver(john@xxxxxxxx.co.uk): Module is for different version 1.2.16: /usr/lib/dovecot/lda/lib90_sieve_plugin.so

So I guess I've had an automatic update of dovecot and have an incompatible sieve plugin.

Mail server configuation is a black art to me ... so what's the quickest fix?

Is it safe to temporarily disable sieve?

Whether it is or not I have just edited my dovecot.conf to remove sieve from the pop3 plugins and restarted dovecot. All the mail immediately came tumbling through. Users now happy!

BUT how do I fix the sieve incompatability?
Reply With Quote
  #3  
Old 18th May 2011, 21:26
Lionheart82 Lionheart82 is offline
Member
 
Join Date: May 2011
Posts: 40
Thanks: 3
Thanked 4 Times in 4 Posts
Default

i do seem to have the same problem after an php 5.1 to 5.3 yum update...
If i find something i ll tell you, so far only relative post from google i have found is this one...
http://comments.gmane.org/gmane.mail.imap.dovecot/53605 good luck!
Reply With Quote
The Following User Says Thank You to Lionheart82 For This Useful Post:
mike_p (20th May 2011)
  #4  
Old 20th May 2011, 00:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

What's your dovecot version now? ISPConfig 3 does not support dovecot 2.x, only 1.x.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th May 2011, 08:12
Lionheart82 Lionheart82 is offline
Member
 
Join Date: May 2011
Posts: 40
Thanks: 3
Thanked 4 Times in 4 Posts
Default

I have found the problem see here bottom page (http://www.howtoforge.com/perfect-se...ispconfig-3-p4) but not the sollution yet... it seems that atrpms upgraded dovecot from 1.2.16 into 1.2.17 and now dovecot-sieve does not support it... so we either wait for a sieve upgraded version or we recompile it (dont know how yet).

If anyone has a sollution please say so

Edit: Is there a way to downgrade dovecot-sieve?(i mean version 1.2.16) i cannot find it from atrpms repo its removed...

Last edited by Lionheart82; 20th May 2011 at 09:13.
Reply With Quote
  #6  
Old 20th May 2011, 08:31
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

Lionheart appears to have identified the precise problem.

My current dovecot version is 1.2.17

As I said, by disabling sieve in the dovecot.conf, I have got my mail flowing correctly.
If dovecot[/-sieve 1.2.17] has been removed from the atrpms repo, maybe they're aware of the problem?

Last edited by mike_p; 20th May 2011 at 08:35.
Reply With Quote
  #7  
Old 20th May 2011, 08:52
Lionheart82 Lionheart82 is offline
Member
 
Join Date: May 2011
Posts: 40
Thanks: 3
Thanked 4 Times in 4 Posts
Default

i have edited my post above, i meant version 1.2.16 for downgrade.
Now also in atrpms i saw this post...

http://lists.atrpms.net/pipermail/at...ay/012644.html
Meaning it is know to them.

Last edited by Lionheart82; 20th May 2011 at 09:13.
Reply With Quote
  #8  
Old 20th May 2011, 09:04
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

Quote:
Originally Posted by Lionheart82 View Post
i have edited my post above, i meant version 1.1.16 for downgrade.
.. and I presume you mean 1.2.16 ...
Reply With Quote
The Following User Says Thank You to mike_p For This Useful Post:
Lionheart82 (20th May 2011)
  #9  
Old 21st May 2011, 13:09
saptaru saptaru is offline
Junior Member
 
Join Date: May 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Cool Solution - downgrade to Version 1.2.16

Hi all,

I have found the solution in order to fix this. The problem is that the lib90-... is not compatible with Version 1.2.17, so in order to solve this I installed dovecot again from rpms like this :

PLEASE BACK UP ALL YOUR DATA LIKE dovecot.conf and dovecot-sql.conf (you might want to search and backup also dovecot.conf.rpmsave) from /etc/

first is to stop dovecot: /etc/ini.d/dovecot stop

remove dovecot without dependencies: rpm -e --nodeps dovecot

cd /tmp

download it : wget http://centos.alt.ru/pub/dovecot/1.2...el5.x86_64.rpm

install from rpms : rpm -i dovecot-1.2.16-1.el5.x86_64.rpm

then edit /etc/dovecot.conf and paste the content from the old dovecot.conf.rpmsave or dovecot.conf depending what is your previous working backup version.

/etc/init.d/dovecot start
Reply With Quote
The Following User Says Thank You to saptaru For This Useful Post:
mlz (8th June 2011)
  #10  
Old 21st May 2011, 13:16
Lionheart82 Lionheart82 is offline
Member
 
Join Date: May 2011
Posts: 40
Thanks: 3
Thanked 4 Times in 4 Posts
 
Default

Thank you, it seems that the new sieve plugin 1.2.19 is ready http://hg.rename-it.nl/dovecot-1.2-sieve/summary .. all is left is to become available or you can compile it...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
installing squirrelmail on Debian with ispconfig3 saco721 Installation/Configuration 18 1st April 2011 17:57
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 16:27
procmail can't write Hellbound General 27 8th June 2009 21:51
postfix, pop3 uvbnserved Server Operation 22 24th May 2009 21:00
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 06:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.