Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st July 2006, 03:19
lt_wentoncha lt_wentoncha is offline
Junior Member
 
Join Date: Jul 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect 10.1 SuSE setup - postfix

Hi all,

I'm having problems with postfix. Now, it says it can't connect to the mysql database through localhost...but I can through phpmyadmin. None of the services in masterconfig is running in chroot, and the mysql-transport.cf file is, I think, correct.

BTW I'm not using ISP Config, just squirrelmail, but I don't think that makes a difference with this problem.

MY_DOMAIN is substituted
Code:
 30 18:10:25 localhost postfix/smtpd[23464]: warning: problem talking to service rewrite: Connection reset by peer
Jun 30 18:10:25 localhost postfix/master[4840]: warning: process /usr/libexec/postfix/trivial-rewrite pid 26385 exit status 1
Jun 30 18:10:25 localhost postfix/pickup[26301]: AE7BABE9BF: uid=0 from=<root>
Jun 30 18:10:25 localhost postfix/master[4840]: warning: process /usr/libexec/postfix/trivial-rewrite pid 26386 exit status 1
Jun 30 18:10:25 localhost postfix/master[4840]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling
Jun 30 18:10:25 localhost postfix/qmgr[26364]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
Jun 30 18:10:25 localhost postfix/qmgr[26364]: warning: problem talking to service rewrite: Success
Jun 30 18:10:25 localhost postfix/trivial-rewrite[26387]: warning: connect to mysql server localhost: Access denied for user 'mail'@'localhost' (using passwo$
Jun 30 18:10:25 localhost postfix/cleanup[25632]: warning: AE7BABE9BF: virtual_alias_maps map lookup problem for root@MY_DOMAIN
Jun 30 18:10:25 localhost postfix/pickup[26301]: warning: maildrop/2CAD8BE9D5: Error writing message file
Jun 30 18:10:26 localhost postfix/trivial-rewrite[26387]: fatal: mysql:/etc/postfix/mysql-transport.cf(0,100): table lookup problem
Jun 30 18:10:26 localhost postfix/pickup[26301]: C1BA1BE9BF: uid=0 from=<root>
Jun 30 18:10:27 localhost postfix/cleanup[25632]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
Jun 30 18:10:27 localhost postfix/cleanup[25632]: warning: problem talking to service rewrite: Connection reset by peer
Jun 30 18:10:27 localhost postfix/smtpd[24534]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
Jun 30 18:10:27 localhost postfix/smtpd[24534]: warning: problem talking to service rewrite: Success
Jun 30 18:10:27 localhost postfix/master[4840]: warning: process /usr/libexec/postfix/trivial-rewrite pid 26387 exit status 1
Any help would be most welcomed.
Reply With Quote
Sponsored Links
  #2  
Old 1st July 2006, 06:12
lt_wentoncha lt_wentoncha is offline
Junior Member
 
Join Date: Jul 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just went through flishing mysql privileges and checking for whitespace in authmysqlrc and restarting all daemons...still no go
Reply With Quote
  #3  
Old 1st July 2006, 08:05
lt_wentoncha lt_wentoncha is offline
Junior Member
 
Join Date: Jul 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, whelp, I fixed the problem....fatigue set in and I just wasn't reading that the password to access the db was wrong in some instances. Now, this error is vexing me:

Code:
Jun 30 22:17:52 localhost imapd: authentication error: Input/output error
Jun 30 22:23:35 localhost imapd: authentication error: Input/output error
Jun 30 22:31:43 localhost imapd: authentication error: Input/output error
Jun 30 22:39:11 localhost imapd: authentication error: Input/output error
Jun 30 22:43:37 localhost imapd: authentication error: Input/output error
Jun 30 22:49:39 localhost imapd: authentication error: Input/output error
Jun 30 22:54:42 localhost last message repeated 2 times
Jun 30 22:55:46 localhost imapd: authentication error: Input/output error
Again, any help would be most welcomed. Thanks.
Reply With Quote
  #4  
Old 1st July 2006, 08:43
lt_wentoncha lt_wentoncha is offline
Junior Member
 
Join Date: Jul 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok,

I get this error after trying to telnet localhost 143
a login myaccount@domain.com mypassword
BYE Temporary problem, please try again later

In looking @ the c code for courier-imap, I noticed that the the function that produces that error occurs when the value rc=0. rc is set by rc=auth_callback_default(ainfo);, which in turn returns 1 if the value of some pointers are not null, namelt uid and gid. I'm assuming this is the uid/gid values in postfix_users in the postfix db. So what values should uid/gid reflect?

Thanks.

I'm reasonably sure authdaemon is running:

Code:
 ps -ef | grep authdaemon
root     23429     1  0 14:44 ?        00:00:00 /usr/local/sbin/courierlogger -pid=/usr/local/var/spool/authdaemon/pid -start /usr/local/libexec/courier-authlib/authdaemond
root     23430 23429  0 14:44 ?        00:00:00 /usr/local/libexec/courier-authlib/authdaemond
root     30278 23430  0 23:25 ?        00:00:00 /usr/local/libexec/courier-authlib/authdaemond
root     30279 23430  0 23:25 ?        00:00:00 /usr/local/libexec/courier-authlib/authdaemond
root     30280 23430  0 23:25 ?        00:00:00 /usr/local/libexec/courier-authlib/authdaemond
root     30281 23430  0 23:25 ?        00:00:00 /usr/local/libexec/courier-authlib/authdaemond
root     30282 23430  0 23:25 ?        00:00:00 /usr/local/libexec/courier-authlib/authdaemond
root     30510 28452  0 23:44 pts/1    00:00:00 grep authdaemon
Reply With Quote
  #5  
Old 2nd July 2006, 17:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by lt_wentoncha
I'm assuming this is the uid/gid values in postfix_users in the postfix db. So what values should uid/gid reflect?
Did you have a look at this tutorial? http://www.howtoforge.com/virtual_po..._quota_courier
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect Setup SuSE 10 djinn Server Operation 1 18th April 2006 11:11
Is there also a Perfect Setup for SuSE 9.1 bluegrass Installation/Configuration 7 18th January 2006 17:16
The perfect Setup Suse 10 RC1 ispconfig won't create postfix users! fatum112 HOWTO-Related Questions 1 14th January 2006 14:25
The Perfect Setup - SUSE 9.3 (firewall?!) bogdinator HOWTO-Related Questions 7 12th December 2005 12:31
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 22:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.