Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st May 2011, 06:46
appleoddity appleoddity is offline
Junior Member
 
Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Unknown recipients not rejected in alias domain

Hello all.

I'm running ISPConfig 3 on Ubuntu 10.

I used the perfect setup tutorial to install the entire system.

The problem I realized today is that mail sent to an alias domain (i.e. @somedomain forwards to @newsomedomain) is not blocked even though the recipient does not exist in the forwarded domain.

Mail is rejected for unknown recipients in the real domain.

No bounce message is generated though.

Looking in the mail.log I see the mail to the invalid recipient being queued and delivered via maildrop.

The problem is I need e-mail that is addressed to person@somedomain to be rejected, if person@newsomedomain does not exist. I have an upstream spam filter that is generating quarantines for invalid recipients because of this.

Thanks for your help.
Reply With Quote
Sponsored Links
  #2  
Old 10th May 2011, 13:05
Wojtek1 Wojtek1 is offline
Member
 
Join Date: Sep 2008
Posts: 36
Thanks: 1
Thanked 5 Times in 3 Posts
Default

same problem ...
maildrop creating new directories for any address, so after some time is little mess in /var/vmail/newsomedomain/
Reply With Quote
  #3  
Old 10th May 2011, 13:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Thats a known problem on courier setups, please see bugtracker. Possible solutions are described in the bugtracker too:

http://bugtracker.ispconfig.org/inde...1393&project=3
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 10th May 2011, 13:27
Wojtek1 Wojtek1 is offline
Member
 
Join Date: Sep 2008
Posts: 36
Thanks: 1
Thanked 5 Times in 3 Posts
Default

thanks for advice !
Reply With Quote
  #5  
Old 10th May 2011, 16:35
appleoddity appleoddity is offline
Junior Member
 
Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Thats a known problem on courier setups, please see bugtracker. Possible solutions are described in the bugtracker too:

http://bugtracker.ispconfig.org/inde...1393&project=3
Thanks for the reply. I looked at the bugtracker. I even registered. But, it appears the post is cut off? I can't seem to figure out how to display the rest of the content.
Reply With Quote
  #6  
Old 10th May 2011, 19:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

I've added the missing part of the last sentence.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 10th May 2011, 19:57
appleoddity appleoddity is offline
Junior Member
 
Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
I've added the missing part of the last sentence.
Thanks.

I guess the question is, is there anyway to block these invalid e-mail addresses at the Postfix level?

My biggest issue is because Postfix accepts the invalid e-mail address, it causes my upstream spamfilter to also think it is valid and thus creates quarantines for non-existent e-mail addresses.

I would like postfix to reply with a reject message like it does for other invalid e-mail addresses.

Maybe I should I post this in a Postfix support forum?
Reply With Quote
  #8  
Old 10th May 2011, 20:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Quote:
I guess the question is, is there anyway to block these invalid e-mail addresses at the Postfix level?
See link in the last bugtracker post.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 11th May 2011, 00:47
appleoddity appleoddity is offline
Junior Member
 
Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I can appreciate that. Except I don't speak German and when I try to translate it I can't make heads or tails of what is actually being said.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 23:58
mail authentication failure - unknown user or password evok Installation/Configuration 9 16th October 2010 07:37
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 15:49
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 15:22
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 08:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.