Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd April 2011, 15:55
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 224
Thanks: 11
Thanked 10 Times in 10 Posts
Default Server Hangs Every Thursday Night at 11:26pm

I have a Debian server that for the last three Thursday nights, has hung at 11:26pm.

There is nothing in the syslog

Apr 21 22:26:01 server1 /USR/SBIN/CRON[31391]: (root) CMD (/cron/liveice_cron.txt >> /dev/null 2>&1)
Apr 22 05:47:05 server1 kernel: imklog 3.18.6, log source = /proc/kmsg started.


The liveice cron job runs every five minutes...so that isn't the issue.

Is there anywhere else I can look for a log that may show what is happening?
Reply With Quote
Sponsored Links
  #2  
Old 24th April 2011, 12:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you check the cron logs in /etc/cron.weekly/?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 24th April 2011, 17:51
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 224
Thanks: 11
Thanked 10 Times in 10 Posts
Default

No logs there...just a man-db file.

Quote:
#!/bin/sh
#
# man-db cron weekly

set -e

if ! [ -d /var/cache/man ]; then
# Recover from deletion, per FHS.
mkdir -p /var/cache/man
chown man:root /var/cache/man || true
chmod 2755 /var/cache/man
fi

# regenerate man database
if [ -x /usr/bin/mandb ]; then
# --pidfile /dev/null so it always starts; mandb isn't really a daemon,
# but we want to start it like one.
start-stop-daemon --start --pidfile /dev/null \
--startas /usr/bin/mandb --oknodo --chuid man \
-- --quiet
fi

exit 0
Reply With Quote
  #4  
Old 28th April 2011, 09:57
net-help.dk net-help.dk is offline
Junior Member
 
Join Date: Apr 2011
Location: Denmark
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
Default

hung as in system not responding for at short periode of time or do you have to do something to help the server "recover" ?

Do you have any graph off your system load CPU, MEM, DISK ?
Are you aware off any changes on the server 3 weeks ago ?
Reply With Quote
  #5  
Old 28th April 2011, 18:32
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 224
Thanks: 11
Thanked 10 Times in 10 Posts
Default

I have to manually press the reset button...the server does not respond to any ssh or keyboard commands.

I don't have monit or munin running on this server. I'll try to get it installed before tonight to see what's up.
Reply With Quote
  #6  
Old 29th April 2011, 07:17
net-help.dk net-help.dk is offline
Junior Member
 
Join Date: Apr 2011
Location: Denmark
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Are you able to see whats on the server's screen when it hangs, before you hit the reset buttom ?

Are there any sign on kernel panic ?

Are you able to ping the server from an external machine or does it stop completely responding ?
Reply With Quote
  #7  
Old 29th April 2011, 07:19
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 224
Thanks: 11
Thanked 10 Times in 10 Posts
Default

The screen is black...and it doesn't respond to anything.

I didn't get time to install monit today...which means I'll have a week to get it done before it hangs again...which should happen tonight.
Reply With Quote
  #8  
Old 29th April 2011, 07:38
net-help.dk net-help.dk is offline
Junior Member
 
Join Date: Apr 2011
Location: Denmark
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
Default

i'm starting to think "hardware issue"
but lets see what your graphs are showing ?

when was the server last updatet ?
Reply With Quote
  #9  
Old 29th April 2011, 15:43
bschultz bschultz is offline
Senior Member
 
Join Date: Jul 2006
Posts: 224
Thanks: 11
Thanked 10 Times in 10 Posts
 
Default

And oddly enough, the server didn't hang last night!!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
User unknown in relay recipient table Taxick Installation/Configuration 12 9th April 2013 13:31
Centos5.4/ISPConfig 3--Virtual site not working MichaelCaditz Installation/Configuration 25 25th March 2011 12:37
SSL don't work please help me walner8080 Installation/Configuration 8 26th September 2010 13:07
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 17:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.