Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th April 2011, 00:56
krambiorix krambiorix is offline
Junior Member
 
Join Date: Apr 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Ubuntu 10.04 Syntax error in php5.conf (ISPC 2)

Hi guys,

first of all, great work, nice product!

When i try to restart apache from a fresh install, i get Syntax error on line 3 of /etc/apache2/mods-enabled/php5.conf: SetHandler takes one argument, a handler name that overrides any other configured handler ...fail!

This is my php5.conf :

<IfModule mod_php5.c>
<FilesMatch "\.ph(p3?|tml)$">
SetHandler ##ISPConfig INSTALL## application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler ##ISPConfig INSTALL## application/x-httpd-php-source
</FilesMatch>
# To re-enable php in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.
<IfModule mod_userdir.c>
<Directory /home/*/public_html>
php_admin_value engine Off
</Directory>
</IfModule>
</IfModule>
~
Thanks for the help
Reply With Quote
Sponsored Links
  #2  
Old 28th April 2011, 16:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Modify the file as follows and restart Apache:


Code:
<IfModule mod_php5.c>
<FilesMatch "\.ph(p3?|tml)$">
##ISPConfig INSTALL## SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
##ISPConfig INSTALL## SetHandler application/x-httpd-php-source
</FilesMatch>
# To re-enable php in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.
<IfModule mod_userdir.c>
<Directory /home/*/public_html>
php_admin_value engine Off
</Directory>
</IfModule>
</IfModule>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th April 2011, 16:22
krambiorix krambiorix is offline
Junior Member
 
Join Date: Apr 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Falko,

i reinstalled everything and now it works.

Thx for your time!
Reply With Quote
Reply

Bookmarks

Tags
php5.conf, syntax error, ubuntu 10.04

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 21:31
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 14:49
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 04:38
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 19:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 5th October 2005 00:53


All times are GMT +2. The time now is 06:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.