Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th April 2011, 20:21
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
Default Mail Authentication fails in OSX on port 465

I've been stumbling upon this for a few days now. I use OSX Mail and somehow I just can't configure it to work with my Debian Squeeze with ISPConfig 3.

Problem:
ISP blocks port 25
So I try to connect through 465
And yes I want a secure connection...

What I've done:
Decomment in /etc/postfix/master.cf
Code:
smtps     inet  n       -       -       -       -       smtpd
Restart postfix

Enable firewall port 465

Checked telnet, outcome on port 465:
Code:
Escape character is '^]'.
220 vps.domain.com ESMTP Postfix (Debian/GNU)
ehlo localhost
250-vps.domain.com
250-PIPELINING
250-SIZE
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
Seems okay right? But OSX mail keeps complaining it cannot reach the server. Mail retrieval is possible. In both cases I use mail.domain.com (IMAP and SMTP.

So different operating system then... Ubuntu 10.10 mail client (Evolution). It works but only if I use TLS.

Back to OSX.. nope.. doesn't work. I've already specified to use port 465 on Advanced settings. But just can't figure it out. I've even done a full reboot of the server... enabled/disables ssh, but no luck so far. Pleeezz help , how do I configure my server OSX Mail also works.

Last edited by JeffryL; 11th April 2011 at 20:40.
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2011, 13:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Are there any errors in your mail log (in the /var/log/ directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th April 2011, 20:20
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
Default

Hi Falko, thank u for replying. I did find these messages today in mail.log:
Code:
Apr 12 17:57:35 vps postfix/smtpd[32323]: connect from isp.domain.com[xxx.xxx.xxx.xxx]
Apr 12 18:02:35 vps postfix/smtpd[32323]: lost connection after UNKNOWN from isp.domain.com[xxx.xxx.xxx.xxx]
Apr 12 18:02:35 vps postfix/smtpd[32323]: disconnect from isp.domain.com[xxx.xxx.xxx.xxx]
As follows from the timestamp the second and third message appear only after OSX Mail end because of a time-out. The telnet connect and ehlo localhost and quit appear normally.

In the working Ubuntu the following appears:
Code:
Apr 12 18:26:13 VPS postfix/smtpd[596]: connect from isp.domain.com[xxx.xxx.xxx.xxx]
Apr 12 18:26:14 VPS postfix/smtpd[596]: 38A839C511: client=isp.domain.com[xxx.xxx.xxx.xxx], sasl_method=PLAIN, sasl_username=info@mail.nl
Apr 12 18:26:14 VPS postfix/cleanup[599]: 38A839C511: message-id=<1302632771.1498.0.camel@user-VirtualBox>
Apr 12 18:26:14 VPS postfix/qmgr[2023]: 38A839C511: from=<info@mail.nl>, size=928, nrcpt=1 (queue active)
Apr 12 18:26:15 VPS postfix/smtpd[596]: disconnect from isp.domain.com[xxx.xxx.xxx.xxx]
Apr 12 18:26:15 VPS postfix/smtp[601]: 38A839C511: to=<recipient@mail.nl>, relay=ASPMX.L.GOOGLE.COM[xxx.xxx.xxx.xxx]:25, delay=1.6, delays=0.25/0.01/0.13/1.2, dsn=2.0.0, status=sent (250 2.0.0 OK 1302632774 p50si16587853eei.98)
Apr 12 18:26:15 vps1042 postfix/qmgr[2023]: 38A839C511: removed
And what I did was disable the virusscanner (before using mail) by editing main.cf and commenting:
Code:
#content_filter = amavis:[127.0.0.1]:10024
#receive_override_options = no_address_mappings
And in master.cf:
Code:
#amavis unix - - - - 2 smtp
#        -o smtp_data_done_timeout=1200
#        -o smtp_send_xforward_command=yes

#127.0.0.1:10025 inet n - - - - smtpd
#        -o content_filter=
#        -o local_recipient_maps=
#        -o relay_recipient_maps=
#        -o smtpd_restriction_classes=
#        -o smtpd_client_restrictions=
#        -o smtpd_helo_restrictions=
#        -o smtpd_sender_restrictions=
#        -o smtpd_recipient_restrictions=permit_mynetworks,reject
#        -o mynetworks=127.0.0.0/8
#        -o strict_rfc821_envelopes=yes
#        -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
#        -o smtpd_bind_address=127.0.0.1
But I don´t think that´s the problem since everything works in Ubuntu right?

And last but not least an error appeared while figuring this error out when connecting to the server for incoming mail (pop/imap), which was solved by installing gamin instead of fam.

Last edited by JeffryL; 12th April 2011 at 20:49.
Reply With Quote
  #4  
Old 17th April 2011, 11:59
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
Default

Tried it with a ubuntu 10.04/ISP3 setup, but this results in the same problem. It's gotta be something with OSX Mail that is not working very well. But I just can't find out what the problem is.

Isn't it strange a connection pops up, but nothing seems to happen while everything seems configured allright?

Any thoughts on this are appreciated!
Reply With Quote
  #5  
Old 18th April 2011, 08:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Hm, I have no idea... Unfortunately I don't have a Mac to test.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
JeffryL (18th April 2011)
  #6  
Old 23rd April 2011, 10:22
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
 
Default

Ok the solution was not that hard... I also had to uncomment the following lines in master.cf for OSX Mail to work.

Code:
smtps     inet  n       -       n       -       -       smtpd
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
Still, I haven't got a clue why it did work in Ubuntu and not in OSX Mail. So if someone has any ideas about this, share them

Last edited by JeffryL; 23rd April 2011 at 10:40.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Undelivered Mail Returned to Sender djmixx07 Server Operation 27 18th June 2010 12:57
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
postfix, pop3 uvbnserved Server Operation 22 24th May 2009 21:00
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 16:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.