#1  
Old 19th April 2011, 03:07
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default Sites aren't showing up

All of a sudden my sites aren't showing up when I go to the url. My server sits in my closet. My ip hasn't changed. Nothing at the registrar seems out of the ordinary. I have rebooted the machine (old windows habit).

I can get to the admin panel and nothing seems out of the ordinary. I ran a traceroute and it seems to get through my isp and choke at my house. I have checked my router and everything seems okay there.

Any advice on how to trace down this issue?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 19th April 2011, 14:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Any errors in Apache's error log? Is Apache running? What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th April 2011, 14:52
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default here's the output

Falko,

Not sure how to copy and paste this in an elegant form.



tcp 0 0 localhost.localdo:10024 *:* LISTEN 2218/amavisd (maste
tcp 0 0 localhost.localdo:10025 *:* LISTEN 3123/master
tcp 0 0 *:mysql *:* LISTEN 2293/mysqld
tcp 0 0 localhost.localdo:spamd *:* LISTEN 2350/spamd.pid
tcp 0 0 *:ftp *:* LISTEN 3137/pure-ftpd (SER
tcp 0 0 *:ssh *:* LISTEN 2164/sshd
tcp 0 0 *:smtp *:* LISTEN 3123/master
tcp 0 148 192.168.1.99:ssh 192.168.1.25:54798 ESTABLISHED 20317/sshd: shawn [
tcp 0 0 localhost.localdo:mysql localhost.localdo:60253 ESTABLISHED 2293/mysqld
tcp 0 0 localhost.localdo:60253 localhost.localdo:mysql ESTABLISHED 2346/amavisd (ch3-a
tcp6 0 0 [::]:imaps [::]:* LISTEN 3009/couriertcpd
tcp6 0 0 [::]op3s [::]:* LISTEN 3047/couriertcpd
tcp6 0 0 [::]op3 [::]:* LISTEN 3025/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 2982/couriertcpd
tcp6 0 0 [::]:http-alt [::]:* LISTEN 359/apache2
tcp6 0 0 [::]:www [::]:* LISTEN 359/apache2
tcp6 0 0 [::]:tproxy [::]:* LISTEN 359/apache2
tcp6 0 0 [::]:ftp [::]:* LISTEN 3137/pure-ftpd (SER
tcp6 0 0 [::]:ssh [::]:* LISTEN 2164/sshd
tcp6 0 0 [::]:https [::]:* LISTEN 359/apache2



Thanks,
Reply With Quote
  #4  
Old 20th April 2011, 13:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Apache is running. Did you check Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th April 2011, 14:10
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default

I don't know if it is related but in error.log.1 I do see a few errors like this:

/usr/local/ispconfig/interface/web/proxyheader.php' not found or unable to stat

Another idea, is it possible that my local ISP has blocked http requests? Is there a way to check this? I was not getting a lot of traffic.

Thanks,
Reply With Quote
  #6  
Old 21st April 2011, 13:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Did you check the error log in /var/log/apache2/ or /var/log/httpd/?

Quote:
Originally Posted by jopa123 View Post
Another idea, is it possible that my local ISP has blocked http requests? Is there a way to check this? I was not getting a lot of traffic.

Thanks,
Some ISPs block port 80. You should ask your ISP.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 21st April 2011, 21:39
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default

Falko,

There is no folder named httpd in /var/log
However, in the individual site's error log, I see these errors going back to January. The site(s) were working fine until two weeks ago or so.


[Wed Jan 05 16:28:36 2011] [error] [client 220.181.108.121] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/
[Sat Jan 08 18:08:15 2011] [error] [client 220.181.108.101] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/
[Mon Jan 10 21:09:49 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Mon Jan 10 21:09:49 2011] [warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request function
[Mon Jan 10 21:19:36 2011] [warn] mod_fcgid: read data timeout in 360 seconds
[Mon Jan 10 21:19:36 2011] [error] [client 192.168.1.1] Premature end of script headers: index.php
[Mon Jan 10 21:20:00 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Mon Jan 10 21:20:00 2011] [warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request function
[Tue Jan 11 14:02:21 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Tue Jan 11 14:02:21 2011] [warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request function
[Tue Jan 11 14:37:10 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Tue Jan 11 14:37:10 2011] [warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request function
[Thu Jan 13 11:05:57 2011] [error] [client 220.181.108.112] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/
[Sat Jan 15 17:44:19 2011] [error] [client 220.181.108.118] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/
[Mon Jan 17 14:24:34 2011] [error] [client 220.181.108.103] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/
[Fri Jan 21 16:58:49 2011] [error] [client 220.181.108.109] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/
[Tue Feb 01 08:04:21 2011] [warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function
[Fri Feb 25 10:14:44 2011] [error] [client 69.28.58.43] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://mysite.com/install/
[Fri Feb 25 10:14:45 2011] [error] [client 69.28.58.41] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://www.mysite.com/install/
[Thu Mar 03 03:05:22 2011] [warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function
[Fri Mar 04 09:44:41 2011] [warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function
[Sun Mar 06 11:32:49 2011] [error] [client 69.28.58.43] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://mysite.com/install/
[Sun Mar 06 11:32:59 2011] [error] [client 69.28.58.42] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://www.mysite.com/install/
[Tue Mar 08 23:35:40 2011] [error] [client 88.190.13.201] client denied by server configuration: /var/www/mysite.com/web/templates
[Fri Mar 11 12:24:59 2011] [error] [client 69.28.58.41] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://mysite.com/install/
[Fri Mar 11 12:25:07 2011] [error] [client 69.28.58.42] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://www.mysite.com/install/
[Mon Mar 14 11:29:50 2011] [error] [client 69.28.58.41] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://www.mysite.com/install/
[Mon Mar 14 11:29:53 2011] [error] [client 69.28.58.42] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://mysite.com/install/
[Wed Mar 16 03:57:30 2011] [warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function
[Thu Mar 17 13:10:36 2011] [warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function
[Tue Mar 22 14:56:01 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Tue Mar 22 14:56:01 2011] [warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request function
[Wed Mar 30 17:10:36 2011] [error] [client 69.28.58.41] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://mysite.com/install/
[Wed Mar 30 17:10:36 2011] [error] [client 69.28.58.41] Directory index forbidden by Options directive: /var/www/mysite.com/web/install/, referer: http://www.mysite.com/install/


/var/log/apache2:

[Sun Apr 10 06:45:08 2011] [warn] long lost child came home! (pid 22057)
[Mon Apr 11 14:51:14 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Mon Apr 11 14:51:18 2011] [notice] Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.6 with Suhosin-Patch mod_ssl/2.2.11 OpenSSL/0.9.8g configured -- resuming normal operations
[Tue Apr 12 12:56:09 2011] [error] [client 222.187.221.224] script '/usr/local/ispconfig/interface/web/proxy-1.php' not found or unable to stat
[Wed Apr 13 07:13:40 2011] [error] [client 222.187.221.224] script '/usr/local/ispconfig/interface/web/proxyheader.php' not found or unable to stat
[Wed Apr 13 07:51:04 2011] [notice] caught SIGTERM, shutting down
[Wed Apr 13 07:52:16 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Wed Apr 13 07:52:19 2011] [notice] Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.6 with Suhosin-Patch mod_ssl/2.2.11 OpenSSL/0.9.8g configured -- resuming normal operations
[Wed Apr 13 13:22:01 2011] [error] [client 222.187.221.224] script '/usr/local/ispconfig/interface/web/judge123.php' not found or unable to stat
[Wed Apr 13 22:11:13 2011] [error] [client 88.191.74.171] File does not exist: /usr/local/ispconfig/interface/web/redhat.test0
[Wed Apr 13 22:11:13 2011] [error] [client 88.191.74.171] File does not exist: /usr/local/ispconfig/interface/web/index.html
[Wed Apr 13 23:57:25 2011] [error] [client 222.187.221.224] script '/usr/local/ispconfig/interface/web/proxyheader.php' not found or unable to stat
[Thu Apr 14 15:51:58 2011] [error] [client 208.176.53.58] Invalid URI in request GET HTTP/1.1 HTTP/1.1
[Thu Apr 14 15:51:59 2011] [error] [client 208.176.53.58] File does not exist: /usr/local/ispconfig/interface/web/index.html
[Fri Apr 15 10:32:38 2011] [error] [client 222.186.50.11] script '/usr/local/ispconfig/interface/web/proxyheader.php' not found or unable to stat
[Sun Apr 17 06:49:46 2011] [notice] Graceful restart requested, doing restart

BTW, contacted my ISP and they say they do not block any ports. Of course take that with a grain of salt

Thanks
Reply With Quote
  #8  
Old 25th April 2011, 17:53
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default Any ideas?

Is it possible to scan my ports from an internal computer? In other words, can I check to see if my ISP is lying and my http port really is blocked?

BTW, I did a port scan from here:

http://www.t1shopper.com/tools/port-scan/

And it says that http is not responding, but it also says other ports aren't listening and I know that to be untrue.

Thanks.

Last edited by jopa123; 25th April 2011 at 17:57.
Reply With Quote
  #9  
Old 26th April 2011, 15:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by jopa123 View Post
Is it possible to scan my ports from an internal computer? In other words, can I check to see if my ISP is lying and my http port really is blocked?
You, you must do this from a remote computer.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 9th May 2011, 17:41
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
 
Default Solved

Falko and others,

Just FYI. A firmware upgrade of the router solved my issue.

Thanks for the help, though.
Reply With Quote
The Following User Says Thank You to jopa123 For This Useful Post:
falko (10th May 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
vhost Default disabled and other sites showing with 404 error. WeaponX General 2 14th December 2011 21:54
Web Sites Not Showing Up sonicscott Installation/Configuration 2 26th August 2010 09:03
Sites Not Showing on mirror Toucan Installation/Configuration 13 9th June 2010 00:47
New sites added is not showing anymore.. eddie67 General 2 19th May 2009 21:59
new sites not showing in Vhosts_ispconfig.conf DaddyFix Installation/Configuration 17 25th January 2006 11:00


All times are GMT +2. The time now is 18:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.