Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th April 2011, 00:05
tuxic tuxic is offline
Junior Member
 
Join Date: Mar 2011
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Default The Perfect Server - CentOS 5.6 Joomla and Drupal troubles

Hi followed this tutorial and encountered this error when installing CMS like Joomla or Drupal:

Code:
Warning: include() [function.include]: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client3/web5/web:/var/www/clients/client3/web5/tmp:/var/www/site.com/web:/srv/www/site.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in theme_render_template() (line 1234 of/var/www/clients/client3/web5/web/includes/theme.inc).
I doublechecked the PHP open_basedir directive. It contained all the necessay paths so that is not the cause.

I selected suexec and fastcgi. Choosing suphp or modphp doesn't make a difference. After a lot of troubleshooting I removed php-Eaccelerator and the errors dissapeared. Only now php is a lot slower. Is this a bug? Any way around it? I need php caching.

Thx
Reply With Quote
Sponsored Links
  #2  
Old 19th April 2011, 14:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Not sure why this happens, but instead of eAccelerator, you can try Xcache or APC.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th April 2011, 15:04
tuxic tuxic is offline
Junior Member
 
Join Date: Mar 2011
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by falko View Post
Not sure why this happens, but instead of eAccelerator, you can try Xcache or APC.
Thx for your reply Falko, I managed to fix it by installing PHP Eaccelerator from source with the following:

Code:
./configure -enable-eaccelerator=shared -with-php-config=$PHP_PREFIX/bin/php-config -with-eaccelerator-shared-memory -with-eaccelerator-sessions -with-eaccelerator-content-caching -with-eaccelerator-debug -with-libdir=/usr/lib/php/modules/ -exec-prefix=/usr --without-eaccelerator-use-inode
Especially this part is important:
Code:
-exec-prefix=/usr --without-eaccelerator-use-inode
Other options are supposedly to make it play nicely with mod_fcgid

Working all nice now. Thx for the great tutorial.


Tuxic
Reply With Quote
The Following User Says Thank You to tuxic For This Useful Post:
falko (20th April 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail server configuration with "The Perfect Server" for Ubuntu 10.10 SacreBleu Installation/Configuration 16 30th January 2011 01:21
FastCGI PHP and permissions issue on ISPConfig perfect server (opensuse 11.3) wildnux Server Operation 0 28th January 2011 23:03
URGENT PLEASE HELP!!! RE: The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 2 husskii HOWTO-Related Questions 1 6th January 2010 22:45


All times are GMT +2. The time now is 08:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.