#1  
Old 4th August 2011, 19:27
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default webmail url [solved]

I have installed Roundcube, and it is working fine but I have some questions about the url to access them.

I can access from http://clientdomain.com:8080/webmail

Why I need to use port 8080? How can I access without typing port?

How I can do a subdomain for access from http://webmail.clientdomain.com/ to Roundcube? Can I do that it automatically for a new sites ?

I have checked /etc/roundcube/main.inc.php & /etc/roundcube/apache.conf but I haven't seen anything port related.

Last edited by mentes; 6th August 2011 at 19:00.
Reply With Quote
Sponsored Links
  #2  
Old 4th August 2011, 19:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Why I need to use port 8080? How can I access without typing port?
Just remove :8080 from the URL.

Quote:
How I can do a subdomain for access from http://webmail.clientdomain.com/
Create a new website webmail.clientdomain.com and install roundcube into that website.

Quote:
Can I do that it automatically for a new sites ?
No.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th August 2011, 19:35
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

If I remove :8080 I get an ERROR 500 - Internal Server Error!

I don't want install roundcube for each domain. I think I can use http://webmail.clientdomain.com/ using CNAME, but I'm not sure how do that.
Reply With Quote
  #4  
Old 4th August 2011, 19:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
If I remove :8080 I get an ERROR 500 - Internal Server Error!
Check the error.log of the website for the error message.

Quote:
I think I can use http://webmail.clientdomain.com/ using CNAME, but I'm not sure how do that.
CNAME is a dns record, this is required because otherwise the subdomain does not exist, but that not enough to display the website. You will have to add a aliasdomain to that website for every additional domain too.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 4th August 2011, 20:02
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/domain.es/web"
[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] Premature end of script headers: index.php

And I have tried to create a subdomain for redirect to roundcube but doesn't work:

Host: webmail
Domain: clientdomain.com
Redirect Type: R, L
Redirect: Path: http://www.clientdomain.com/webmail/
Active: yes
Reply With Quote
  #6  
Old 4th August 2011, 20:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/domain.es/web"
[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] Premature end of script headers: index.php
Which php mode do you use for that website? And have you added the path /usr/share/roundcube/ to the allowed open_basedir paths of that website?

Quote:
And I have tried to create a subdomain for redirect to roundcube but doesn't work:

Host: webmail
Domain: clientdomain.com
Redirect Type: R, L
Redirect: Path: http://www.clientdomain.com/webmail/
Active: yes
Thats wont work as you acn not reach roundcube at the URL http://www.clientdomain.com/webmail. Please see my description above on how to configure roundcube for that.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 4th August 2011, 20:32
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

I'm trying with all php modes. Fast-CGI usually.

This is the new error when I have added the path to open_basedir

Code:
[Thu Aug 04 20:21:00 2011] [error] [client 81.39.9.247] PHP Warning:  Unknown: open_basedir restriction in effect. File(/usr/share/roundcube/index.php) is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/domain.es/web:/srv/www/domain.es/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in Unknown on line 0
[Thu Aug 04 20:21:00 2011] [error] [client 81.39.9.247] PHP Warning:  Unknown: failed to open stream: Operation not permitted in Unknown on line 0
[Thu Aug 04 20:21:00 2011] [error] [client 81.39.9.247] PHP Fatal error:  Unknown: Failed opening required '/var/lib/roundcube/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0
And now without :8080 doesn't show nothing, with :8080 stil working

Do I need to add the path for each domain ?
Reply With Quote
  #8  
Old 4th August 2011, 22:04
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 90 Times in 68 Posts
Default

You need set aliasdomain. Check it in /etc/roundcube/apache.conf . Alias must point to your roundcube path. Make sure that don't exist already an aliasdomain called webmail ok? And check if exist a symbolic link pointing to /etc/roundcube/apache.conf in /etc/apache2/conf.d (typical location for includes files in ubuntu/debian)

Suerte
Reply With Quote
  #9  
Old 6th August 2011, 13:26
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

If I don't create any "site" I can access through www.domain.com/webmail but when I create a "site" I can access only through www.domain.com:8080/webmail

In www.domain.com/webmail I get Error 500 - Internal Server Error and in /var/www/domain.com/log/error.log I get this:

Code:
[Sat Aug 06 12:37:37 2011] [error] [client 81.202.46.31] SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/domain.com/web"
[Sat Aug 06 12:37:37 2011] [error] [client 81.202.46.31] Premature end of script headers: index.php
[Sat Aug 06 12:37:37 2011] [error] [client 81.202.46.31] File does not exist: /var/www/domain.com/web/favicon.ico, referer: http://domain.com/webmail/
I get the same result and error, with ssl enabled or disabled (if I disable ssl I comment mod_rewrite rules on /etc/roundcube/apache.conf)

I get that error with PHP: Disabled, Fast-CGI and SuPHP

And with CGI, Mod-PHP I get:

Code:
[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Warning:  include(): open_basedir restriction in effect. File(/usr/share/php/PEAR.php) is not within the allowed path(s): (/var/www/clients/client4/web3/web:/var/www/clients/client4/web3/tmp:/var/www/domain.es/web:/srv/www/domain.es/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/roundcube/) in /usr/share/roundcube/program/include/iniset.php on line 99
[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Warning:  include(/usr/share/php/PEAR.php): failed to open stream: Operation not permitted in /usr/share/roundcube/program/include/iniset.php on line 99
[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Warning:  include(): Failed opening 'PEAR.php' for inclusion (include_path='/var/lib/roundcube/:/var/lib/roundcube/program:/var/lib/roundcube/program/lib:/var/lib/roundcube/program/include:.:/usr/share/php:/usr/share/pear') in /usr/share/roundcube/program/include/iniset.php on line 99
[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Fatal error:  Class 'PEAR' not found in /usr/share/roundcube/program/include/iniset.php on line 122
I try adding /usr/share/roundcube/ to open_basedir too.

Note:
I can access to www.domain.com/phpmyadmin always, without typing port.
It's a fresh installation on Debian 6.0.2.1 following "The Perfect Server Howto" step by step carefully.
Reply With Quote
  #10  
Old 6th August 2011, 19:04
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
 
Default

Seems there are a problem between Roundcube & Debian/Ubuntu & SuPHP

http://www.crazysquirrel.com/computi...il-server.jspx

My solution:

root@main:~# a2dismod suphp
Module suphp disabled.

root@main:~# /etc/init.d/apache2 restart
Reply With Quote
The Following 2 Users Say Thank You to mentes For This Useful Post:
falko (7th August 2011), Kozley (23rd October 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horde Groupware Webmail Edition ByteMe Networking Tips/Tricks/Mods 17 20th December 2012 10:12
webmail url blocker General 1 28th November 2008 14:28
website and webmail with same URL hvrossum Installation/Configuration 1 1st January 2008 20:43
Change of URL in Webmail in second domain jofranco General 1 8th May 2006 00:37
Problem with Webmail URL, uses local network and not internet danf.1979 General 8 24th December 2005 16:24


All times are GMT +2. The time now is 22:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.