#1  
Old 18th April 2011, 10:01
adnese adnese is offline
Junior Member
 
Join Date: Nov 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default SASL error after Debian upgrade

Hello Till,

after performing debian stable updates, postfix stopped working properly.
logs:

Apr 18 09:39:37 voradesign postfix/smtpd[1275]: fatal: no SASL authentication mechanisms
Apr 18 09:40:38 voradesign postfix/smtpd[1659]: fatal: no SASL authentication mechanisms
Apr 18 09:40:38 voradesign postfix/smtpd[1661]: fatal: no SASL authentication mechanisms

and

Apr 18 09:54:11 voradesign postfix/smtp[2897]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Apr 18 09:54:11 voradesign postfix/smtp[2897]: 25A051017A: to=<xxxx@gmail.com>, relay=none, delay=379, delays=379/0.03/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

sasl directives in main.cf:

smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth

Any idea how to get the mailserver / sasl working ?

Thank you,

Adrian
Reply With Quote
Sponsored Links
  #2  
Old 18th April 2011, 10:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

download ispconfig 3.0.3.3, unpack it and run update.php script. Choose to reconfigure services during update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th April 2011, 10:28
adnese adnese is offline
Junior Member
 
Join Date: Nov 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hello Till,

it start working again, after restart of postfix and all components (dovecot, amavis). I didn't change anything on the configuration and after half hour of troubleshoot everything became accessible again (webmail login/ user login).

Thanks so far.

Regards,

Adrian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fail2ban + sasl problem and Solution pititis General 1 2nd March 2011 07:02
Cannot login to SquirrelMail sellotape Installation/Configuration 13 26th October 2010 11:03
Mail problem after upgrade to 3.0.2.1 The-Ghost Installation/Configuration 15 11th April 2010 15:37
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57


All times are GMT +2. The time now is 01:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.