Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th April 2011, 12:59
Overcrook Overcrook is offline
Junior Member
 
Join Date: Jan 2010
Posts: 11
Thanks: 3
Thanked 2 Times in 2 Posts
Default [SOLVED] Problem with phpmyadmin after upgrade to 3.0.3.3

Hi,

after my update to 3.0.3.3 I can not open my /phpmyadmin site.

I use phpmyadmin with the ispconfig3 ssl cert.
Therefore I open phpmyadmin with "" https://MY-SERVERIP:8080/phpmyadmin ""

Before the update everything worked fine, but after the update all I get is a " 404 The requested URL /phpmyadmin was not found on this server ".

Please help.

-----

Hm .. okay that is odd.

I looked in my apache2-error.log and found the line:
" File does not exist: /usr/local/ispconfig/interface/web/phpmyadmin "

I don't know why ispconfig3 wants the phpmyadmin files in this folder, but after a symlink everything is working again.

Before the update it was enough to have a symlink in /var/www/ .

I don't know why I got this error, but I'm happy that everything is working again.

Last edited by Overcrook; 16th April 2011 at 13:04. Reason: SOLVED
Reply With Quote
Sponsored Links
  #2  
Old 18th April 2011, 10:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
I don't know why ispconfig3 wants the phpmyadmin files in this folder, but after a symlink everything is working again.
ISPConfig does not wnat phpmyadmin to be there and adding a symlink there is a security risk. So please remove the symlink that you have added there. I guess you have set no or a wrong path to phpmyadmin in system > interface config in ispconfig. It has to be a complete URL starting with http://.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th April 2011, 19:08
Overcrook Overcrook is offline
Junior Member
 
Join Date: Jan 2010
Posts: 11
Thanks: 3
Thanked 2 Times in 2 Posts
 
Default

Thanks Till,

I've removed the symlink. Don't want a security risk with my half-assed solution

But I think that I've found my mistake:

Since I use the SSL-Cert. from ispconfig3 for phpmyadmin I looked again ( for the 100th time ) in the apache2 config files and found something. ^_^

I use this code in my /../ispconfig.vhost:

Code:
SSLEngine On

SSLCertificateFile // MY FILE PATH //

SSLCertificateKeyFile // MY FILE PATH //

SSLProtocol All -SSLv2
SSLCipherSuite ALL:!EXP:!NULL:!ADH:!LOW
SetEnvIf User-Agent “.*MSIE.*” nokeepalive ssl-unclean-shutdown
But after the update the last 3 lines were missing. So I added the lines, and my phpmyadmin works again without the symlink + no errors in my logs.

I don't believe that it has something to do with the update, but anyway everything works fine and I'm happy.

And now I hope that I didn't do something stupid again.

Thanks
Overcrook
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
MySQL Error Nolan Installation/Configuration 12 16th February 2011 02:15
How can I upgrade phpmyadmin ? arastirici Installation/Configuration 1 2nd June 2010 08:52
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52


All times are GMT +2. The time now is 20:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.