Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th October 2013, 13:42
Mazaire Mazaire is offline
Junior Member
 
Join Date: Oct 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Receiving Apache Test page on fresh install.

Hello Howto Forge!

I have recently done a fresh install of ISP config 3.0.5.3 on Centos 6.4. following this guide here;

http://www.howtoforge.com/perfect-se...e2-ispconfig-3

Looks like everything has installed without a hitch. However when navigating to my https://MYIP:8080 it displays the apache test page. (Navigating to the https://MYIP:8080/index.php I am unsurprisingly getting a 404). I would hazard a guess it is an error with the aliasing so here is a tail of the apache conf file (httpd.conf). I have had a look through these files and I cannot see any obvious errors in the 000-ispconfig.vhost or the 000-ispconfig.conf files. I have also tried uninstalling and re-installing ISPConfig as well as a an update. Haven't tried a clean install for an older version however.

ispconfig Alias
Code:
 
#    DocumentRoot /www/docs/dummy-host.example.com                                                    
#    ServerName dummy-host.example.com                                                                
#    ErrorLog logs/dummy-host.example.com-error_log                                                   
#    CustomLog logs/dummy-host.example.com-access_log common                                          
#</VirtualHost>                                                                                       
                                                                                                      
NameVirtualHost *:80                                                                                  
NameVirtualHost *:443                                                                                 
Include /etc/httpd/conf/sites-enabled/
And here is the entire sites enables file for ISP config in sites-enabled.

ispconf
Code:
################################################
# ISPConfig Logfile configuration for vlogger
################################################

LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" /var/log/ispconfig/httpd" combined_ispconfig

<Directory /var/www/clients>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

# Do not allow access to the root file system of the server for security reasons
<Directory />
       AllowOverride None
       Order Deny,Allow
       Deny from all
</Directory>

<Directory /var/www/conf>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

# Except of the following directories that contain website scripts
<Directory /usr/share/phpmyadmin>
        Order allow,deny
        Allow from all
</Directory>

<Directory /usr/share/phpMyAdmin>
        Order allow,deny
        Allow from all
</Directory>

<Directory /usr/share/squirrelmail>
        Order allow,deny
        Allow from all
</Directory>

# allow path to awstats and alias for awstats icons
<Directory /usr/share/awstats>
        Order allow,deny
        Allow from all
</Directory>

Alias /awstats-icon "/usr/share/awstats/icon"

NameVirtualHost *:80
NameVirtualHost *:443

And the one for the isp vhhost file
Code:
######################################################
# This virtual host contains the configuration
# for the ISPConfig controlpanel
######################################################

 Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
  ServerAdmin webmaster@localhost
  
  <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
  </FilesMatch>
  
  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
      Options -Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
    IPCCommTimeout  7200
	MaxRequestLen 15728640
  </IfModule>
  
  <IfModule mpm_itk_module>
    DocumentRoot /usr/local/ispconfig/interface/web/
	AssignUserId ispconfig ispconfig
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
	  php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>
  
  # ErrorLog /var/log/apache2/error.log
  # CustomLog /var/log/apache2/access.log combined
  ServerSignature Off
  
  <IfModule mod_security2.c>
    SecRuleEngine Off
  </IfModule>

  # SSL Configuration
  SSLEngine On
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
  #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>
I have hit a brick wall on this one. Not really sure where to go from here. Any Suggestions are much appreciated!!!
Reply With Quote
Sponsored Links
  #2  
Old 17th January 2014, 23:53
interaxive interaxive is offline
Junior Member
 
Join Date: Jan 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem here...

I'm having the same problem as described above. Installing "Perfect Server" on CentOS 6.5. Some packages had to be updated but everything installed easily, but at the very end ISPConfig Panel does not show -- instead just getting Apache 2 Test Page.

Did you resolve the problem or does anyone else have some insight?
Reply With Quote
  #3  
Old 29th January 2014, 04:14
rkdutta rkdutta is offline
Junior Member
 
Join Date: Jan 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default isp config page not opening

try this

https://111.111.111.111:8080/index.php

replace 111.111.111.111 with your ip address

rkd
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need be Validate - Extras for Perfect Server Debian / Ubuntu Users Wisdown Installation/Configuration 0 1st September 2012 01:07
sessions not being saved gavimobile General 6 15th January 2012 15:05
Apache hangs without traffic Thesee General 21 27th September 2011 23:43
ISPConfig shows Apache 2 Test Page powered by CentOS onastvar Installation/Configuration 1 27th October 2009 15:23
install apache 1.3 on FC 4 superg Server Operation 1 22nd December 2005 17:44


All times are GMT +2. The time now is 22:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.