Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th April 2011, 14:01
soldier soldier is offline
Junior Member
 
Join Date: Apr 2011
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default httpd crashes after installing ISPconfig3

After installing ESP 3 httpd gives error
[root@localhost install]# /etc/init.d/httpd restart
Останавливается httpd: [ СБОЙ ]
Запускается httpd: [Tue Apr 12 08:40:30 2011] [warn] NameVirtualHost *:443 has no VirtualHosts
[Tue Apr 12 08:40:30 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
(13)Permission denied: make_sock: could not bind to address [::]:8081
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
no listening sockets available, shutting down
Unable to open logs

Please help in solving the problem!
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2011, 14:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Seems as if you run already some other software on port 8081. Please check with the command:

netstat -tap

which software uses that port and stop it. Then you should be able to start apache again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th April 2011, 14:15
soldier soldier is offline
Junior Member
 
Join Date: Apr 2011
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

[root@localhost ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdomain:10025 *:* LISTEN 3118/master
tcp 0 0 *:mysql *:* LISTEN 3025/mysqld
tcp 0 0 localhost.local:dyna-access *:* LISTEN 2944/clamd
tcp 0 0 *:sunrpc *:* LISTEN 2665/portmap
tcp 0 0 *:ftp *:* LISTEN 3147/pure-ftpd (SER
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2648/named
tcp 0 0 *:ssh *:* LISTEN 2922/sshd
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2931/cupsd
tcp 0 0 *:con *:* LISTEN 2697/rpc.statd
tcp 0 0 *:smtp *:* LISTEN 3118/master
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2648/named
tcp 0 0 192.168.127.129:38267 ie.freshrpms.net:http TIME_WAIT -
tcp 0 0 192.168.127.129:38266 ie.freshrpms.net:http TIME_WAIT -
tcp 0 0 192.168.127.129:32825 ftp.nara.wide.ad.jp:http TIME_WAIT -
tcp 0 0 192.168.127.129:32824 ftp.nara.wide.ad.jp:http TIME_WAIT -
tcp 0 0 192.168.127.129:60739 mirror.yandex.ru:http TIME_WAIT -
tcp 0 0 192.168.127.129:60742 mirror.yandex.ru:http TIME_WAIT -
tcp 0 0 192.168.127.129:41400 222.122.43.209:http TIME_WAIT -
tcp 0 0 192.168.127.129:41399 222.122.43.209:http TIME_WAIT -
tcp 0 0 192.168.127.129:41398 222.122.43.209:http TIME_WAIT -
tcp 1 0 192.168.127.129:56687 rhlx01.hs-esslingen.de:http CLOSE_WAIT 3625/python
tcp 0 0 192.168.127.129:56678 rhlx01.hs-esslingen.de:http TIME_WAIT -
tcp 0 0 192.168.127.129:49048 211.62.252.36:http TIME_WAIT -
tcp 0 0 192.168.127.129:49049 211.62.252.36:http TIME_WAIT -
tcp 0 0 192.168.127.129:49046 211.62.252.36:http TIME_WAIT -
tcp 0 0 192.168.127.129:50935 server88-208-217-170.l:http TIME_WAIT -
tcp 0 0 192.168.127.129:43260 mandril.creatis.insa-l:http TIME_WAIT -
tcp 0 0 192.168.127.129:56674 centos.servint.net:http TIME_WAIT -
tcp 0 0 192.168.127.129:34517 s334-kt9-sel.cdn1.net:http TIME_WAIT -
tcp 0 0 192.168.127.129:41300 221x247x219x6.ap221.ft:http TIME_WAIT -
tcp 0 0 192.168.127.129:41302 221x247x219x6.ap221.ft:http TIME_WAIT -
tcp 0 0 192.168.127.129:49506 psw32.psw.net:http TIME_WAIT -
tcp 0 0 192.168.127.129:51492 centos-mirror.hostdime:http TIME_WAIT -
tcp 0 0 192.168.127.129:35527 ftp.chg.ru:http TIME_WAIT -
tcp 0 0 192.168.127.129:35522 ftp.chg.ru:http TIME_WAIT -
tcp 0 0 192.168.127.129:60291 earth.corbina.net:http TIME_WAIT -
tcp 0 0 192.168.127.129:60288 earth.corbina.net:http TIME_WAIT -
tcp 0 0 192.168.127.129:60318 earth.corbina.net:http ESTABLISHED 3625/python
tcp 0 0 192.168.127.129:60285 earth.corbina.net:http TIME_WAIT -
tcp 0 0 *:ftp *:* LISTEN 3147/pure-ftpd (SER
tcp 0 0 localhost6.localdoma:domain *:* LISTEN 2648/named
tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 2648/named
[root@localhost ~]#

not software uses port 8081 ?!
Reply With Quote
  #4  
Old 12th April 2011, 14:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

And you accepted the default port 8080 for ispconfig as you installed it? You can not use 8081 for ispconfig interface as this would cause a collision with the ispconfig apps vhost which runs on 8081 already.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th April 2011, 14:54
soldier soldier is offline
Junior Member
 
Join Date: Apr 2011
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yes I spent the installation instructions and accept the default port of 8080.
Reply With Quote
  #6  
Old 12th April 2011, 14:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Is this a virtual server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 12th April 2011, 15:00
soldier soldier is offline
Junior Member
 
Join Date: Apr 2011
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yes, server work in base VMware
Reply With Quote
  #8  
Old 12th April 2011, 16:29
soldier soldier is offline
Junior Member
 
Join Date: Apr 2011
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Shutdown SElinux, error change:
(13)Permission denied: make_sock: could not bind to address [::]:8081
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
----->
(98)Permission denied: make_sock: could not bind to address [::]:8081
(98)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
Reply With Quote
  #9  
Old 13th April 2011, 14:52
soldier soldier is offline
Junior Member
 
Join Date: Apr 2011
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

please suggest any solution to the problem!
Reply With Quote
  #10  
Old 13th April 2011, 16:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
 
Default

You can change the port 8081 in the file /etc/apache2/sites-enabled/000-apps.vhost to a port that is not in use on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Something blocking port 53 stigge2000 Installation/Configuration 4 5th April 2011 14:46
Problems with installing SSL-certifates on ISPConfig3 slaveservers Hans General 4 5th October 2010 12:22
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Problems with installation on openSUSE 10.2 douglaslopezt Installation/Configuration 3 24th August 2007 22:04


All times are GMT +2. The time now is 04:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.