#1  
Old 13th April 2011, 23:22
jribeiro jribeiro is offline
Junior Member
 
Join Date: Mar 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS Not working

Hi there!!

Really sorry to trouble everyone with another dns related issue but I've read numerous threads with no luck...

I have ISPConfig 3 + Centos 5.5.

The domain I'm trying to configure is sostudent.com. Created ns1.sostudent.com and ns2.sostudent.com and assigned to the right ip: 85.139.252.201

The ispconfig is shown in attachement.

However I can't access the domain and the tool intodns says "I could not get any nameservers from your nameservers (the ones listed at the parent server). Please verify that they are not lame nameservers and are configured properly. "

http://www.intodns.com/sostudent.com

I bought the manual but still can't get through this... I'm newbie!

Thanks everyone
Attached Images
 
Reply With Quote
Sponsored Links
  #2  
Old 14th April 2011, 10:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Please run this command on the shell and post the output:

dig @localhost sostudent.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th April 2011, 10:44
jribeiro jribeiro is offline
Junior Member
 
Join Date: Mar 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Please run this command on the shell and post the output:

dig @localhost sostudent.com
Thanks for the reply!!

Result:
; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 <<>> @localhost sostudent.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 51119
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;sostudent.com. IN A

;; Query time: 2214 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Apr 14 08:42:01 2011
;; MSG SIZE rcvd: 31
Reply With Quote
  #4  
Old 14th April 2011, 12:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

restart bind and then check the syslog and messages log file for errors.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 14th April 2011, 14:14
jribeiro jribeiro is offline
Junior Member
 
Join Date: Mar 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks again!! No errors I think. Please check the image bellow
Attached Images
 
Reply With Quote
  #6  
Old 14th April 2011, 17:01
jribeiro jribeiro is offline
Junior Member
 
Join Date: Mar 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi there!!

Some more info...

telnet localhost 53
Responds OK

telnet localip 53
Unable to connect

telnet publicip 53
Unable to connect

This is happens both with ispconfig firewall active and inactive...

What's is going wrong here?? Can anyone help?
Reply With Quote
  #7  
Old 14th April 2011, 17:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Can you post your /var/named/chroot/etc/named.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 14th April 2011, 17:39
jribeiro jribeiro is offline
Junior Member
 
Join Date: Mar 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yup!

Code:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
options {
        listen-on port 53 { 127.0.0.1; };
        listen-on-v6 port 53 { ::1; };
        directory       "/var/named/chroot/var/named";
        dump-file       "/var/named/chroot/var/named/data/cache_dump.db";
        statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
        allow-query     { localhost; };
        recursion yes;
};
logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};
zone "." IN {
        type hint;
        file "named.root";
};
include "/var/named/chroot/etc/named.conf.local";
Followed this tutorial:
http://www.howtoforge.com/perfect-se...ispconfig-3-p5

and addapted it to 32bit version.

Anyway just some extra info... the telnet problem happens with other services like pop.

However the router is propelly configrued. I'm almost 100% positive of that!!

Also I have two nics but the router is only configured for one of them.

Don't know if this extra info helps but anyway...

Thanks!!
Reply With Quote
  #9  
Old 15th April 2011, 00:02
dromney dromney is offline
Junior Member
 
Join Date: Apr 2011
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Similar Issue, except Ubuntu 10.10

I am having a similar issue running Ubuntu 10.10, I have the most up to date ISP Config, and I have kept my Ubuntu up to date. Using BIND, and getting the same response from intodns.com. So I would much appreciate any help on this. Same this with the manual to, not very helpful.
Reply With Quote
  #10  
Old 15th April 2011, 14:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

Quote:
Originally Posted by jribeiro View Post
Yup!

Code:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
options {
        listen-on port 53 { 127.0.0.1; };
        listen-on-v6 port 53 { ::1; };
        directory       "/var/named/chroot/var/named";
        dump-file       "/var/named/chroot/var/named/data/cache_dump.db";
        statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
        allow-query     { localhost; };
        recursion yes;
};
logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};
zone "." IN {
        type hint;
        file "named.root";
};
include "/var/named/chroot/etc/named.conf.local";
Followed this tutorial:
http://www.howtoforge.com/perfect-se...ispconfig-3-p5

and addapted it to 32bit version.

Anyway just some extra info... the telnet problem happens with other services like pop.

However the router is propelly configrued. I'm almost 100% positive of that!!

Also I have two nics but the router is only configured for one of them.

Don't know if this extra info helps but anyway...

Thanks!!
Replace the file with this one:

Code:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
options {
        listen-on port 53 { any; };
        listen-on-v6 port 53 { any; };
        directory       "/var/named/chroot/var/named";
        dump-file       "/var/named/chroot/var/named/data/cache_dump.db";
        statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
        allow-query     { any; };
        recursion yes;
};
logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};
zone "." IN {
        type hint;
        file "named.root";
};
include "/var/named/chroot/var/named/named.local";
Then restart named.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
dns, nameservers

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 DNS not working for remote domains phorce1 Installation/Configuration 20 18th September 2010 00:23
No SPF record. beryl Installation/Configuration 6 17th May 2007 20:52
Dns question Mahir Installation/Configuration 48 14th November 2006 11:19
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 10:45
Pri & Slave DNS HOWTO (FC4) ppettigrew Suggest HOWTO 0 1st April 2006 16:35


All times are GMT +2. The time now is 00:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.