Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th April 2011, 14:00
ggarcia24 ggarcia24 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Question [The Perfect Server - Debian Squeeze - ISPConfig 3] - Connection Refused by Bind

Hi,

I've been having a problem with bind since a few days ago, I have a multiple server setup according to the manual, but following the squeeze perfect setup.

Now when I tried to do:

Code:
dig @ns1.example.com testdomain.com
All that I can get is:

Code:
; <<>> DiG 9.7.3 <<>> @ns1.example.com testdomain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 45017
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available
However when I execute the same query from localhost it works perfectly:

Code:
dig @localhost testdomain.com
; <<>> DiG 9.7.3 <<>> @localhost testdomain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26342
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;doso3.com.ar.			IN	A

;; ANSWER SECTION:
testdomain.com.		83362	IN	A	192.168.10.12

;; AUTHORITY SECTION:
testdomain.com.		83362	IN	NS	@ns1.example.com.

;; ADDITIONAL SECTION:
@ns1.example.com. 562	IN	A	192.168.10.93

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Apr 13 04:54:43 2011
;; MSG SIZE  rcvd: 100
Am I doing something wrong? I've been looking at "netstat -tlpn" but I can see that "named" is running on the external IP address:

Code:
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:47374           0.0.0.0:*               LISTEN      614/rpc.statd   
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      602/portmap     
tcp        0      0 192.168.10.93:53        0.0.0.0:*               LISTEN      31994/named     
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      31994/named     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      841/sshd        
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      31994/named     
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1090/exim4      
tcp        0      0 0.0.0.0:3306            0.0.0.0:*               LISTEN      31296/mysqld    
tcp6       0      0 :::53                   :::*                    LISTEN      31994/named     
tcp6       0      0 :::22                   :::*                    LISTEN      841/sshd        
tcp6       0      0 ::1:953                 :::*                    LISTEN      31994/named     
tcp6       0      0 ::1:25                  :::*                    LISTEN      1090/exim4
Any help will be really appreciated.

Greetings!
Gonzalo.
Reply With Quote
Sponsored Links
  #2  
Old 13th April 2011, 14:10
ggarcia24 ggarcia24 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

After a few thoughts I've check under syslog and found this:

Code:
Apr 13 05:06:35 ns1 named[31994]: client [MY_HOME_IP_ADDRESS]#59501: query (cache) 'testdomain.com/A/IN' denied
Reply With Quote
  #3  
Old 13th April 2011, 14:36
ggarcia24 ggarcia24 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I was able to solve this problem! ^_^! After googling a lot I found that I have to add the following to the file /etc/bind/named.conf.options:

Code:
allow-query { any; };
Could some tell me if this "safe" to made, I really think that the problem should be another one...

Greetings!
Gonzalo.
Reply With Quote
  #4  
Old 13th April 2011, 16:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
 
Default

That change is ok and required if your server shall be able to answer external dns requests.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with mail server and subdomains MyKE General 7 26th February 2010 10:18
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Email doesn't work... Ventzy Installation/Configuration 1 14th February 2010 11:49
Can't send mail [Lenny ISPConfig 3] Deficit HOWTO-Related Questions 2 14th June 2009 14:30
Connection dropped by IMAP server gublym Server Operation 5 23rd January 2009 09:47


All times are GMT +2. The time now is 19:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.