#1  
Old 7th April 2011, 14:33
EdjeB EdjeB is offline
Junior Member
 
Join Date: Nov 2010
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default DNS does not work

Hi,

I use The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3] setup. At one point everything worked. Now, all of a sudden dns does not. I have several several dns zones and multiple sites using a couple of ip-addresses on a single server. Lately i did updates, upgrades, dist-upgrades. Now there is only one site (on the first ip) and subdomains from that sites that works. This is really frustrating.
I want to break down to where the issue is. So i have a couple of questions:
- What logs can i tail to see any errors that pop up when trying to browse the non working sites?
- how do i know if the database content, concerning dns and the zone files are ok?
- how do i determine if this is dns on the box or external, like my registrar of dns propagation?
- is there a good dns troubleshoot how to somewhere that'll get me in the right direction?

please help me out to get the other domains back in the air asap. thanks in advance for any effort.

Kind regards,
Ed
Reply With Quote
Sponsored Links
  #2  
Old 7th April 2011, 14:43
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,439
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Restart bind and then take a look at the syslog to see which error bind has added there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th April 2011, 16:02
EdjeB EdjeB is offline
Junior Member
 
Join Date: Nov 2010
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default Solved

Hi,

thanks. I have it solved. The problem was that the additional ip-addresses that i configured in interfaces where not bound to the nic. a restart fixed that.

Kind regards,
Ed.
Reply With Quote
Reply

Bookmarks

Tags
debian, dns, multiple ips on one nic, single server

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Record Creation Doesn't Work elrako Installation/Configuration 5 19th May 2010 22:05
Minimal DNS server fabiosergio Installation/Configuration 1 5th April 2010 22:25
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
DNS Issues Alam Installation/Configuration 3 11th November 2006 13:57
Using a different DNS server with Dynamic DNS CombatGod Installation/Configuration 1 11th May 2006 17:43


All times are GMT +2. The time now is 14:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.