#1  
Old 23rd February 2011, 17:44
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default Another one on awstats

The integrated implementation of awstats (not the plugin discussed in this forum) does not show Search Keyphrases.

I use the latest stable ISPConfig 3 and I know that there are keyphrases for this particular site.

One more thing:
All the bots from search engines are listed in the hosts section. Normally they would show in Robots/Spiders visitors or in a section for search engines.
Reply With Quote
Sponsored Links
  #2  
Old 1st March 2011, 00:44
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

I think that I found the problem.
The LogFormat must be 1 and not 4 in
Code:
/etc/awstats/awstats.conf
I followed the Perfect Server for Debian Squeeze and installed awstats fvia apt-get. I didn't change anything in awstats.conf until now.

I think that the:
LogFormat=1
must be placed in
Code:
/etc/awstats/awstats.conf.local
so as further updates, do not change it again
Reply With Quote
The Following User Says Thank You to 8omas For This Useful Post:
till (1st March 2011)
  #3  
Old 1st March 2011, 12:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,989
Thanks: 825
Thanked 5,373 Times in 4,220 Posts
Default

Thanks for the info. We will add the instructions to the perfect setup guide.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 23rd March 2011, 06:25
Agent_M Agent_M is offline
Junior Member
 
Join Date: Jul 2010
Location: Perth, Australia
Posts: 29
Thanks: 5
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by 8omas View Post
I think that I found the problem.
The LogFormat must be 1 and not 4 in
Code:
/etc/awstats/awstats.conf
full thread at http://www.howtoforge.com/forums/sho...822#post249822

Quote:
Originally Posted by Agent_M View Post
I tried changing the log format in the awstats.conf file from 4 to 1 and that seemed to display the missing info, but it didn't seem to record all the visits to each site, so I have changed it back to 4, now the visits seemed to have improved, but the other info isn't displayed.

Is this just a config issue, or something else, what log format should it be using?
__________________
If it ain't broke, then take it apart to see what makes it so bloody special!!!
Reply With Quote
  #5  
Old 23rd March 2011, 10:12
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
 
Default

What do you mean that you don't get all the info? Do you consider spiders and robots as visits of normal visitors?

If the log format is 4, then those things (spiders, robots, etc) appear as clients

Last edited by 8omas; 23rd March 2011 at 10:19.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO: Run AWStats from the Command Line linus3x Tips/Tricks/Mods 1 22nd October 2010 22:54
Need help setting up or accessing AWStats on 3.0.2 please jwlinux Installation/Configuration 2 17th April 2010 16:38
Awstats config problem Paladinemishakal HOWTO-Related Questions 1 13th February 2009 13:38
Ispconfig + awstats on debian etch Dennis Installation/Configuration 1 19th April 2008 22:57
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 15th May 2006 23:04


All times are GMT +2. The time now is 13:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.