#1  
Old 3rd February 2011, 14:06
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default Autoresponder trick

I would like the autoresponder message to be dynamic, i.e. how can I program the autoresponder message to send back a password that changes every day or similar?

It would be great if the autoresponder text could be replaced by the output of a given script for example.
Reply With Quote
Sponsored Links
  #2  
Old 4th February 2011, 14:38
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

anyone?

where is the autoresponder message stored?
in the database?
can I make a cron job that changes the message every day?
Reply With Quote
  #3  
Old 4th February 2011, 14:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
where is the autoresponder message stored?
That depends on the lda that you use. For courier, it is tored in a file in the /var/vmail/mailfilters/..... folder. For dovecot the message is stored in the .sieve file in the root of the maildir folder.

Quote:
can I make a cron job that changes the message every day?
You can change the autoresponder text with the ispconfig remote API withe the mail user update function.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
manarak (4th February 2011)
  #4  
Old 4th February 2011, 15:07
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

found it in mailfilters, thank you!

will try to use a script to change it every day.
Reply With Quote
  #5  
Old 4th February 2011, 17:48
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

can't get it to work.

I chmodded .vacation.msg to 777 and added
/var/vmail/mailfilters/mydomain.com/passwords
to the openbasedir...

and I try
Code:
$fh = fopen('/var/vmail/mailfilters/mydomain.com/passwords/.vacation.msg', 'w')
(passwords is the email alias)


but I still get

Quote:
Warning: fopen(/var/vmail/mailfilters/mydomain.com/passwords/.vacation.msg) [function.fopen]: failed to open stream: Permission denied in /var/www/clients/client2/web7/web/change_autoresponder.php on line 3
ideas anyone?

Last edited by manarak; 4th February 2011 at 18:04.
Reply With Quote
  #6  
Old 4th February 2011, 23:54
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

what else than file permissions and openbasedir is denying access here please?
Reply With Quote
  #7  
Old 4th March 2011, 11:16
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

still stumped by this problem.

.vacation.msg has 777 permissions, as well as the directory containing the file.

I added the path to PHP openbasedir.

I still get

Warning: fopen(/var/vmail/mailfilters/mydomain.com/passwords/.vacation.msg) [function.fopen]: failed to open stream: Permission denied in /var/www/clients/client2/web7/web/change_autoresponder.php on line 3


Can someone help me or tell me why I can't open the file for writing?
Reply With Quote
  #8  
Old 5th March 2011, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Did you check the permissions/ownerships of all directories in the path to /var/vmail/mailfilters/mydomain.com/passwords/.vacation.msg?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 5th March 2011, 14:04
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
 
Default

thank you Falko

that is the probable cause why it doesn't work, but I don't want to potentially mess up my system by changing the groups on the directories

instead, I try to copy files there, but it doesn't work either:
http://www.howtoforge.com/forums/showthread.php?t=51754

the script works fine when started manually, but not with the cron job...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 problems with autoresponder raiman Installation/Configuration 7 1st September 2010 12:53
Autoresponder problem raicabogdan Installation/Configuration 13 9th June 2010 13:25
Autoresponder not working? cambo Installation/Configuration 36 24th July 2008 04:18
autoresponder Tripple2 Installation/Configuration 9 30th August 2007 17:12
Autoresponder / Local Username / Reject / Bounce Yves Installation/Configuration 3 12th July 2006 13:58


All times are GMT +2. The time now is 17:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.