Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 8th March 2011, 21:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by dkdzn View Post
Do I just download the new version and upload? How to I upgrade?
No need to download it manually. Login on the shell as root and execute the command:

ispconfig_update.sh
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 8th March 2011, 22:01
dkdzn dkdzn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did as you said... upgraded to 3.0.3.2 (checked version to confirm). I deleted both symlinks (in /var/www and /var/www/clients/client_1). And it didn't work. Now the vhost says "web_36" and the two new symlinks are "web_32" and "web_33" respectively.

~dkdzn
Reply With Quote
  #13  
Old 8th March 2011, 22:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Hmm, thats strange. Please post the output of:

ls -la /var/www/clients/client_1/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 8th March 2011, 22:13
dkdzn dkdzn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here you go. I replaced the actual domains and subdomains with sub1, sub2, etc... and domain1, domain2, etc.


root@marty:/etc/apache2/sites-enabled# ls -la /var/www/clients/client_1/
total 52
drwxr-xr-x 13 root root 4096 Mar 8 20:57 .
drwxr-xr-x 3 root root 4096 Jan 2 09:25 ..
lrwxrwxrwx 1 root root 33 Jan 7 21:32 domain1.org -> /var/www/client s/client_1/web_31/
lrwxrwxrwx 1 root root 33 Jan 7 21:30 domain2.com -> /var/www/cl ients/client_1/web_30/
lrwxrwxrwx 1 root root 33 Jan 4 15:17 sub1.domain3.com -> /var/www/clie nts/client_1/web_14/
lrwxrwxrwx 1 root root 33 Jan 3 15:19 sub2.domain3.com -> /var/www/clients/ client_1/web_13/
lrwxrwxrwx 1 root root 32 Jan 2 09:34 domain4.com -> /var/www/ clients/client_1/web_6/
lrwxrwxrwx 1 root root 32 Jan 2 09:25 domain3.com -> /var/www/clients/clie nt_1/web_5/
lrwxrwxrwx 1 root root 33 Jan 4 22:58 sub3.domain3.com -> /var/www/client s/client_1/web_23/
lrwxrwxrwx 1 root root 33 Mar 8 20:57 sub4.domain3.com -> /var/www/clients/ client_1/web_36/
lrwxrwxrwx 1 root root 32 Jan 2 09:36 sub5.domain3.com -> /var/www/clien ts/client_1/web_7/
lrwxrwxrwx 1 root root 33 Jan 5 19:38 sub6.domain3.com -> /var/www/client s/client_1/web_28/
drwxr-x--x 6 web13 client1 4096 Jan 4 20:22 web_13
drwxr-x--x 6 web14 client1 4096 Jan 4 21:28 web_14
drwxr-x--x 6 web23 client1 4096 Jan 4 22:58 web_23
drwxr-x--x 6 web28 client1 4096 Jan 5 02:10 web_24
drwxr-x--x 6 web28 client1 4096 Jan 5 18:30 web_28
drwxr-x--x 6 web30 client1 4096 Jan 7 21:30 web_30
drwxr-x--x 6 web31 client1 4096 Jan 7 21:32 web_31
drwxr-x--x 6 web36 client1 4096 Mar 8 20:28 web_36
drwxr-x--x 6 web5 client1 4096 Feb 19 18:48 web_5
drwxr-x--x 6 web6 client1 4096 Mar 8 00:30 web_6
drwxr-x--x 6 web7 client1 4096 Mar 8 00:30 web_7
Reply With Quote
  #15  
Old 8th March 2011, 22:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The symlink sub4.domain3.com points to /var/www/clients/ client_1/web_36/. I dont see a symlink to web32 or web33 there and there are also no directories web32 or web33, so that looks ok for me.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 8th March 2011, 22:44
dkdzn dkdzn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's the problem... there IS no web_32 or web_33 but the symlinks... at least according to my FTP program.... point there. Here is a screenshot: http://i1220.photobucket.com/albums/...creenshot1.jpg

I know what it says in the listing... but the screenshot says otherwise.

~dkdzn
Reply With Quote
  #17  
Old 9th March 2011, 15:05
dkdzn dkdzn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is there any other further info you can provide on this issue?
Reply With Quote
  #18  
Old 9th March 2011, 17:01
dkdzn dkdzn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I recreated the sites using ISPConfig and... for whatever reason... the symlinks are now correct in FileZilla. However, the sites are still not working and I still get 404s.

Please advise.
Reply With Quote
  #19  
Old 9th March 2011, 21:22
dkdzn dkdzn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Right now, it seems everything is correct but the site is still 404. Are you part of the ISPConfig development team? And, if so, do you have an email I can send you private information?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.