Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2011, 03:29
CSU-Bill CSU-Bill is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default phpmyadmin is 404 file not found

I hope I have not posted this in the wrong location.

While following your instructions at http://www.howtoforge.com/installing...ntu-10.10-lamp I had a learning curve. Thank you for providing a good set of instructions.

I have played with Linux (Ubuntu) for a very short time. I need a server, so decided to build one. I first loaded the latest Ubuntu (10.10) and then searched for instructions. I tried several and ended up reloading Ubuntu a few times (I have since learned how to un-install things). I found your instructions and loaded MySQL (have not checked it yet), Apache2 (It Works!), PHP5 (Vi was another learning experience, but info.php works). Then I tried to install PHPMyAdmin.

First, I made a mistake and said yes to using dbconfig-common for setting up the database. That got me into a loop asking for a password. This is where I learned "apt-get --purge remove phpmyadmin" and again started the phpmyadmin install. This last one appeared to work, but there are no files in the www folder other than info.php and index.html.

What should I do now? Should I get the phpmyadmin page from my windows machine (and any supporting php include files)? Should I try another install of phpmyadmin? Is there a file folder I can check to see if the files installed?
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2011, 18:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post the outputs of
Code:
ls -la /etc/apache2/conf.d/
and
Code:
ls -la /etc/phpmyadmin/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 9th March 2011, 00:06
CSU-Bill CSU-Bill is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The result of ls -la /etc/apache2/conf.d/
is:
drwxr-xr-x 2 root root 4096 2011-03-06 21:52 .
drwxr-xr-x 7 root root 4096 2011-03-06 16:51 ..
-rw-r--r-- 1 root root 269 2010-11-18 16:16 charset
lrwxrwxrwx 1 root root 45 2011-03-06 21:52 javascript-common.conf -> /etc/javascript-common/javascript-common.conf
-rw-r--r-- 1 root root 3296 2010-11-18 16:16 localized-error-pages
-rw-r--r-- 1 root root 143 2010-11-18 16:16 other-vhosts-access-log
-rw-r--r-- 1 root root 1481 2010-11-18 16:16 security

The output of ls -la /etc/phpmyadmin/
is:
drwxr-xr-x 2 root root 4096 2011-03-06 21:52 .
drwxr-xr-x 142 root root 12288 2011-03-08 17:45 ..
-rw-r--r-- 1 root root 871 2011-02-15 14:04 apache.conf
-rw-r----- 1 root www-data 517 2011-03-06 21:52 config-db.php
-rw-r--r-- 1 root root 168 2011-02-15 14:04 config.footer.inc.php
-rw-r--r-- 1 root root 168 2011-02-15 14:04 config.header.inc.php
-rw-r--r-- 1 root root 3918 2011-02-15 14:04 config.inc.php
-rw-r----- 1 root www-data 8 2011-03-06 21:52 htpasswd.setup
-rw-r--r-- 1 root root 570 2011-02-15 14:04 lighttpd.conf
-rw-r--r-- 1 root root 295 2011-02-15 14:04 phpmyadmin.service

Hope that provides what you asked for.

Bill
Reply With Quote
  #4  
Old 9th March 2011, 17:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please try this:

Code:
ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf
/etc/init.d/apache2 restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th March 2011, 03:24
CSU-Bill CSU-Bill is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko,

Thanks. I know I am getting closer to having things operational. Once I remembered to sudo su, I managed to get to the PHPMyAdmin login.

When I tried to login, I received this: #1045 Cannot log in to the MySQL server

What do I need to do now?

Is there a phpmyadmin config file that I need to edit?

Do I need to do something to MySQL?

Getting closer one-step-at-a-time.
Reply With Quote
  #6  
Old 10th March 2011, 17:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 11th March 2011, 00:04
CSU-Bill CSU-Bill is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is the results:

Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost.localdo:mysql *:*                     LISTEN      1129/mysqld     
tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN      1064/cupsd      
tcp        0      0 server01:46824          yw-in-f164.1e100.ne:www ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:50216          yw-in-f139.1e100.ne:www ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:55917          74.125.229.28:www       ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:53277          74.125.229.8:https      TIME_WAIT   -               
tcp        0      0 server01:36499          74.125.229.27:www       ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:43008          a96-6-45-58.deploy.:www ESTABLISHED 1655/firefox-bin
tcp        0     28 server01:59142          gx-in-f103.1e100.:https FIN_WAIT1   -               
tcp        0      0 server01:49306          yi-in-f139.1e100.ne:www ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:60233          yw-in-f113.1e100.ne:www ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:59136          gx-in-f103.1e100.:https TIME_WAIT   -               
tcp        0      0 server01:60993          gw-in-f139.1e100.ne:www TIME_WAIT   -               
tcp        0      0 server01:36296          74.125.229.29:https     TIME_WAIT   -               
tcp        0      0 server01:40484          yx-in-f164.1e100.:https TIME_WAIT   -               
tcp        0     28 server01:40974          gw-in-f120.1e100.:https FIN_WAIT1   -               
tcp        0      0 server01:34512          yu-in-f155.1e100.ne:www ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:59521          gx-in-f103.1e100.ne:www TIME_WAIT   -               
tcp        0      0 server01:59818          yx-in-f83.1e100.n:https ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:34522          yu-in-f155.1e100.ne:www ESTABLISHED 1655/firefox-bin
tcp        0     28 server01:38296          yw-in-f97.1e100.n:https FIN_WAIT1   -               
tcp        0      0 server01:43004          a96-6-45-58.deploy.:www ESTABLISHED 1655/firefox-bin
tcp        0      0 server01:54113          gx-in-f105.1e100.ne:www TIME_WAIT   -               
tcp        0      0 server01:54111          gx-in-f105.1e100.ne:www ESTABLISHED 1655/firefox-bin
tcp        0     28 server01:59076          74.125.229.0:https      FIN_WAIT1   -               
tcp        0      0 server01:59161          gw-in-f18.1e100.n:https ESTABLISHED 1655/firefox-bin
tcp6       0      0 [::]:www                [::]:*                  LISTEN      1145/apache2    
tcp6       0      0 server01:ipp            [::]:*                  LISTEN      1064/cupsd
Reply With Quote
  #8  
Old 11th March 2011, 15:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please open /etc/mysql/my.cnf and make MySQL listen on all interfaces (comment out bind-address = 127.0.0.1). Then restart MySQL.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 12th March 2011, 02:11
CSU-Bill CSU-Bill is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have modified my.cnf to have

# bind-address = 127.0.0.1

I still get the "#1045 Cannot log in to the MySQL server" error when I try to log in to phpmyadmin.

Just in case, here is the netstat -tap results:

Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN      1103/mysqld     
tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN      993/cupsd       
tcp        0      0 server01:60122          gx-in-f17.1e100.n:https ESTABLISHED 1621/firefox-bin
tcp        0   1189 server01:50566          gw-in-f104.1e100.ne:www ESTABLISHED 1621/firefox-bin
tcp        0      0 server01:34700          gw-in-f83.1e100.n:https ESTABLISHED 1621/firefox-bin
tcp        0      0 server01:60123          gx-in-f17.1e100.n:https ESTABLISHED 1621/firefox-bin
tcp        0    971 server01:51605          a96-17-147-25.deplo:www ESTABLISHED 1621/firefox-bin
tcp6       0      0 [::]:www                [::]:*                  LISTEN      1138/apache2    
tcp6       0      0 server01:ipp            [::]:*                  LISTEN      993/cupsd
Reply With Quote
  #10  
Old 12th March 2011, 19:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Do you use the correct MySQL user/password to log in?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't finish install due a problem Sam9999 Installation/Configuration 7 17th September 2010 22:33
libWand.so.10 error Taxick Installation/Configuration 8 3rd May 2009 01:27
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
BIND broke adamluz Installation/Configuration 4 2nd June 2006 21:31


All times are GMT +2. The time now is 16:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.