Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th November 2010, 21:48
simolokid simolokid is offline
Junior Member
 
Join Date: Nov 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Howto setup websvn on my Ds210j Diskstation.

Hi all,

I've followed the 'tutorial' on
http://forum.synology.com/wiki/index...ing_Subversion

to installing svn + websvn. I seem to have made a mistake somewhere but I can't seem to find out where or what.

When I try to reach websvn trough my browser (http://www.mysite.nl/websvn) i get the message:
Quote:
Unable to find "svn" tool at location "/opt/bin/svn/svn"
Which is weird, because I've gotten no clue where its getting the second 'svn' from.

In my config.php from websvn:

Code:
$config->setSVNCommandPath('/opt/bin/svn');
Code:
$config->addRepository('Test', 'file:///volume1/svn/test');
Just like the tutorial said.

I also came across this thread of this same forum:
http://www.howtoforge.com/forums/sho...d.php?p=157232

Did the which svn command, which outputted: /opt/bin/svn
Which you can see, i set as $config->setSvnCommandPath

Safemode is off.

Does anyone have an idea?

A butt-load of thanks to anyone able to fix my problem.

Kind regards,

Simolokid

[Edit]
Just to be clear; svn is working, its just websvn that cant find the tool apparently, since I just tried adding another repository, whichs works fine trough the cli. So websvn is the problem im guessing.
Also tried setting the command path to '/opt/bin' instead of /opt/bin/svn which did cause the good path, but didnt result in finding the tool.

Last edited by simolokid; 6th November 2010 at 22:01. Reason: More info
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2010, 21:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

What's the output of
Code:
ls -la /opt/bin/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th November 2010, 00:00
simolokid simolokid is offline
Junior Member
 
Join Date: Nov 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I included the output in the printscreen, you notice I blanked my username.

I hope this gives your some more info =P
Attached Images
 
Reply With Quote
  #4  
Old 8th November 2010, 15:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

Looks ok.

Quote:
Originally Posted by simolokid View Post

[Edit]
Just to be clear; svn is working, its just websvn that cant find the tool apparently, since I just tried adding another repository, whichs works fine trough the cli. So websvn is the problem im guessing.
Also tried setting the command path to '/opt/bin' instead of /opt/bin/svn which did cause the good path, but didnt result in finding the tool.
Do you maybe need to reload or restart something so that the change takes effect?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th November 2010, 15:20
simolokid simolokid is offline
Junior Member
 
Join Date: Nov 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Do you maybe need to reload or restart something so that the change takes effect?
Restarted apache 3 times so far >.<
Reply With Quote
  #6  
Old 6th March 2011, 21:45
glenn85 glenn85 is offline
Junior Member
 
Join Date: Mar 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Simolokid, did you already find a solution to this? I seem to have the exact same problem on my ds210j.
At first I thought it was something with the ownership of svn, but changing it to admin:users didn't change anything though...

edit: I found the solution by appending 'open_basedir' of '/usr/syno/etc/php/user-setting.ini' with '/opt/bin:'
So it was quite an easy solution after all...

Last edited by glenn85; 8th March 2011 at 22:02. Reason: solution found
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Chrome + Ubuntu + Flash player andor Desktop Operation 1 25th May 2010 16:59
Searching Howto setup a slackwere server Lord_Mephisto Server Operation 1 11th April 2009 13:16
Howto setup SiS190 Ethernet - not working for me hugoc HOWTO-Related Questions 5 8th May 2008 21:57
HOWTO: Setting up Subversion and websvn on Debian osyrixx HOWTO-Related Questions 0 3rd September 2007 12:28
Question regarding PHP setup in Ubuntu 6.06 LAMP install Howto FXT HOWTO-Related Questions 1 23rd August 2007 18:53


All times are GMT +2. The time now is 13:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.