Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 20th March 2011, 07:49
tazmon95 tazmon95 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 4
Thanked 1 Time in 1 Post
Default

Hello,

I've followed the main tutorial on how to set this up and I've gone through the steps of this post twice now and am getting the same error. It looks like everything should work, but when I get to the Roundcube login page and put in my user information, I get a red box that momentarily popup saying:
Quote:
Connection to IMAP server failed.
After doing more troubleshooting, I found that if I leave the
Quote:
$rcmail_config['default_host'] = 'localhost';
in the /var/lib/roundcube/config/main.inc.php file blank like this
Quote:
$rcmail_config['default_host'] = '';
I get a new box for server under the username and password on my login page. I've tried all the different server names I can think of which are setup in my ISPConfig3 panel, however I keep getting a red box saying:
Quote:
Login Failed
Any help with this would be much appreciated.

Thanks,
~Taz
Reply With Quote
Sponsored Links
  #12  
Old 20th March 2011, 10:04
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

Did you set the variable:
Code:
auto_create_user = TRUE;
in /var/lib/roundcube/config/main.inc.php ?

Are you sure that you set up correctly the mail server?
The new box that appeared, gives you the ability to choose the mail server to login. If the mail server is local (as the manual assumes) then the localhost is correct.

Please verify that you set the auto_create_user to TRUE
Reply With Quote
  #13  
Old 20th March 2011, 11:33
tazmon95 tazmon95 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 4
Thanked 1 Time in 1 Post
Default

I'm not 100% sure I setup the mail server correct, but everything else seems to be working ok.
Quote:
$rcmail_config['auto_create_user'] = TRUE;
This line was already in my /var/lib/roundcube/config/main.inc.php file. Do I need to write it differently?
Reply With Quote
  #14  
Old 20th March 2011, 11:55
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

Do you have the port 143 open on localhost?

what is the output of:
Code:
netstat -taun | grep LISTEN
Reply With Quote
  #15  
Old 20th March 2011, 19:39
tazmon95 tazmon95 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 4
Thanked 1 Time in 1 Post
Default

That's a new file for me and I'm not sure how to read it's output:
Quote:
tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 192.168.3.2:80 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
tcp 0 0 192.168.3.2:53 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:58756 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN
tcp6 0 0 :::110 :::* LISTEN
tcp6 0 0 :::143 :::* LISTEN
tcp6 0 0 :::81 :::* LISTEN
tcp6 0 0 :::8081 :::* LISTEN
tcp6 0 0 :::21 :::* LISTEN
tcp6 0 0 :::53 :::* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 ::1:953 :::* LISTEN
tcp6 0 0 :::443 :::* LISTEN
tcp6 0 0 :::993 :::* LISTEN
tcp6 0 0 :::995 :::* LISTEN
I only see a tcp6 line with 143 on it.
Reply With Quote
  #16  
Old 20th March 2011, 21:28
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

Me too. So you probably must open the port 143 for tcp/ip v4. If you manage your firewall through ISPconfig then you must go to:
System -> Firewall and add the port 143 to you open ports.
Reply With Quote
  #17  
Old 20th March 2011, 22:31
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

I think that with ipv6 listening on port 143, the situation is the same. So in simple words, your server is listening.

Keep in mind that
1) You must have a working mail (e.g. the@maildomain.com -- create it through panel)
2) Your login name must be that one (the@maildomain.com --enter it in the user name field of roundcube)
3) The roundcube and courier must be correctly installed.

If you are not sure about roundcube rerun
Code:
dpkg-reconfigure roundcube-core
For courier follow the perfect server
Reply With Quote
  #18  
Old 21st March 2011, 22:01
tazmon95 tazmon95 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 4
Thanked 1 Time in 1 Post
Default

8omas, Thanks for helping. I was finally able to login. The main part I was missing was the @mydomain.com from the username.

Also, I can't use Localhost as my server. It still tells me it can't connect to the IMAP server, however if I use the domain name it works. Is there any reason this could be an issue and cause problems later on?
Reply With Quote
  #19  
Old 21st March 2011, 22:10
tazmon95 tazmon95 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 4
Thanked 1 Time in 1 Post
Post

just figured it out. It was my /etc/hosts file. I needed to have localhosts separaate on the 127.0.0.1 line

Quote:
127.0.0.1 localhost.localdomain localhost
like that.
Reply With Quote
  #20  
Old 23rd June 2011, 09:34
T1mur T1mur is offline
Junior Member
 
Join Date: Jun 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi

i got instaled roundcube like in tutorial.

got small problem and have no idea how to resolve it...
after http://my.domain.org/webmail/ i got

CONFIGURATION ERROR
main.inc.php was not found.
Please read the INSTALL instructions!

what i did wrong after apt-get installation ?

is the owner of main.inc.php should be root ?

root@ns38685:/usr/share/roundcube# ls -l

drwxr-xr-x 2 root root 4096 Jun 22 13:12 bin
lrwxrwxrwx 1 root root 25 Jun 22 13:12 config -> /var/lib/roundcube/config
-rw-r--r-- 1 root root 9829 Oct 31 2009 index.php
lrwxrwxrwx 1 root root 23 Jun 22 13:12 logs -> /var/lib/roundcube/logs
-rw-r--r-- 1 root root 18294 Oct 18 2010 main.inc.php.dist
lrwxrwxrwx 1 root root 26 Jun 22 13:12 plugins -> /var/lib/roundcube/plugins
drwxr-xr-x 7 root root 4096 Jun 22 13:12 program
-rw-r--r-- 1 root root 26 Mar 22 2008 robots.txt
lrwxrwxrwx 1 root root 24 Jun 22 13:12 skins -> /var/lib/roundcube/skins
lrwxrwxrwx 1 root root 23 Jun 22 13:12 temp -> /var/lib/roundcube/temp

/usr/share/roundcube/config# ls -l

lrwxrwxrwx 1 root root 25 Jun 22 13:12 db.inc.php -> /etc/roundcube/db.inc.php
lrwxrwxrwx 1 root root 27 Jun 22 13:12 main.inc.php -> /etc/roundcube/main.inc.php
lrwxrwxrwx 1 root root 28 Jun 22 13:12 mimetypes.php -> /etc/roundcube/mimetypes.php

thxnks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.