Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 25th March 2011, 15:21
jagsler jagsler is offline
Junior Member
 
Join Date: Mar 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nope. But I changed something and now the error message has changed again..

Now when I try to send a mail to sales@example.com I don't recieve an e-mail in the user account but this is what happens in the maillog.

The mail.2contact.com already existed because of our other mailserver (MS Exchange 2003)

Code:
Mar 25 15:11:19 phunix02 postfix/smtp[12548]: connect to mail.2contact.com[87.213.105.124]:25: Connection timed out
Mar 25 15:11:19 phunix02 postfix/smtp[12548]: connect to fallback.vuurwerk.nl[62.250.3.112]:25: Connection refused
Mar 25 15:11:19 phunix02 postfix/smtp[12548]: 774FCA0072: to=<jmul@2contact.com>, orig_to=<root@localhost.localdomain>, relay=none, delay=103500, delays=103470/0.01/30/0, dsn=4.4.1, status=deferred (connect to fallback.vuurwerk.nl[62.250.3.112]:25: Connection refused)
Mar 25 15:11:51 phunix02 sendmail[12557]: p2PEBpTm012557: from=user, size=275, class=0, nrcpts=1, msgid=<201103251411.p2PEBpTm012557@localhost.localdomain>, relay=root@localhost
Mar 25 15:11:51 phunix02 postfix/smtpd[12558]: connect from phunix02[127.0.0.1]
Mar 25 15:11:51 phunix02 sendmail[12557]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Mar 25 15:11:51 phunix02 postfix/smtpd[12558]: 90DE3A002B: client=phunix02[127.0.0.1], sasl_sender=user@localhost.localdomain
Mar 25 15:11:51 phunix02 postfix/cleanup[12563]: 90DE3A002B: message-id=<201103251411.p2PEBpTm012557@localhost.localdomain>
Mar 25 15:11:51 phunix02 postfix/qmgr[2030]: 90DE3A002B: from=<user@localhost.localdomain>, size=748, nrcpt=1 (queue active)
Mar 25 15:11:51 phunix02 sendmail[12557]: p2PEBpTm012557: to=sales@example.com, ctladdr=user (500/500), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30275, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 90DE3A002B)
Mar 25 15:11:51 phunix02 postfix/smtpd[12558]: disconnect from phunix02[127.0.0.1]
Mar 25 15:11:51 phunix02 clamd[1897]: SelfCheck: Database status OK.
Mar 25 15:12:01 phunix02 dccproc[12570]: no working DCC servers dcc1.dcc-servers.net dcc2.dcc-servers.net dcc3.dcc-servers.net ... at 142.27.70.211 209.169.14.2
Mar 25 15:12:05 phunix02 postfix/smtpd[12572]: connect from unknown[127.0.0.1]
Mar 25 15:12:05 phunix02 postfix/smtpd[12572]: 0E025A0599: client=unknown[127.0.0.1]
Mar 25 15:12:05 phunix02 postfix/cleanup[12563]: 0E025A0599: message-id=<201103251411.p2PEBpTm012557@localhost.localdomain>
Mar 25 15:12:05 phunix02 postfix/qmgr[2030]: 0E025A0599: from=<user@localhost.localdomain>, size=1209, nrcpt=1 (queue active)
Mar 25 15:12:05 phunix02 amavis[11701]: (11701-01) Passed CLEAN, MYNETS LOCAL [127.0.0.1] [127.0.0.1] <user@localhost.localdomain> -> <sales@localhost.localdomain>, Message-ID: <201103251411.p2PEBpTm012557@localhost.localdomain>, mail_id: zZ0UOq6UXmYT, Hits: 0.179, size: 748, queued_as: 0E025A0599, 13428 ms
Mar 25 15:12:05 phunix02 postfix/smtp[12564]: 90DE3A002B: to=<sales@localhost.localdomain>, relay=127.0.0.1[127.0.0.1]:10024, delay=13, delays=0.05/0/0.01/13, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=11701-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 0E025A0599)
Mar 25 15:12:05 phunix02 postfix/qmgr[2030]: 90DE3A002B: removed
Mar 25 15:12:05 phunix02 postfix/cleanup[12563]: 13FA8A002B: message-id=<201103251411.p2PEBpTm012557@localhost.localdomain>
Mar 25 15:12:05 phunix02 postfix/qmgr[2030]: 13FA8A002B: from=<user@localhost.localdomain>, size=1353, nrcpt=1 (queue active)
Mar 25 15:12:05 phunix02 postfix/local[12574]: 0E025A0599: to=<sales@localhost.localdomain>, relay=local, delay=0.04, delays=0.01/0.02/0/0.01, dsn=2.0.0, status=sent (forwarded as 13FA8A002B)
Mar 25 15:12:05 phunix02 postfix/qmgr[2030]: 0E025A0599: removed
Mar 25 15:12:22 phunix02 postfix/smtpd[12453]: timeout after END-OF-MESSAGE from unknown[127.0.0.1]
Mar 25 15:12:22 phunix02 postfix/smtpd[12453]: disconnect from unknown[127.0.0.1]
Mar 25 15:12:35 phunix02 postfix/smtp[12548]: connect to mail.2contact.com[87.213.105.124]:25: Connection timed out
Mar 25 15:12:35 phunix02 postfix/smtp[12548]: connect to fallback.vuurwerk.nl[62.250.3.112]:25: Connection refused
Mar 25 15:12:35 phunix02 postfix/smtp[12548]: 13FA8A002B: to=<jmul@2contact.com>, orig_to=<sales@localhost.localdomain>, relay=none, delay=30, delays=0.01/0/30/0, dsn=4.4.1, status=deferred (connect to fallback.vuurwerk.nl[62.250.3.112]:25: Connection refused)
Thanks for still taking the time to help me figure this out!
Reply With Quote
Sponsored Links
  #22  
Old 26th March 2011, 15:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Mar 25 15:12:35 phunix02 postfix/smtp[12548]: connect to mail.2contact.com[87.213.105.124]:25: Connection timed out
Mar 25 15:12:35 phunix02 postfix/smtp[12548]: connect to fallback.vuurwerk.nl[62.250.3.112]:25: Connection refused

Please check if your server is blacklisted: http://mxtoolbox.com/blacklists.aspx
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #23  
Old 29th March 2011, 13:19
jagsler jagsler is offline
Junior Member
 
Join Date: Mar 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've tried different blacklist tool but nowhere it says the IP is blacklisted...
Reply With Quote
  #24  
Old 20th June 2011, 18:03
yasuni yasuni is offline
Junior Member
 
Join Date: Jun 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Guy's

I am Jagsler colleague, and taken over this project.
I have fixed to most things, like i can send to any @domein.com, and can recieve e-mail of any user.

The last problem where i am stuck on is that i can not send e-mails to our Exchange server.

Because its searching for a MX record but instead of searching on the Internet its searches, on the local Network.

How can fix that postfix search on the web for the MX record instead of on the internal network?

Thanks in advance.
Reply With Quote
  #25  
Old 21st June 2011, 08:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What's the error message in mail.log?

What's the output of
Code:
postconf -n
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #26  
Old 21st June 2011, 13:16
yasuni yasuni is offline
Junior Member
 
Join Date: Jun 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
[root@phunix02 ~]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
disable_vrfy_command = yes
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
 local_recipient_maps =2.2contact.ltd, localhost, localhost.localdomain
mydomain = 2contact.ltd
myhostname = phunix02.2contact.ltd
mynetworks = 127.0.0.0/8
mynetworks_style = host
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.7.1/README_FILES
sample_directory = /usr/share/doc/postfix-2.7.1/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
unknown_local_recipient_reject_code = 550
virtual_alias_domains = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf,  mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_uid_maps = static:5000
Code:
Jun 21 13:14:12 phunix02 sendmail[4935]: p5LBECd6004935: Authentication-Warning: localhost.localdomain: apache set sender to theo@2contact.nl using -f
Jun 21 13:14:12 phunix02 sendmail[4935]: p5LBECd6004935: from=theo@2contact.nl, size=586, class=0, nrcpts=1, msgid=<cf30724e568180341dac066169531043@2contact.nl>, relay=apache@localhost
Jun 21 13:14:12 phunix02 postfix/smtpd[4936]: connect from phunix02[127.0.0.1]
Jun 21 13:14:12 phunix02 sendmail[4935]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jun 21 13:14:12 phunix02 postfix/smtpd[4936]: DD6D2A0264: client=phunix02[127.0.0.1]
Jun 21 13:14:12 phunix02 postfix/cleanup[4943]: DD6D2A0264: message-id=<cf30724e568180341dac066169531043@2contact.nl>
Jun 21 13:14:12 phunix02 postfix/qmgr[3014]: DD6D2A0264: from=<theo@2contact.nl>, size=1034, nrcpt=1 (queue active)
Jun 21 13:14:12 phunix02 sendmail[4935]: p5LBECd6004935: to=<twilde@2contact.com>, ctladdr=theo@2contact.nl (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30586, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as DD6D2A0264)
Jun 21 13:14:12 phunix02 postfix/smtp[4945]: DD6D2A0264: to=<twilde@2contact.com>, relay=none, delay=0.06, delays=0.06/0.01/0/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=2contact.com type=AAAA: Host found but no data record of requested type)
Jun 21 13:14:12 phunix02 postfix/smtpd[4936]: disconnect from phunix02[127.0.0.1]
Jun 21 13:14:12 phunix02 postfix/cleanup[4943]: ED381A12DA: message-id=<20110621111412.ED381A12DA@phunix02.2contact.ltd>
Jun 21 13:14:12 phunix02 imapd: LOGOUT, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=672, sent=275, time=0
Jun 21 13:14:12 phunix02 postfix/qmgr[3014]: ED381A12DA: from=<>, size=3077, nrcpt=1 (queue active)
Jun 21 13:14:12 phunix02 postfix/bounce[4946]: DD6D2A0264: sender non-delivery notification: ED381A12DA
Jun 21 13:14:12 phunix02 postfix/qmgr[3014]: DD6D2A0264: removed
Jun 21 13:14:13 phunix02 postfix/virtual[4948]: ED381A12DA: to=<theo@2contact.nl>, relay=virtual, delay=0.05, delays=0.01/0.01/0/0.03, dsn=2.0.0, status=sent (delivered to maildir)
Jun 21 13:14:13 phunix02 postfix/qmgr[3014]: ED381A12DA: removed
And the Mail that is send back.

Code:
Reporting-MTA: dns; phunix02.2contact.ltd
X-Postfix-Queue-ID: DD6D2A0264
X-Postfix-Sender: rfc822; theo@2contact.nl
Arrival-Date: Tue, 21 Jun 2011 13:14:12 +0200 (CEST)

Final-Recipient: rfc822; twilde@2contact.com
Original-Recipient: rfc822;twilde@2contact.com
Action: failed
Status: 5.4.4
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
    for name=2contact.com type=AAAA: Host found but no data record of requested
    type

Return-Path: <theo@2contact.nl>
Received: from localhost.localdomain (phunix02 [127.0.0.1])
	by phunix02.2contact.ltd (Postfix) with ESMTPS id DD6D2A0264
	for <twilde@2contact.com>; Tue, 21 Jun 2011 13:14:12 +0200 (CEST)
Received: (from apache@localhost)
	by localhost.localdomain (8.14.4/8.14.4/Submit) id p5LBECd6004935;
	Tue, 21 Jun 2011 13:14:12 +0200
X-Authentication-Warning: localhost.localdomain: apache set sender to theo@2contact.nl using -f
To: <twilde@2contact.com>
Subject: test
X-PHP-Originating-Script: 501:func.inc
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8;
 format=flowed
Content-Transfer-Encoding: 7bit
Date: Tue, 21 Jun 2011 13:14:12 +0200
From: Theo Wilde <theo@2contact.nl>
Organization: 2C holding
Message-ID: <cf30724e568180341dac066169531043@2contact.nl>
X-Sender: theo@2contact.nl
User-Agent: Roundcube Webmail/0.5.3

Last edited by yasuni; 21st June 2011 at 13:19.
Reply With Quote
  #27  
Old 22nd June 2011, 13:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What nameservers do you use in /etc/resolv.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #28  
Old 22nd June 2011, 19:58
yasuni yasuni is offline
Junior Member
 
Join Date: Jun 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

our Windows Domain Controllers

10.0.0.61 ( our head DC )
10.0.0.62 ( Back up DC )
Reply With Quote
  #29  
Old 23rd June 2011, 16:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What happens if you use 8.8.8.8 (that's a Google nameserver) as the first nameserver in /etc/resolv.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #30  
Old 23rd June 2011, 16:50
yasuni yasuni is offline
Junior Member
 
Join Date: Jun 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

no luck, when i try it doesnt even send the mail.

Code:
Jun 23 16:42:22 phunix02 sendmail[15238]: p5NEeMIS015238: Authentication-Warning: localhost.localdomain: apache set sender to theo@2contact.nl using -f
Jun 23 16:44:22 phunix02 sendmail[15238]: p5NEeMIS015238: from=theo@2contact.nl, size=586, class=0, nrcpts=1, msgid=<e1e93d0da84b8953f1a697ca0a789460@2contact.nl>, relay=apache@localhost
Jun 23 16:44:22 phunix02 sendmail[15238]: p5NEeMIS015238: to=<twilde@2contact.com>, delay=00:04:00, mailer=esmtp, pri=30586, dsn=4.4.3, stat=queued
Jun 23 16:44:22 phunix02 imapd: LOGOUT, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=672, sent=275, time=240
Jun 23 16:44:23 phunix02 imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 23 16:44:23 phunix02 imapd: LOGIN, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], port=[50201], protocol=IMAP
Jun 23 16:44:23 phunix02 imapd: LOGOUT, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=77, sent=558, time=0
Jun 23 16:44:23 phunix02 imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 23 16:44:23 phunix02 imapd: LOGIN, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], port=[50202], protocol=IMAP
Jun 23 16:44:23 phunix02 imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 23 16:44:23 phunix02 imapd: LOGIN, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], port=[50203], protocol=IMAP
Jun 23 16:44:23 phunix02 imapd: LOGOUT, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=271, sent=856, time=0
Jun 23 16:44:23 phunix02 imapd: LOGOUT, user=theo@2contact.nl, ip=[::ffff:127.0.0.1], headers=1737, body=0, rcvd=288, sent=3820, time=0

And i dont even get a e-mail back with a error or some kind.
And even worse if i try to send to a other mail adress like @live.nl , it doesn' t send the mail any more what before the changes was possible.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
Email Could not send and receive piseth Installation/Configuration 16 17th July 2010 18:27
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 20:43


All times are GMT +2. The time now is 20:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.