Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th February 2011, 20:38
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default Postfix: Unable to send emails.

Hi,

I have followed Falko's tutorial below:
http://www.howtoforge.com/virtual-us...dora-14-x86_64
Somehow I am missing something as my postfix is unable to send e-mails. I went through the howto many times but I am unable to find what is causing the problem.

When I try to send an email from terminal I am getting the below error:
451 4.3.0 <example@gmail.com>: Temporary lookup failure
where example is just replace by the real e-mail address I am testing with.

From logs i managed to find also some errors:
Feb 10 19:26:28 example postfix/smtpd[10798]: connect from example.homelinux.com[127.0.0.1]
Feb 10 19:27:05 example postfix/smtpd[10798]: warning: connect to mysql server 127.0.0.1: Access denied for user 'postfix'@'localhost' (using password: YES)
Feb 10 19:27:05 example postfix/smtpd[10798]: NOQUEUE: reject: RCPT from example.homelinux.com[127.0.0.1]: 451 4.3.0 <example@gmail.com>: Temporary lookup failure; from=<root@localhost> to=<example@gmail.com> proto=ESMTP helo=<localhost>
Feb 10 19:27:15 example postfix/cleanup[10806]: warning: connect to mysql server 127.0.0.1: Access denied for user 'postfix'@'localhost' (using password: YES)
Feb 10 19:27:15 example postfix/cleanup[10806]: warning: 1D86D9AC7AE: virtual_alias_maps map lookup problem for postmaster@example.homelinux.com
Feb 10 19:27:15 example postfix/smtpd[10798]: disconnect from example.homelinux.com[127.0.0.1]
Feb 10 19:30:12 example clamd[1332]: SelfCheck: Database status OK.

I removed my real domain name with the name example....

I really would appreciate any suggestions! Thanks everyone for looking!
regards,
sammd006
Reply With Quote
Sponsored Links
  #2  
Old 11th February 2011, 15:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Please make sure you have the correct MySQL details in your /etc/postfix/mysql*.cf files.

Also make sure that your network connection is working and that you have valid nameservers in /etc/resolv.conf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th February 2011, 00:16
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi Falko,

For /etc/postfix/mysql*.cf:
Username / password are the same of the user i created for my mail DB.

Below is what I have in my => /etc/resolv.conf :

search homelinux.com
nameserver 192.168.2.1 <= my private ip default gateway

Is something missing?
regards,
sammd006
Reply With Quote
  #4  
Old 12th February 2011, 12:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Can you try
Code:
nameserver 8.8.8.8
as the first nameserver in /etc/resolv.conf and see if that changes anything?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 12th February 2011, 12:48
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi Falko,

I did the change as you have sugested but still I am having the Temporary lookup failure in my logs.

regards,
sammd006
Reply With Quote
  #6  
Old 13th February 2011, 11:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

There seems to be something wrong with your MySQL settings. Can you take the user and password from the mysql*.cf files and log into MySQL on the shell?

Code:
mysql -u username -p
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 13th February 2011, 20:14
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi Falko,

I do not think although from log files there seems to be some warnings which are not clear to me too.

I tried from terminal as you suggested and managed to log into the DB with username and password from my mysql*.cf files.

I am missing something somewhere ... May I ask if I can send you my mail.cf conf file pm and you take a look maybe I have some missing entries?

Regards,
sammd006
Reply With Quote
  #8  
Old 14th February 2011, 15:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Does the password contain any special characters?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 14th February 2011, 23:25
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi Falko,

No it does not contain any special characters...

regards,
sammd006
Reply With Quote
  #10  
Old 15th February 2011, 15:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 10:58
Email Could not send and receive piseth Installation/Configuration 16 17th July 2010 19:27
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 17:27
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 21:43
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 18:39


All times are GMT +2. The time now is 12:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.