Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Programming/Scripts

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th February 2011, 15:50
bernikm bernikm is offline
Junior Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default Script to list e-mail account that have mail on a server

Hi

On gentoo Linux I'm trying to find out which users have e-mail messages still on server.
We're moving all user/mail account to a new Linux distribution (RedHat) so I need to know which users still have e-mail messages on a server. Yes I know I can look into each users folder and list messages, but if anyone has a script that will seatch through all users mailboxes and list how much e-mail messages each user still has on a server that would be great!
Any ideas or instructions how to do this?
Regards,
Miha
Reply With Quote
Sponsored Links
  #2  
Old 17th February 2011, 17:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I don't have such a script, but I think it should be easy to migrate all email accounts using imapsync: http://www.howtoforge.com/how-to-mig...-with-imapsync
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd February 2011, 15:02
bernikm bernikm is offline
Junior Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko View Post
I don't have such a script, but I think it should be easy to migrate all email accounts using imapsync: http://www.howtoforge.com/how-to-mig...-with-imapsync
Thanks! Tried with imapsync, I get error on second server that I want to transfer mail to

Error login: [XXX.XXX.XXX.XXX] with user [testb@mydomain.com] auth [CRAM-MD5]: 2 NO [ALERT] Unsupported authentication mechanism.

Any ideas how to solve this?
Reply With Quote
  #4  
Old 23rd February 2011, 14:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

There seems to be something wrong with authentication on the second server? Did you check the mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 24th February 2011, 16:11
bernikm bernikm is offline
Junior Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Hi

Running with option --authmech2 LOGIN solved the issue!
Reply With Quote
The Following User Says Thank You to bernikm For This Useful Post:
falko (25th February 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email Could not send and receive piseth Installation/Configuration 16 17th July 2010 18:27
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Postfix + postfixadmin = SMTP errors... Rashef Server Operation 4 25th June 2009 16:12
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50


All times are GMT +2. The time now is 15:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.