Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th February 2011, 15:40
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
Default [The Perfect Spamsnake Ubuntu 10.10] - Problems with domains.

Thanks for a good guide

I seem to have the system running, BUT I'm getting errors when adding the SMTP server to my second domain.

Code:
Error, the mailserver mailserver.xxx.com is NOT accepting mail for : yyy.com
This happens after I click the "check" button next to the pencil.

I have 4 domains, all using the same mailserver, lets call it mailserver.xxx.com

All MX records currently point to this servers hostname, and my mail has always been running perfect, no issues, so I don't think it's a DNS/MX issue.

My first domain I CAN add to Baruwa, but funny enough this domain has the same TLD as the server on which Spamsnake is installed on, it's called mailgw.xxx.com.

So, just to clarify:

1st domain = xxx.com works fine(baruwa is called mailgw.xxx.com)
2nd domain = Error (yyy.com)

Can anyone please point me in the right direction of a solution?

Thanks
__________________
Best regards

Jim
Reply With Quote
Sponsored Links
  #2  
Old 19th February 2011, 16:39
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Baruwa runs the check by attempting to deliver a message to postmaster@domain_name. So if you do not have postmaster account on that specific domain then you can safely ignore that error as long as all other mail gets through.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
itsnedkeren (19th February 2011)
  #3  
Old 19th February 2011, 16:57
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
Default

Thanks a lot, I'll try to add a postmaster account on the domains in question.

Oh and a very noob question: I need to point all my domains MX-record to the server on where Baruwa lies, right?
__________________
Best regards

Jim
Reply With Quote
  #4  
Old 19th February 2011, 17:11
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

+ No you do not have to add those accounts, if the test does not work it does not mean that normal mail will not work.

+ Yes if you need to filter the mail then you have to point the MX to the machine running the spam snake, and on your actual mail server only allow access from the spam snake such that people cannot bypass the filter and send directly to the mail server.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
itsnedkeren (19th February 2011)
  #5  
Old 19th February 2011, 19:09
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
Default

Quote:
Originally Posted by topdog View Post
+ Yes if you need to filter the mail then you have to point the MX to the machine running the spam snake, and on your actual mail server only allow access from the spam snake such that people cannot bypass the filter and send directly to the mail server.
Any quick method of allowing access from the mail gateway only? I'm running Debian5 with ISPConfig3. (Courier)

Thanks again.
__________________
Best regards

Jim

Last edited by itsnedkeren; 19th February 2011 at 19:17.
Reply With Quote
  #6  
Old 20th February 2011, 08:07
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Are you trying to run the gateway and the mail server on the same machine ? This will not work with that howto you are following.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #7  
Old 20th February 2011, 12:35
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
 
Default

Quote:
Originally Posted by topdog View Post
Are you trying to run the gateway and the mail server on the same machine ? This will not work with that howto you are following.
No no, not at all. It's a seperate virtual machine. I'll start over on a fresh install
__________________
Best regards

Jim
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect SpamSnake - Ubuntu Jeos 10.04 - Nginx, uWSGI & Baruwa Drex56 HOWTO-Related Questions 17 8th February 2011 23:21
The Perfect SpamSnake - Ubuntu Jeos 10.10 - Managing transport relay_domains etc mintydave HOWTO-Related Questions 19 20th January 2011 04:15
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 9th May 2009 00:00
The Perfect SpamSnake - Ubuntu 8.04 - troubles teixeira HOWTO-Related Questions 8 14th November 2008 20:38
ISPConfig + Perfect Setup Ubuntu 5.10 + Smtp SPAM problems lyndros Installation/Configuration 11 15th April 2006 18:07


All times are GMT +2. The time now is 20:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.