#1  
Old 15th February 2011, 22:27
Steve-0 Steve-0 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default DJBDNS Help, please

I have 3 nameservers set up with TinyDNS, but only one is working correctly...these servers are:

ns1.radicalcomputingconcepts.com (Lenny)
ns2.radicalcomputingconcepts.com (Etch)
67.14.192.56 (Lenny)

Tinydns is running on all three machines as confirmed by svstat and the log files present in /etc/service/tinydns/log/main/current

The issue I'm having is that when querying the servers via dig @servername...only the ns2.radicalcomputingconcepts.com responds correctly.

Even if I log into the servers and query with dig @localhost, or dig@ IP to the servers themselves, the response is,
"; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached"

a test name to query for correct results is as follows:
dig @ns2.radicalcomputingconcepts.com www.keystonedesign.com
Reply With Quote
Sponsored Links
  #2  
Old 16th February 2011, 16:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's the output of
Code:
netstat -tap
and
Code:
netstat -uap
on the not-working server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th February 2011, 16:46
Steve-0 Steve-0 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default netstat

~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:59406 *:* LISTEN 1822/rpc.statd
tcp 0 0 *:sunrpc *:* LISTEN 1811/portmap
tcp 0 0 *:ssh *:* LISTEN 2069/sshd
tcp 0 0 localhost.localdom:smtp *:* LISTEN 2336/exim4
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6622 TIME_WAIT -
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6636 TIME_WAIT -
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6754 ESTABLISHED 30154/sshd: unknown
tcp 0 240 ns1.radicalcomputin:ssh c-76-120-72-105.h:54765 ESTABLISHED 30122/0
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6758 ESTABLISHED 30168/sshd: [accept
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6762 ESTABLISHED 30170/sshd: [accept
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6637 TIME_WAIT -
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6755 ESTABLISHED 30155/sshd: unknown
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6718 TIME_WAIT -
tcp 0 0 ns1.radicalcomputin:ssh 218.201.249.211:6763 ESTABLISHED 30171/sshd: [accept
tcp6 0 0 [::]:ssh [::]:* LISTEN 2069/sshd


and

~# netstat -uap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
udp 0 0 ns1.radicalcompu:domain *:* 31964/tinydns
udp 0 0 ns1.radicalcomput:39094 nrcns.s3woodstoc:domain ESTABLISHED 30968/sshd: [accept
udp 0 0 *:54468 *:* 1822/rpc.statd
udp 0 0 *:726 *:* 1822/rpc.statd
udp 0 0 *:sunrpc *:* 1811/portmap
Reply With Quote
  #4  
Old 17th February 2011, 17:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
udp 0 0 ns1.radicalcompu:domain *:* 31964/tinydns
tinyDNS is not listening on all interfaces. Can you configure it to listen on all interfaces?

If that still doesn't help, please make it listen on TCP as well (in addition to UDP).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th February 2011, 19:33
Steve-0 Steve-0 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default all interfaces?

Falko,
The tinydns-conf program does not allow for setting TinyDNS to run on more than one interface. I have mail and other services running on these interfaces.

Likewise TINYDNS is not intended to run on TCP. AXFRDNS is the sister package that is part of DJBDNS intended to run on TCP.

The working server reports similar information via netstat...surely this is not causing the lack of response by the server???

~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdo:60000 *:* LISTEN 1934/postgrey.pid -
tcp 0 0 localhost.localdo:10024 *:* LISTEN 1931/amavisd (maste
tcp 0 0 localhost.localdo:mysql *:* LISTEN 2134/mysqld
tcp 0 0 localhost.localdoma:781 *:* LISTEN 2301/famd
tcp 0 0 *:sunrpc *:* LISTEN 1575/portmap
tcp 0 0 *:auth *:* LISTEN 2083/inetd
tcp6 0 0 *:imaps *:* LISTEN 2031/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 2052/couriertcpd
tcp6 0 0 *op3 *:* LISTEN 2039/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 2001/couriertcpd
tcp6 0 0 *:www *:* LISTEN 4133/apache2
tcp6 0 0 *:ssh *:* LISTEN 2297/sshd
tcp6 0 0 *:https *:* LISTEN 4133/apache2
tcp6 0 1824 ::ffff:66.55.47.207:ssh c-76-120-72-105.h:59672 ESTABLISHED15093/0

~# netstat -uap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
udp 0 0 ns2.radicalcompu:domain *:* 2407/tinydns
udp 0 0 *:sunrpc *:* 1575/portmap
Reply With Quote
  #6  
Old 18th February 2011, 16:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Are there any djbdns errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 18th February 2011, 17:20
Steve-0 Steve-0 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

No errors...but I think I figured it out...did complete reinstall...For whatever reason, I think dig was broken and tinydns just needed a local query with dnsq to get the ball rolling....now dig works as well.

S
Reply With Quote
Reply

Bookmarks

Tags
djbdns, tinydns

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
djbdns problems - slow responses technick Server Operation 1 16th September 2008 22:16
DJBDNS and DNSCache VMWare satyannair Feature Requests 1 28th November 2007 22:42
DJBDNS Problem pinguingilo Installation/Configuration 3 8th October 2006 02:54
DJBDns? Dertanion General 1 23rd August 2006 11:16
djbdns in redhat enterprise 4 update 2 under vmware. Layn Installation/Configuration 1 15th March 2006 11:33


All times are GMT +2. The time now is 21:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.