Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th February 2011, 20:55
n0rbertt n0rbertt is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help installing courier

So I'm trying to install courier and I first got the error :

configure: error: Courier authentication library version 0.63 is required.

So I installed it , but I still get the error.

So I see on this post it is suggested to install courier-imap but that still gives me this error :


checking for courierauthconfig... /usr/bin/courierauthconfig
configure: error: Courier authentication library version 0.61 required.
Reply With Quote
Sponsored Links
  #2  
Old 17th February 2011, 04:44
n0rbertt n0rbertt is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone Please ?
Reply With Quote
  #3  
Old 17th February 2011, 17:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Which distribution and which tutorial (URL) do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 17th February 2011, 18:18
n0rbertt n0rbertt is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Cent OS and this one : http://www.howtoforge.com/installing...-redhat-centos
Reply With Quote
  #5  
Old 18th February 2011, 16:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you download the newest versions from http://www.courier-mta.org/download.php , or did you use the versions from the tutorial?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 18th February 2011, 20:32
n0rbertt n0rbertt is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The newest version.
Reply With Quote
  #7  
Old 19th February 2011, 11:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

When exactly do you get the error? When you build courier-authlib, courier-imap, or maildrop?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 19th February 2011, 17:20
n0rbertt n0rbertt is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The main courier program
Reply With Quote
  #9  
Old 20th February 2011, 06:11
n0rbertt n0rbertt is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So I ussue this command : sudo rpm -ivh courier-authlib-0.63.0-1.x86_64.rpm

and get :

Quote:
file /etc/authlib/authpgsqlrc.dist from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libauthcustom.la from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libauthcustom.so.0 from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libauthpam.la from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libauthpam.so.0 from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauth.la from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauth.so.0 from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauthcommon.la from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauthcommon.so.0 from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauthsasl.la from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauthsasl.so.0 from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauthsaslclient.la from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/lib64/courier-authlib/libcourierauthsaslclient.so.0 from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/libexec/courier-authlib/authdaemond from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/libexec/courier-authlib/makedatprog from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/libexec/courier-authlib/sysconftool from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/sbin/authenumerate from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/sbin/authpasswd from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/sbin/authtest from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/sbin/courierlogger from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/share/man/man1/authpasswd.1.gz from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/share/man/man1/authtest.1.gz from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
file /usr/share/man/man1/courierlogger.1.gz from install of courier-authlib-0.63.0-1.x86_64 conflicts with file from package courier-authlib-0.60.2-1.x86_64
Reply With Quote
  #10  
Old 20th February 2011, 23:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

You installed courier-authlib-0.60.2-1.x86_64 before courier-authlib-0.63.0-1.x86_64, right? Please uinstall courier-authlib-0.60.2-1.x86_64, and then try to install courier-authlib-0.63.0-1.x86_64 again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Courier installing error in Fedora10 bola Installation/Configuration 5 26th February 2010 15:39
Errors Installing Postfix, PostfixAdmin, Courier asyadiqin Installation/Configuration 15 13th November 2008 17:28
Problems with installation on openSUSE 10.2 douglaslopezt Installation/Configuration 3 24th August 2007 22:04
Installing postfix, courier, etc, but mail login fails JimXL HOWTO-Related Questions 11 25th July 2007 20:10
Problem Installing Courier (The Perfect Setup) regan Installation/Configuration 1 22nd April 2006 22:49


All times are GMT +2. The time now is 02:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.