Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th February 2011, 00:40
aberrio aberrio is offline
Senior Member
 
Join Date: Sep 2007
Posts: 150
Thanks: 13
Thanked 3 Times in 3 Posts
Default Unable to auth with Dovecot

Hello,

I am trying to configure an email server. I followed information on this
The Perfect Server - OpenSUSE 11.3 x86_64 [ISPConfig 3]


and add it the virtual and user from a different tutorial.

I like to use Dovecot but SMTP is not able to loging with it. I am getting the following error.


Feb 6 16:22:04 xxxx postfix/smtpd[13015]: warning: SASL: Connect to private/auth failed: No such file or directory
Feb 6 16:22:04 xxxx postfix/smtpd[13015]: fatal: no SASL authentication mechanisms
Feb 6 16:22:05 xxxx postfix/master[12784]: warning: process /usr/lib/postfix/smtpd pid 13015 exit status 1
Feb 6 16:22:05 xxxx postfix/master[12784]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

Here is the netstat -tap

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imap *:* LISTEN 12991/dovecot
tcp 0 0 *:sunrpc *:* LISTEN 2109/rpcbind
tcp 0 0 *:ndmp *:* LISTEN 2327/perl
tcp 0 0 *:smtp *:* LISTEN 12784/master
tcp 0 0 *:imaps *:* LISTEN 12991/dovecot
tcp 0 0 localhost:10024 *:* LISTEN 2218/amavisd (maste
tcp 0 0 localhost:10025 *:* LISTEN 12784/master
tcp 0 0 *:mysql *:* LISTEN 3740/mysqld
tcp 0 0 *:12 *:* LISTEN 1561/sshd
tcp 0 0 localhost:dyna-access *:* LISTEN 2000/clamd
tcp 0 0 tchosting.net:12 wsip-174:haipe-discover ESTABLISHED 2576/0
tcp 0 0 tchosting.net:imap wsip-174-xx-xxx-17:4978 TIME_WAIT -
tcp 0 0 tchosting.net:imap wsip-174-xx-xxx-17:4981 ESTABLISHED 13172/imap-login
tcp 0 0 tchosting.net:imap wsip-174-xx-xxx-17:4977 TIME_WAIT -
tcp 0 0 tchosting.net:imap wsip-174-xx-xxx-17:4982 ESTABLISHED 13201/imap-login
tcp 0 0 *:sunrpc *:* LISTEN 2109/rpcbind
tcp 0 0 *:www-http *:* LISTEN 2254/httpd2-prefork
tcp 0 0 *:smtp *:* LISTEN 12784/master
tcp 0 0 *:https *:* LISTEN 2254/httpd2-prefork
tcp 0 0 localhost:10025 *:* LISTEN 12784/master
tcp 0 0 *:12 *:* LISTEN 1561/sshd

My Dovecot .conf...

base_dir = /var/run/dovecot/
protocols = imap imaps
log_timestamp = "%b %d %H:%M:%S "
syslog_facility = mail
ssl_parameters_regenerate = 168
verbose_ssl = no
mail_location = maildir:/var/vmail/%d/%n
mail_access_groups = mail
mail_debug = no
first_valid_uid = 150
last_valid_uid = 150
maildir_copy_with_hardlinks = yes

protocol imap {
login_executable = /usr/lib/dovecot/imap-login
mail_executable = /usr/lib/dovecot/imap
imap_max_line_length = 65536
#mail_plugins = quota imap_quota
#mail_plugin_dir = /usr/lib/dovecot/imap
#login_greeting_capability = no
#imap_capability =
imap_client_workarounds = outlook-idle delay-newmail
}

#protocol pop3 {
# login_executable = /usr/lib/dovecot/pop3-login
# mail_executable = /usr/lib/dovecot/pop3
#pop3_no_flag_updates = no
#pop3_enable_last = no
#pop3_reuse_xuidl = no
#pop3_lock_session = no
#pop3_uidl_format = %08Xv%08Xu
#pop3_logout_format = top=%t/%p, retr=%r/%b, del=%d/%m, size=%s
#mail_plugins = quota imap_quota
#mail_plugin_dir = /usr/lib/dovecot/pop3
# pop3_client_workarounds = outlook-no-nuls oe-ns-eoh
#}

protocol lda {
postmaster_address = postmaster@example.com
#hostname =
mail_plugins = quota
#mail_plugin_dir = /usr/lib/dovecot/lda
sendmail_path = /usr/lib/sendmail
auth_socket_path = /var/run/dovecot/auth-master
}

auth_username_chars = abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWX YZ01234567890.-_@
auth_verbose = no
auth_debug = no

auth default {
mechanisms = plain digest-md5 cram-md5 login
passdb pam {
}
passdb sql {
args = /etc/dovecot/dovecot-sql.conf
}

userdb passwd {
}
userdb sql {
args = /etc/dovecot/dovecot-sql.conf
}
user = nobody
socket listen {
master {
path = /var/run/dovecot/auth-master
mode = 0600
user = vmail
group = mail
}
client {
path = /var/run/dovecot/auth-client
mode = 0660
user = postfix
group = mail
}
}
}

dict {
#quota = mysql:/etc/dovecot-dict-quota.conf
}

plugin {
quota = maildir:storage=10240:messages=1000
acl = vfile:/etc/dovecot-acls
#convert_mail = mbox:%h/mail
trash = /etc/dovecot-trash.conf
}
ssl = yes


My Dovecot -sql.

driver = mysql

connect = host=localhost dbname=maildb user=mailuser password=mailpwd

default_pass_scheme = MD5

user_query = SELECT concat('/var/vmail/', maildir) as home, concat('maildir:/var/vmail/', maildir) as mail, 150 AS uid, 8 AS gid, concat('maildir:storage=', quota) AS quota FROM mailbox WHERE username = '%u' AND active = '1'
# fast but now so nice:-)
#user_query = SELECT '/var/vmail/%d/%n' as home, 'maildir:/var/vmail/%d/%n' as mail, 150 AS uid, 8 AS gid, concat('dirsize:storage=', quota) AS quota FROM mailbox WHERE username = '%u' AND active = '1'
password_query = SELECT username as user, password, concat('/var/vmail/', maildir) as userdb_home, concat('maildir:/var/vmail/', maildir) as userdb_mail, 150 as userdb_uid, 8 as userdb_gid FROM mailbox WHERE username = '%u' AND active = '1'
# fast but now so nice:-)
#password_query = SELECT username as user, password, '/var/vmail/%d/%n' as userdb_home, 'maildir:/var/vmail/%d/%n' as userdb_mail, 150 as userdb_uid, 8 as userdb_gid FROM mailbox WHERE username = '%u' AND active = '1'

Any suggestion?

Regards
Reply With Quote
Sponsored Links
  #2  
Old 8th February 2011, 07:41
aberrio aberrio is offline
Senior Member
 
Join Date: Sep 2007
Posts: 150
Thanks: 13
Thanked 3 Times in 3 Posts
Default

Hello,

SOLVED the error ...

Feb 6 16:22:04 xxxx postfix/smtpd[13015]: warning: SASL: Connect to private/auth failed: No such file or .

But now when I add the following line to my main.cf to use Dovecot for authentication

smtpd_sasl_type = dovecot

i am getting the following error.

warning: SASL: Connect to /var/run/dovecot/ failed: Permission denied
Feb 10 20:36:30 musica postfix/smtpd[2974]: fatal: no SASL authentication mechanisms


Here is the result for postconf -a
cyrus
dovecot


Any ideas?

Kind regards,

AL

Regards,

AL

Last edited by aberrio; 11th February 2011 at 05:27.
Reply With Quote
  #3  
Old 11th February 2011, 16:58
aberrio aberrio is offline
Senior Member
 
Join Date: Sep 2007
Posts: 150
Thanks: 13
Thanked 3 Times in 3 Posts
Default

Hi,

Any update on this issue?
Reply With Quote
  #4  
Old 14th February 2011, 17:06
aberrio aberrio is offline
Senior Member
 
Join Date: Sep 2007
Posts: 150
Thanks: 13
Thanked 3 Times in 3 Posts
Default

Hi,

Anybody on this?

Regards,

Al
Reply With Quote
  #5  
Old 15th February 2011, 11:48
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
Default

It's like you are not allowed to use dovecot. Post the result here for

Code:
ls -al /var/run/ |grep dovecot
and

Code:
ls -al /var/run/dovecot/
Reply With Quote
The Following User Says Thank You to alleks For This Useful Post:
aberrio (15th February 2011)
  #6  
Old 15th February 2011, 15:36
aberrio aberrio is offline
Senior Member
 
Join Date: Sep 2007
Posts: 150
Thanks: 13
Thanked 3 Times in 3 Posts
Default

Hello,


Finally SOLVED.

I had to change the following line in my main.conf

path = /var/run/dovecot/

to

path = /var/run/dovecot/auth-client

I am able to send email with Outlook but unable to do it with claws, this is another issue.

Kind regards,

Al
Reply With Quote
The Following User Says Thank You to aberrio For This Useful Post:
falko (15th February 2011)
  #7  
Old 15th February 2011, 15:38
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
 
Default

Glad that you had solved the problem.
Reply With Quote
The Following User Says Thank You to alleks For This Useful Post:
aberrio (21st February 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email Sending and receiving problems kennethwu Server Operation 1 7th January 2011 14:57
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 17:59
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 19:16
Postfix can't received email from exterior astra2000 Server Operation 5 18th October 2009 00:26
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 22:12


All times are GMT +2. The time now is 23:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.