#1  
Old 12th February 2011, 21:52
unsichtbare unsichtbare is offline
Senior Member
 
Join Date: Sep 2007
Posts: 111
Thanks: 18
Thanked 7 Times in 6 Posts
Default Subdomain not working

I have created a new subdomain in my ISPconfig 3 as follows:

Host: webmail
Domain: mysite.net
Redirect type: R,L
Redirect path: hosting.myserver.com/webmail
Active: yes

Nothing seems to get through. At the address specified, I get a "server not found".
Do I also need to set-up DNS separately? Should this not be done through the vhosts configuration?

Code:
" ============================================================================
" Netrw Directory Listing                                        (netrw v136)
"   /etc/apache2/sites-available
"   Sorted by      name
"   Sort sequence: [\/]$,\<core\%(\.\d\+\)\=\>,\.h$,\.c$,\.cpp$,*,\.o$,\.obj$,\.info$,\.swp$,\.bak$,\~$
"   Quick Help: <F1>:help  -:go up dir  D:delete  R:rename  s:sort-by  x:exec
" ============================================================================
../
apps.vhost
XXXXXX.com.vhost
default
default-ssl
ispconfig.conf
ispconfig.vhost
mysite.net.vhost
.swp
Code:
<Directory /var/www/mysite.net>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/mysite.net/web
  
    ServerName mysite.net
    ServerAlias www.mysite.net 
    ServerAlias webmail.mysite.net
    ServerAdmin webmaster@mysite.net

    ErrorLog /var/log/ispconfig/httpd/mysite.net/error.log


    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html
	
    <Directory /var/www/mysite.net/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/clientX/webX/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>


    # suexec enabled
    SuexecUserGroup webX clientX
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
      
	  # SocketPath /tmp/fcgid_sock/
	  
	  # IdleTimeout n (3600 seconds)
	  # An idle fastcgi application will be terminated after IdleTimeout seconds.
      IdleTimeout 3600
	  
	  # ProcessLifeTime n (7200 seconds)
      # A fastcgi application will be terminated if lifetime expired, even no error is detected.
      ProcessLifeTime 7200
	  
	  # MaxProcessCount n (1000)
      # The max count of total fastcgi process count.
      # MaxProcessCount 1000
      
	  # DefaultMinClassProcessCount n (3)
      # The minimum number of fastcgi application instances for any one fastcgi application.
      # Idle fastcgi will not be killed if their count is less than n
      # Set this to 0, and tweak IdleTimeout
	  DefaultMinClassProcessCount 0
	  
	  # DefaultMaxClassProcessCount n (100)
      # The maximum number of fastcgi application instances allowed to run for
      # particular one fastcgi application.
      DefaultMaxClassProcessCount 100
	  
	  # IPCConnectTimeout n (3 seconds)
      # The connect timeout to a fastcgi application.
      IPCConnectTimeout 8
	  
	  # IPCCommTimeout n (20 seconds)
      # The communication timeout to a fastcgi application. Please increase this
      # value if your CGI have a slow initialization or slow respond.
      IPCCommTimeout 360
      
	  # BusyTimeout n (300 seconds)
      # A fastcgi application will be terminated if handing a single request
      # longer than busy timeout.
	  BusyTimeout 300
	  
    </IfModule>
    <Directory /var/www/mysite.net/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/webX/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
	<Directory /var/www/clients/clientX/webX/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/webX/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^webmail.mysite.net [NC]
    RewriteRule   ^/(.*)$ http://XXX.XXX.com/webmail/$1  [R,L]

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId webX clientX
    </IfModule>

    <IfModule mod_dav_fs.c>
      # DO NOT REMOVE THE COMMENTS!
      # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
      # WEBDAV BEGIN
      # WEBDAV END
    </IfModule>


</VirtualHost>
__________________
Ubuntu 14.04 - The Perfect Setup
ISPConfig 3.0.5
http://www.vmsources.com

Last edited by unsichtbare; 13th February 2011 at 17:33.
Reply With Quote
Sponsored Links
  #2  
Old 13th February 2011, 17:12
germinator germinator is offline
Member
 
Join Date: Nov 2010
Location: /root
Posts: 51
Thanks: 7
Thanked 16 Times in 9 Posts
Default

yes, you do need to create a DNS entry for it .. create an "A" record pointing at the ipaddress your site is located on, leave the TTL and check "active" with the hostname webmail.shannonlynn.net

are you managing your domain through your dns server or do you one from the provider you bought the domain from?

Last edited by germinator; 13th February 2011 at 17:18.
Reply With Quote
The Following User Says Thank You to germinator For This Useful Post:
unsichtbare (13th February 2011)
  #3  
Old 13th February 2011, 17:23
unsichtbare unsichtbare is offline
Senior Member
 
Join Date: Sep 2007
Posts: 111
Thanks: 18
Thanked 7 Times in 6 Posts
 
Default

OK, works now.

This was unclear in documentation and I had already tried it without success.

I must have fat-fingered something on my previous attempt to create an a-record for webmail!
__________________
Ubuntu 14.04 - The Perfect Setup
ISPConfig 3.0.5
http://www.vmsources.com
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Qemu-kVM setup vm using 2 NIC's are not working muzi Technical 1 14th February 2011 23:27
auto subdomain not working, 403 error. ispconfig 3 SeanT Installation/Configuration 18 4th October 2010 19:39
Proper subdomain support. arcain6 Feature Requests 1 28th June 2010 11:15
How Subdomain works (for documentation) moglia Developers' Forum 7 19th June 2010 23:14
auto update svn working copy donix Installation/Configuration 0 9th June 2010 21:59


All times are GMT +2. The time now is 19:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.