#1  
Old 2nd March 2011, 10:08
scottrill2 scottrill2 is offline
HowtoForge Supporter
 
Join Date: Dec 2009
Posts: 93
Thanks: 21
Thanked 2 Times in 1 Post
Default Apache Directives questions

Hello folks,

A few questions in regard to apache directives. On my Ispconfig 2 server I used suPHP and had multiple php.ini files.

For instance in the "administrator" folder of one of my sites I had a php.ini file allowing really large uploads in order for a joomla extension to work, but yet in my root folder I had a php.ini with more stringent settings for the public so they couldnt upload a monster file.

In ISPConfig 3 I am using fast-cgi and I understand I can no longer use php.ini files. my question is how can I tell ISPConfig3 to apply this php setting to admin folder but yet this setting to root web folder etc?

I tried using the directory syntax in the apache directives like so:

<Directory "/var/www/clients/client2/web1/web/administrator/">
loose php values here
</Directory>

<Directory "/var/www/clients/client2/web1/web/">
strict php values here
</Directory>

But that doesnt work. Of course putting the commands in the "Custom php.ini settings" works, but then it applies the settings across the board.


As always thoughts and suggestions appreciated folks,

Scott
Reply With Quote
Sponsored Links
  #2  
Old 2nd March 2011, 10:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

PHP.ini values are always set per vhost, the directory syntax is not supported by suphp.

Quote:
In ISPConfig 3 I am using fast-cgi and I understand I can no longer use php.ini files.
Thats wrong. the php.ini setting on the options tab works for php-cgi, suphp and php-fcgi as described in the manual.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th March 2011, 15:08
scottrill2 scottrill2 is offline
HowtoForge Supporter
 
Join Date: Dec 2009
Posts: 93
Thanks: 21
Thanked 2 Times in 1 Post
Default Thanks for the reply Till

In suphp I used individual php.ini files in admin folder etc etc. I am probably not conveying my thoughts clearly I do apologize. here is an example.

On the Ispconfig 2 server with suphp I had for instance the following:

In folder /var/www/web1/web/ - php.ini with settings like (upload_max_size = 5M & post_max_size = 10M)

In folder /var/www/web1/web/administrator/ - php.ini with settings like (upload_max_size = 25M & post_max_size = 30M)


I did the above so that family could upload photos etc but not try to upload like a whole home movie etc. But yet for some joomla extensions located in the administrator folder I would receive errors because some of the extensions needed larger upload allowances.

Now that I am trying to switch to ISPConfig 3 with Fastcgi and suexec, I would like to have those same settings. Is that possible?

Quote:
Originally Posted by till View Post
PHP.ini values are always set per vhost, the directory syntax is not supported by suphp.
Can the directory syntax be used with fastcgi? Or should I switch back to suphp so that I can go back to mukltiple php.i ni files in diff folders?


Thanks as always,

Scott Cottrill
Reply With Quote
  #4  
Old 4th March 2011, 15:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

php.ini settings are set per vhost and not per directory for php-fcgi.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
scottrill2 (4th March 2011)
  #5  
Old 4th March 2011, 18:44
scottrill2 scottrill2 is offline
HowtoForge Supporter
 
Join Date: Dec 2009
Posts: 93
Thanks: 21
Thanked 2 Times in 1 Post
 
Default

Cool Deal Till,

Thanks for the clarification. The only time I needed the larger upload allowances was when I was installing a big extension etc. I could always increase the upload size under custom php.ini settings and then set it back to normal after I am done installing module etc.


Thank you as always,

Scott
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL don't work please help me walner8080 Installation/Configuration 8 26th September 2010 13:07
trying to install roundcubemail ressel Installation/Configuration 13 24th December 2009 21:13
problems with suexec gobokster Installation/Configuration 7 7th May 2009 14:33
FTP cannot open remote folder!?! andysm849 Server Operation 23 17th October 2008 00:34
Can't start apache Musty Server Operation 12 9th March 2008 14:58


All times are GMT +2. The time now is 01:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.