#1  
Old 11th February 2011, 01:05
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default update packages on ubuntu

i am running Ubuntu Linux 9.10 and have not checked on it for a bit. today i logged into webmin and found i had 88 package updates. i ran the updater and they all failed what should i do to force them to update?


thanks
kwick

Last edited by kwickcut; 11th February 2011 at 06:06.
Reply With Quote
Sponsored Links
  #2  
Old 11th February 2011, 14:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

What's the error message you got?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th February 2011, 19:16
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default

this is just a few they are all the same

Code:
Now updating apache2 ..

      Installing package(s) with command apt-get -y install apache2 ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        apache2: Depends: apache2-mpm-worker (>= 2.2.12-1ubuntu2.4) but it is not going to be installed or
                          apache2-mpm-prefork (>= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed or
                          apache2-mpm-event (>= 2.2.12-1ubuntu2.4) but it is not going to be installed or
                          apache2-mpm-itk (>= 2.2.12-1ubuntu2.4) but it is not going to be installed
                 Depends: apache2.2-common (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!


Now updating apache2-doc ..

      Installing package(s) with command apt-get -y install apache2-doc ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!


Now updating apache2-mpm-prefork ..

      Installing package(s) with command apt-get -y install apache2-mpm-prefork ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        apache2-mpm-prefork: Depends: apache2.2-common (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
                             Depends: apache2.2-bin (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!


Now updating apache2-suexec ..

      Installing package(s) with command apt-get -y install apache2-suexec ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!


Now updating apache2-utils ..

      Installing package(s) with command apt-get -y install apache2-utils ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        apache2-utils: Depends: libssl0.9.8 (>= 0.9.8g-16ubuntu3.2) but 0.9.8g-16ubuntu3.1 is to be installed
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!


Now updating apache2.2-bin ..

      Installing package(s) with command apt-get -y install apache2.2-bin ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        apache2-mpm-prefork: Depends: apache2.2-bin (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
        apache2.2-bin: Depends: libssl0.9.8 (>= 0.9.8g-16ubuntu3.2) but 0.9.8g-16ubuntu3.1 is to be installed
        apache2.2-common: Depends: apache2.2-bin (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!


Now updating apache2.2-common ..

      Installing package(s) with command apt-get -y install apache2.2-common ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        apache2: Depends: apache2.2-common (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
        apache2-mpm-prefork: Depends: apache2.2-common (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
        apache2.2-common: Depends: apache2.2-bin (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!


Now updating bind9-host ..

      Installing package(s) with command apt-get -y install bind9-host ..

      dpkg: dependency problems prevent configuration of webmin:
       webmin depends on apt-show-versions; however:
        Package apt-show-versions is not installed.
      dpkg: error processing webmin (--configure):
       dependency problems - leaving unconfigured
      Errors were encountered while processing:
       webmin
      Reading package lists...
      Building dependency tree...
      Reading state information...
      You might want to run `apt-get -f install' to correct these:
      The following packages have unmet dependencies:
        bind9-host: Depends: libbind9-50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                    Depends: libdns53 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                    Depends: libisc50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                    Depends: libisccfg50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                    Depends: liblwres50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
        webmin: Depends: apt-show-versions but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      .. install failed!
thanks for any input

kwick
Reply With Quote
  #4  
Old 12th February 2011, 01:45
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
 
Default

problem solver i had to install apt-show-versions and also had to forward port 22 i always did everything on box



kwick
__________________
Operating system Ubuntu Linux 10.04.4
ISPConfig Version: 3.0.4.3
Webmin version 1.580
Kernel and CPU Linux 2.6.32-40-server on x86_64
Processor information AMD Phenom(tm) II X4 945 Processor, 4 cores
Real memory 4.0 GB total
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vhosts...conf not synced to changes crypted General 50 24th April 2010 00:54
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19


All times are GMT +2. The time now is 23:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.