#1  
Old 3rd February 2011, 22:13
lightning200mph lightning200mph is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ubuntu 10.10 /webmail

I've setup my server following the perfect server Ubuntu 10.10 guide and at the end of the 5th page it shows how to add /webmail to access the squirrel mail through the web address. The problem I'm having is that after I do those steps my browser downloads a file instead of opening the login page. If i use the ip/webmail then it will show the login screen. Is there another step I'm missing or could it be I have configured something wrong.
Reply With Quote
Sponsored Links
  #2  
Old 4th February 2011, 15:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Did you enable PHP for your web sites in ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th February 2011, 21:05
lightning200mph lightning200mph is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can get the login screen to come up now, I switched from suphp to mod-php. But now I'm getting an error when trying to log in.

"Error opening ../config/default_pref
Could not create initial preference file!
/var/lib/squirrelmail/data/ should be writable by user www-data
Please contact your system administrator and report this error."
Reply With Quote
  #4  
Old 6th February 2011, 21:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's the output of
Code:
ls -la /var/lib/squirrelmail/data/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th February 2011, 22:42
lightning200mph lightning200mph is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the output:
Code:
total 12
drwx-wx--- 2 root     www-data 4096 2011-02-05 15:51 .
drwxr-xr-x 3 root     root     4096 2011-02-02 16:37 ..
-rw------- 1 www-data www-data  108 2011-02-05 15:51 postmaster@"website".com.pref
Another issue that is happening is in chrome when i type in .com/webmail is will download the file of the page, but if i type out the whole /webmail/src/login.php it opens the page just fine. Now in IE just /webmail pulls up the log in page.
Reply With Quote
  #6  
Old 7th February 2011, 18:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Try
Code:
chmod 770 /var/lib/squirrelmail/data/
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 9th February 2011, 19:41
lightning200mph lightning200mph is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I don't know what happened, but I did the chmod and that didn't help. The server was doing some weird stuff so I wiped the drive and reinstalled. Everything is working as it should now.

Thanks for all of the input and help.
Zach
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High quality video security with Ubuntu desktop 10.10, Zoneminder 1.24.x and webcam. letsharehowto HOWTO-Related Questions 7 18th December 2011 14:01
Ubuntu 10.10 Total Freeze jackgow Installation/Configuration 3 25th December 2010 18:17
Problem send/receive Courier+Postfix+Squirrelmail Pirk Installation/Configuration 2 21st May 2010 14:26
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 21:31
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 14:49


All times are GMT +2. The time now is 17:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.