Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd February 2011, 10:38
abintipl abintipl is offline
Senior Member
 
Join Date: Nov 2010
Posts: 150
Thanks: 31
Thanked 5 Times in 5 Posts
Default SerVer down After running Aptitude

hello all,

My server was running fine on Debain Lenny with ISPconfig 3 latest Stable version

Under monitor I was getting Waring In Blue which requires an update

After reading ISPConfig manual Page No.222, I ran a command

aptitude update

then

aptitude safe-upgrade

Now I am not able to open my website, I get an Error

Oops! This link appears to be broken.

Please advice

Your help would be sincerely appreciated.

Thanks

Abin
Reply With Quote
Sponsored Links
  #2  
Old 2nd February 2011, 12:36
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 39 Times in 33 Posts
Default

as a start try restarting apache.

From the shell:
Code:
/etc/init.d/apache2 restart
I probably can't help much more but if you post the result of that back it will be a good starting point to help others diagnose your problem.
Reply With Quote
  #3  
Old 2nd February 2011, 12:47
abintipl abintipl is offline
Senior Member
 
Join Date: Nov 2010
Posts: 150
Thanks: 31
Thanked 5 Times in 5 Posts
Default Aptitude

Hello,

Thanks for your reply, I have run the said command & results are as under;

~# /etc/init.d/apache2 restart

Restarting web server: apache2[Wed Feb 02 11:43:49 2011] [warn] NameVirtualHost*:80 has no VirtualHosts
[Wed Feb 02 11:43:50 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
failed!


regards,

Abin
Reply With Quote
  #4  
Old 2nd February 2011, 13:49
abintipl abintipl is offline
Senior Member
 
Join Date: Nov 2010
Posts: 150
Thanks: 31
Thanked 5 Times in 5 Posts
Default tmp folder files replaced

Hello,

I have been searching hard on my server about the above said problem & have seen that my server "tmp" folder which was containing Ispconfig files are replaced with the following two folders;

.ICE-unix

.X11-unix

The above 2 folders does not contain any files in their respective folders.

Please advice should I run ISPconfig install again

Your help would be highly appreciated.

Thanks

Abin
Reply With Quote
  #5  
Old 3rd February 2011, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What are the outputs of
Code:
netstat -tap
and
Code:
ls -la /tmp
? Have you tried to reboot the server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 3rd February 2011, 13:54
abintipl abintipl is offline
Senior Member
 
Join Date: Nov 2010
Posts: 150
Thanks: 31
Thanked 5 Times in 5 Posts
Default Output

Dear Sir,

here is output;


# netstat -tap

Active Internet connections (servers and established)

Proto Recv-Q Send-Q Local Address Foreign Address State
PID/Program name
tcp 0 0 *op3s *:* LISTEN
2141/dovecot
tcp 0 0 localhost:10024 *:* LISTEN
1148/amavisd (maste
tcp 0 0 localhost:10025 *:* LISTEN
2090/master
tcp 0 0 *:mysql *:* LISTEN
3643/mysqld
tcp 0 0 localhost:11211 *:* LISTEN
1998/memcached
tcp 0 0 *op3 *:* LISTEN
2141/dovecot
tcp 0 0 *:imap2 *:* LISTEN
2141/dovecot
tcp 0 0 localhost:spamd *:* LISTEN
1277/spamd.pid
tcp 0 0 *:sunrpc *:* LISTEN
1003/portmap
tcp 0 0 *:www *:* LISTEN
6954/inetd
tcp 0 0 *:tproxy *:* LISTEN
2006/mono
tcp 0 0 *:ftp *:* LISTEN
6983/pure-ftpd (SER
tcp 0 0 10.180.89.168:domain *:* LISTEN
1103/named
tcp 0 0 abc.mydomain.comt:domain *:* LISTEN
1103/named
tcp 0 0 localhost:domain *:* LISTEN
1103/named
tcp 0 0 *:ssh *:* LISTEN
3426/sshd
tcp 0 0 localhost:1015 *:* LISTEN
2111/famd
tcp 0 0 *:smtp *:* LISTEN
2090/master
tcp 0 0 localhost:953 *:* LISTEN
1103/named
tcp 0 0 *:imaps *:* LISTEN
2141/dovecot
tcp 0 0 localhost:mysql localhost:52919 ESTABLISHED
3643/mysqld
tcp 0 0 localhost:mysql localhost:44817 ESTABLISHED
3643/mysqld
tcp 0 0 localhost:44817 localhost:mysql ESTABLISHED
1225/amavisd (ch8-a
tcp 0 52 abc.mydomain.c:ssh band-xx.xxx:xxxx ESTABLISHED
28828/0
tcp 0 0 localhost:52919 localhost:mysql ESTABLISHED
1224/amavisd (ch9-a
tcp6 0 0 [::]:81 [::]:* LISTEN
5864/lighttpd
tcp6 0 0 [::]:ftp [::]:* LISTEN
6983/pure-ftpd (SER
tcp6 0 0 [::]:domain [::]:* LISTEN
1103/named
tcp6 0 0 [::]:ssh [::]:* LISTEN
3426/sshd
tcp6 0 0 ::1%6978992:953 [::]:* LISTEN
1103/named

~#

2nd Output is as under;

~# ls -la /tmp
total 16

drwxrwxrwt 4 root root 4096Feb 3 12:50 .
drwxr-xr-x 20 root root 4096 Feb 2 09:10 ..
drwxrwxrwt 2 root root 4096 Feb 2 09:10 .ICE-unix
drwxrwxrwt 2 root root 4096 Feb 2 09:10 .X11-unix
:~#


regards,

Abin
Reply With Quote
  #7  
Old 3rd February 2011, 13:56
abintipl abintipl is offline
Senior Member
 
Join Date: Nov 2010
Posts: 150
Thanks: 31
Thanked 5 Times in 5 Posts
Default Reboot

Quote:
Originally Posted by falko View Post
What are the outputs of
Code:
netstat -tap
and
Code:
ls -la /tmp
? Have you tried to reboot the server?
Yes, I did reboot the server when I was unable to access my webserver

regards,

Abin
Reply With Quote
  #8  
Old 4th February 2011, 14:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
tcp 0 0 *:www *:* LISTEN 6954/inetd
You have some inetd process listening on port 80 instead of Apache. Please check your inetd configuration and disable that process, then restart inetd and then Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 5th February 2011, 14:49
abintipl abintipl is offline
Senior Member
 
Join Date: Nov 2010
Posts: 150
Thanks: 31
Thanked 5 Times in 5 Posts
 
Default Thanks

Quote:
Originally Posted by falko View Post
You have some inetd process listening on port 80 instead of Apache. Please check your inetd configuration and disable that process, then restart inetd and then Apache.
Dear Sir,

Thank you so much for your kind support & help

Now my Server is UP & running fine

regards,

Abin
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with mail server and subdomains MyKE General 7 26th February 2010 10:18
FTP cannot open remote folder!?! andysm849 Server Operation 23 16th October 2008 23:34
mail delivered in mbox patfee Installation/Configuration 8 11th December 2007 13:58
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44


All times are GMT +2. The time now is 22:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.