#1  
Old 1st February 2011, 00:01
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 40 Times in 34 Posts
Default Possible php problem

Today a slave on lenny VDS stopped resonding and had to be rebooted. On reboot ispconfig is failing to complete jobs on this slave.

I've put the slave into debug mode and it's reporting the following:
Quote:
There is already an instance of server.php running. Exiting.
I've put a php info file on that server and it reports:
Quote:
PHP Version 5.2.17-0.dotdeb.0
A few weeks ago I added extra sources:
Quote:
# deb cdrom:[Debian GNU/Linux 5.0.6 _Lenny_ - Official amd64 NETINST Binary-1 20100905-11:18]/ lenny main

#deb cdrom:[Debian GNU/Linux 5.0.6 _Lenny_ - Official amd64 NETINST Binary-1 20100905-11:18]/ lenny main

deb http://www.mirrorservice.org/sites/f...an.org/debian/ lenny main non-free contrib
deb-src http://www.mirrorservice.org/sites/f...an.org/debian/ lenny main non-free contrib

# deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

deb http://ftp.uk.debian.org/debian/ lenny main
deb-src http://ftp.uk.debian.org/debian/ lenny main

deb-src http://security.debian.org/ lenny/updates main
deb http://security.debian.org/ lenny/updates main

# deb http://volatile.debian.org/debian-volatile lenny/volatile main
# deb-src http://volatile.debian.org/debian-volatile lenny/volatile main

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all
and installed php5-gd.

When I do an apt-get upgrade I get two packages kept back, mysql client and mysql server.

Any ideas what is happening here?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 1st February 2011, 15:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

What's the output of
Code:
ps aux | grep server.php
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st February 2011, 20:58
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 40 Times in 34 Posts
Default Urgent help requested please

This is the result:
Quote:
root 22174 0.0 0.1 5164 856 pts/0 S+ 19:55 0:00 grep server.php
Apache has now taken itself completely offline at some point this evening.

If I try to restart it, it reports this:
Quote:
/var/run/apache2# /etc/init.d/apache2 start
Starting web server: apache2rm: cannot remove `/var/run/apache2/*ssl_scache*': Read-only file system
(30)Read-only file system: apache2: could not open error log file /var/log/apache2/error.log.
Unable to open logs
failed!
This is the more recent content of the apache error log:
Quote:
[Tue Feb 01 00:51:06 2011] [notice] Digest: done
[Tue Feb 01 00:51:06 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Feb 01 00:51:06 2011] [warn] RSA server certificate CommonName (CN) `BadBison' does NOT match server name!?
[Tue Feb 01 00:51:06 2011] [notice] Apache/2.2.9 (Debian) DAV/2 PHP/5.2.17-0.dotdeb.0 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Tue Feb 01 00:55:09 2011] [notice] caught SIGTERM, shutting down
[Tue Feb 01 00:55:10 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Feb 01 00:55:10 2011] [warn] RSA server certificate CommonName (CN) `BadBison' does NOT match server name!?
[Tue Feb 01 00:55:10 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Tue Feb 01 00:55:10 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 01 00:55:10 2011] [notice] Digest: done
[Tue Feb 01 00:55:10 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Feb 01 00:55:10 2011] [warn] RSA server certificate CommonName (CN) `BadBison' does NOT match server name!?
[Tue Feb 01 00:55:10 2011] [notice] Apache/2.2.9 (Debian) DAV/2 PHP/5.2.17-0.dotdeb.0 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Tue Feb 01 01:08:03 2011] [notice] caught SIGTERM, shutting down
[Tue Feb 01 01:08:04 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Feb 01 01:08:04 2011] [warn] RSA server certificate CommonName (CN) `BadBison' does NOT match server name!?
[Tue Feb 01 01:08:04 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Tue Feb 01 01:08:04 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 01 01:08:04 2011] [notice] Digest: done
[Tue Feb 01 01:08:04 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Feb 01 01:08:04 2011] [warn] RSA server certificate CommonName (CN) `BadBison' does NOT match server name!?
[Tue Feb 01 01:08:04 2011] [notice] Apache/2.2.9 (Debian) DAV/2 PHP/5.2.17-0.dotdeb.0 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Tue Feb 01 01:12:17 2011] [notice] mod_fcgid: call /var/www/gohosti.com/web/index.php with wrapper /var/www/php-fcgi-scripts/web96/.php-fcgi-starter
[Tue Feb 01 01:59:17 2011] [notice] mod_fcgid: call /var/www/bournemouthfacialcare.com/web/index.php with wrapper /var/www/php-fcgi-scripts/web86/.php-fcgi-starter
Any urgent help would me much appreciated to get apache back on line please.

Last edited by Toucan; 1st February 2011 at 21:05.
Reply With Quote
  #4  
Old 2nd February 2011, 12:38
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 40 Times in 34 Posts
Default

after
Code:
aptitude upgrade
and a reboot apache now appears to be back on line.

Hopefully this has cured the problem, but if someone could clear up for me what sources I should and should not have available that would be appreciated.
Reply With Quote
  #5  
Old 2nd February 2011, 15:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Starting web server: apache2rm: cannot remove `/var/run/apache2/*ssl_scache*': Read-only file system
(30)Read-only file system: apache2: could not open error log file /var/log/apache2/error.log.
There seems to have been a problem with one of your partitions. Maybe you should check your hard drive and file system for errors.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 3rd February 2011, 00:24
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 40 Times in 34 Posts
Default

Ok thanks. Just so I don't go off in the wrong direction with this one, as this is a virtual server, should I be checking the file system from my shell or be asking the rack provider to check the hard drive of the greater machine?

The first time it hung they said it did report a panic message but couldn't recover the details.
Reply With Quote
  #7  
Old 3rd February 2011, 13:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

Good question... Maybe you should ask the rack provider.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Cannot add Mailboxes after PHP-Update hfr Installation/Configuration 5 7th November 2009 20:09
Rewrites problem with trailing "/" (Slash) on non-www domain.ext yuro Installation/Configuration 1 15th October 2008 10:36
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 17:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.