Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2011, 16:53
scibile scibile is offline
Junior Member
 
Join Date: Jan 2007
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Default Squirrelmail-IMAP-courier performance problem

Hi everybody,

I've installed a new Ubuntu server 10.04 with ISPconfig 3 (3.0.3.2).

I've a problem with some email account with squirrelmail:
when I log in squirrelmail the navigation is very very slow.
I think the problem is between IMAP-courier - squirrelmail.

I see an apache process with 100% of CPU usage for 20-30 seconds every click I do in squirrelmail.

The email account have about 20 emails.
If I move the email files (in cur dir) from this user to another user that works correctly this new account will have the same problem.

Can someone help me?

I din't found anything in different log files (syslog, auth log, ect.)

Thankyou
Cristian
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2011, 17:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

Have you configured squirrelmail with the correct default settings for courier with the squirrelmail-configure command?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
scibile (8th March 2011)
  #3  
Old 8th March 2011, 17:43
scibile scibile is offline
Junior Member
 
Join Date: Jan 2007
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Till,

yes, the squirrelmail is configured with default setting.

I found out that the issue is only witt it_IT language.
I changed the language to english or german everything works correcty...

I found this in apache error.log:

[Tue Mar 08 17:29:35 2011] [error] [client X.X.X.X] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /usr/share/squirrelmail/functions/strings.php on line 1246

Thankyou
Reply With Quote
  #4  
Old 8th March 2011, 17:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

Then there is most likely a problem in the it_IT language file from squirrelmail. You can e.g. try to download the latest language file from the suirrelmail project directly, maybe the issue is already fixed.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 9th March 2011, 11:03
scibile scibile is offline
Junior Member
 
Join Date: Jan 2007
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Hi everybody,

I found out the problem:

in the file squirrelmail/functions/i18n.php I've changed the following values:

************************************************** ******
$languages['it_IT']['NAME'] = 'Italian';
$languages['it_IT']['ALTNAME'] = 'Italiano';
$languages['it_IT']['CHARSET'] = 'utf-8';
$languages['it_IT']['LOCALE'] = array('it_IT.UTF-8','it_IT.UTF-8','it_IT');
$languages['it']['ALIAS'] = 'it_IT';
************************************************** ******

TO

************************************************** ******
$languages['it_IT']['NAME'] = 'Italian';
$languages['it_IT']['ALTNAME'] = 'Italiano';
$languages['it_IT']['CHARSET'] = 'iso-8859-1';
$languages['it_IT']['LOCALE'] = array('it_IT.ISO8859-1','it_IT.ISO-8859-1','it_IT');
$languages['it']['ALIAS'] = 'it_IT';
************************************************** ******

Now squirrel is running fine

Thankyou Till for your Help.

Cristian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why did Squirrelmail, Dovecot/IMAP & Outbound mail break? websissy Technical 4 29th October 2009 22:39
Courier Imap problem sheshes Server Operation 6 26th August 2009 18:03
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.10) VTCop HOWTO-Related Questions 9 9th April 2009 16:17
Courier IMAP and Squirrelmail issue with Maildir raymonvdm Installation/Configuration 2 4th April 2009 05:26
Performance Problem sigma Tips/Tricks/Mods 3 19th December 2006 03:29


All times are GMT +2. The time now is 06:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.