Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th January 2011, 13:33
James A James A is offline
Member
 
Join Date: Jan 2011
Posts: 51
Thanks: 11
Thanked 0 Times in 0 Posts
Default Mailfilter folders / files not created

Hi, we have been using ISPConfig successfully for about a year. Recently we found that adding auto responders / custom mail filters stopped working as the required files and directories weren't being created wasn't (we were running V3.0.1.6 at the time).

Since finding the issue we upgraded to 3.0.3.2 believing this may fix the issue. Unfortunately it didn't so we started to look into it in a lot greater detail.

First thing we found after enabling debug was that the job queue had backed up with the .ispconfig_lock file being present. We manually deleted this, however this was recreated everytime server.sh ran and no job progress occurred.

As we had created numerous jobs ourselves when testing the autoresponder we decided the most appropriate thing was to try and clear the job queue. There were no records in the sys_remoteuser and we followed earlier advice to clear the sys_datalog which then cleared the queue and allowed server.sh to run successfully (or so it appears, no more permanent .ispconfig_lock file).

Unfortunately though, we are still not able to create the autoresponder files from the GUI. and are having to manually create the files by copying the autoresponder.master and creating a vacation.message in order to get it working where required. It appears that any attempt to create files under the mailfilters directory is failing.

For further detail, we are using courier-imap with the maildrop mailfilter syntax configured. From what we understand, it's the maildrop plugin that creates these files / folders. There is a symlink in the plugins-enabled folder for this.

Final things to note:
We don't appear to get any update jobs processed by server.sh and they are not appearing in the job queue. Server.sh just responds with no updates even after updates have clearly been made.

Even with debug enabled we don't appear to get any error or warning messages, and apart from this issue the servers appear to work fine.

Any help would be gratefully appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2011, 16:13
manticore01 manticore01 is offline
Junior Member
 
Join Date: Jan 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same Issue

Hi James

I seem to be experiencing the same issue aswell, its as if the maildrop plugin isnt firing as this is what creates the mailfilter directories if im not mistaken.
Reply With Quote
  #3  
Old 28th January 2011, 17:17
James A James A is offline
Member
 
Join Date: Jan 2011
Posts: 51
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Hi Manticore

Yeah this is a really weird one although I'm sure there's an easy fix. No doubt when Till or Falco get a chance to read this post they'll point us in the right direction.
Reply With Quote
  #4  
Old 29th January 2011, 15:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

@James: Most likely your problem is not related to mail filters. I guess that your system daemon is not writing changes at all at the moment. Please check if other changes like creating a new website gets written to disk.


@manticore: Please check that you reaally use courier. In almost al current poerfect setup guides we use dovecot and not courier.

I dont think that there is a problem at all, the folders that you think are missing are only used by courier pop3 / imap daemon. So on all other systems that use dovecot, thes efolders are not there and shall not be there as dovecot stores the rules in the .sieve file which is in the maildir an not a separate mail
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 31st January 2011, 10:39
James A James A is offline
Member
 
Join Date: Jan 2011
Posts: 51
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Hi Till

As suggested I tried creating a website and your assumption was correct, no files / folders were created in the var/www/clients directory. Looking at the job queue nothing appears to have been added and no updates found when server.sh ran.

It is probably worth noting if I create a new email address then I do get folders created under the var/vmail/ folder.

So if the problem is that the system daemon isn't writing changes how do I fix that (apologies if this is a stupid question)?

Thanks
Reply With Quote
  #6  
Old 10th March 2011, 17:09
James A James A is offline
Member
 
Join Date: Jan 2011
Posts: 51
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Hi All

This is still a problem for me and I would really appreciate some help.

If the issue is as Till suggests, that the system Daemon isn't writing changes at all at the moment how do I get it going again. Please note I'm assuming this is correct as I can't create a new website but I can create email accounts under var/vmail.

Any help would be appreciated
Reply With Quote
  #7  
Old 10th March 2011, 17:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
but I can create email accounts under var/vmail.
Email accounts get created automatically by postfix and maildrop or deliver when a email arrives, this is no indication that any config files get written to disk.

So the jobqueue is empty at the moment?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 10th March 2011, 17:14
James A James A is offline
Member
 
Join Date: Jan 2011
Posts: 51
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Yup, no jobs at present
Reply With Quote
  #9  
Old 10th March 2011, 17:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please edit the root crontab by running the command:

crontab -e

and comment out the server.sh cronjob line by adding a # in the first line. Then create a new website or email mailbox in ispconfig and check the ispconfig monitor, a item must show up in the jobqueue then.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 10th March 2011, 17:39
James A James A is offline
Member
 
Join Date: Jan 2011
Posts: 51
Thanks: 11
Thanked 0 Times in 0 Posts
 
Default

Hi Till

I have just run a few tests, adding an autoresponder to a mailbox and then checking the job queue and confirm they aren't being added. I also checked the system-log which simply shows:

2011-03-10 16:28 srv.xyz.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2011-03-10 16:28 srv.xyz.com Debug No Updated records found, starting only the core.
2011-03-10 16:28 srv.xyz.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

so it doesn't look as though I'm just being slow and the job is processing.

What does happen is the change appears to get written to the ISPConfig database as the change is shown when I go back to the email account in question.
Reply With Quote
Reply

Bookmarks

Tags
autoresponder, courier, jobqueue, mail filter, plugin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
when deleting index.* files index.html is created and owned by root pssara Installation/Configuration 3 27th February 2009 12:37
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
ubuntu 8.04 server installation of ispconfig fails DocProc Installation/Configuration 27 5th June 2008 21:23
pure-ftp woes d3th_n1gG4 Server Operation 4 24th January 2007 13:11


All times are GMT +2. The time now is 21:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.