#1  
Old 8th September 2005, 14:41
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default Forwarding mail

If I set mail forwarding to a certain user it work's okay. After I remove this setting (and save) forwarding is still active.
How do I remove it permanently ?

Jysse
Reply With Quote
Sponsored Links
  #2  
Old 8th September 2005, 15:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Originally Posted by jysse
If I set mail forwarding to a certain user it work's okay. After I remove this setting (and save) forwarding is still active.
How do I remove it permanently ?

Jysse
Forwarding is removed if you empty the forwaring field and click on save.
It may take up to a minute until the changed forwarding information is saved to the config files.
Reply With Quote
  #3  
Old 9th September 2005, 09:53
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default More information

Quote:
Originally Posted by till
Forwarding is removed if you empty the forwaring field and click on save.
It may take up to a minute until the changed forwarding information is saved to the config files.
I did try that and found that problem is not related to mail forwarding. It's something with the mail system.
This is a little bit difficult to explain but I'll try with my bad english.
I have two domains. Let's say they are domain1.com and domain2.com.
Mail services with domain1.com works ok. In domain2.com there is mail user called info@domain2.com. Before I set this mail forwarding like this info@domain2.com goes to user1@domain1.com. When I removed this setting mail is still received by user1@domain1.com
I tested more and found out that no matter what mail address I use to domain2.com it goes to user1@domain1.com.
Example: mailto info@domain2.com > goes to user1@domain1.com
mailto xxx@domain2.com (does not exist) > goes to user1@domain1.com

These two isp sites have same kind of settings. Only difference that I found
is PHP Safe mode. It is enabled in domain2.com.

Jysse
Reply With Quote
  #4  
Old 9th September 2005, 10:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Originally Posted by jysse
I did try that and found that problem is not related to mail forwarding. It's something with the mail system.
This is a little bit difficult to explain but I'll try with my bad english.
I have two domains. Let's say they are domain1.com and domain2.com.
Mail services with domain1.com works ok. In domain2.com there is mail user called info@domain2.com. Before I set this mail forwarding like this info@domain2.com goes to user1@domain1.com. When I removed this setting mail is still received by user1@domain1.com
I tested more and found out that no matter what mail address I use to domain2.com it goes to user1@domain1.com.
Example: mailto info@domain2.com > goes to user1@domain1.com
mailto xxx@domain2.com (does not exist) > goes to user1@domain1.com

These two isp sites have same kind of settings. Only difference that I found
is PHP Safe mode. It is enabled in domain2.com.

Jysse

As i understand you have a website in ISPConfig with the domain domain1.com. Is domain1.com also the domainname of your Server?

Postfix cant handle email correctly when the domainname of the server is identical to the domainname of one of the virtual sites. Postfix then routes all email to the first site.
Reply With Quote
  #5  
Old 9th September 2005, 10:22
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default Same name

Quote:
Originally Posted by till
As i understand you have a website in ISPConfig with the domain domain1.com. Is domain1.com also the domainname of your Server?

Postfix cant handle email correctly when the domainname of the server is identical to the domainname of one of the virtual sites. Postfix then routes all email to the first site.
Yes, that's correct, they are with the same name. Can you tell me how do I fix it ?

Jysse
Reply With Quote
  #6  
Old 9th September 2005, 10:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Originally Posted by jysse
Yes, that's correct, they are with the same name. Can you tell me how do I fix it ?

Jysse
Try to change your hostname to something like server1.domain1.com, maybe that is enough:

echo server1.domain.com > /etc/hostname
/bin/hostname -F /etc/hostname

Then set the new server hostname in the ispconfig configuration file:

/home/admispconfig/ispconfig/lib/config.inc.php
Reply With Quote
  #7  
Old 9th September 2005, 11:22
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by till
Try to change your hostname to something like server1.domain1.com, maybe that is enough:

echo server1.domain.com > /etc/hostname
/bin/hostname -F /etc/hostname

Then set the new server hostname in the ispconfig configuration file:

/home/admispconfig/ispconfig/lib/config.inc.php
I was not correct with these settings. Here is some more information. Hope it helps, thanx so far.

from server:
/etc/hostname = machinename.domain1.com

From ispconfig (domain1):

server = machinename.domain1.com
hostname = www
domain = domain1.com
ip address = 192.168.1.2

Domain2:

server = machinename.domain1.com
hostname = www
domain = domain2.com
ip address = 192.168.1.2
Reply With Quote
  #8  
Old 9th September 2005, 18:03
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in /etc/postfix/main.cf as myhostname or mydomain? I guess it's www.domain1.com so you should change it to machinename.domain1.com and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 10th September 2005, 08:24
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by falko
What's in /etc/postfix/main.cf as myhostname or mydomain? I guess it's www.domain1.com so you should change it to machinename.domain1.com and restart Postfix.
Sorry, it's already machinename.domain1.com ...

I tried to restart postfix but same problem exist. Any more suggestions ?
Shall I examine logs and if so which one ?

Jysse
Reply With Quote
  #10  
Old 11th September 2005, 19:13
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Is machinename.domain1.com a Co-Domain of the web site www.domain1.com? If so, remove it!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Using a subdomain as mail server roberto8080 Installation/Configuration 7 21st June 2006 01:50
mail user settings todvard Feature Requests 7 2nd March 2006 10:45
Mailserver not receiving mail Unsaferanger Installation/Configuration 3 26th August 2005 08:59
2 mail servers? thedude General 2 15th August 2005 16:34
mail() function not available in PHP??? dirk Programming/Scripts 4 26th May 2005 14:18


All times are GMT +2. The time now is 10:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.