Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 6th May 2011, 13:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

There are spikes in disk latency and disk usage for /dev/sdb. Maybe there's something wrong with the drive?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #22  
Old 6th May 2011, 13:34
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

thanks, I saw that. but postfix was busy sending out a huge newsletter and the HD always gets that busy during that period without crashing everything.

since I moved to this new server just a few months ago, I assumed the HDs were ok...

I'll run the Strato HW test again tonight, makes the server unreachable for two hours but at least I'll know if there is something wrong...

btw. that server runs on a software raid1 that came pre-installed on the minimal debian OS they offer. anyone has any links for raid optimizing? any parameters to tune? I haven't touched it yet...
Reply With Quote
  #23  
Old 9th May 2011, 21:59
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Maybe this could help you...

http://rimuhosting.com/howto/memory.jsp
Reply With Quote
  #24  
Old 9th May 2011, 22:12
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

thx, there are a few nice tips in there, will see if it helps figure it all out...
Reply With Quote
  #25  
Old 11th May 2011, 21:15
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

didn't have time to check the HDs yet, but here we go again:


|-amavisd-new---2*[amavisd-new]
|-apache2-+-50*[apache2]
| |-apache2---60*[php-cgi]

swapping like crazy.

top with M pressed: http://screencast.com/t/P4m7xKvs8

everything is soooo slow :-(

###edit###
managed to dump some info here: http://pastebin.com/qErr4PjE - does that help?

Last edited by Ovidiu; 11th May 2011 at 21:45.
Reply With Quote
  #26  
Old 11th May 2011, 22:52
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Are you using prefork or worker? Could you post your apache2.conf
Reply With Quote
  #27  
Old 11th May 2011, 22:54
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

using prefork.
config is here: http://howtoforge.com/forums/showpos...9&postcount=14
did restart apache and it became a bit better and more responsive...

still need to figure out whats going wrong here.
Reply With Quote
  #28  
Old 11th May 2011, 23:26
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Backup your apache2.conf, make this changes:

MaxKeepAliveRequests 100
KeepAlivetimeout 15

<IfModule mpm_prefork_module>
StartServers 2
MinSpareServers 2
MaxSpareServers 3
MaxClients 45
MaxRequestsPerChild 500
</IfModule>

I am not an expert, but as I can see apache2 is eating all your memory... I don't know your entire configuration and if this could or not work for you. But I think that you must limit the resources destinated to apache, in order to evade swap (and lack of memory... see what happen in four or five days, your memory will not be enough if you let it as it is right now).

Try to see if it works better or not than before. Take note of memory consumtion and memory consumption incrementation curve (more slow? more quickly?). If you note any change, it is just a setting problem with this directives. If this not work, you always can rollback the conf file.

Restart apache2 this night, it was recently restarted, so... it must be running ok right now.

Regards
Reply With Quote
  #29  
Old 11th May 2011, 23:47
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

not sure if your settings will help.
I see you want me to start fewer children and limit the maxrequestsperchild but it doesn't look like some script has a memory leak as I don't have a few apache children with high memory consumption, I have heaps of them...

default KeepAlivetimeout is 5 - why set it higher? that will tie my ressources down even more :-(

still, giving some of your changes a try.

thanks
Reply With Quote
  #30  
Old 12th May 2011, 00:51
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
 
Default

What I want is to isolate you problem (not to find the exactly settings). If you can manage to do that, next you know where to work (if you have changes after this, you can see if you have problems only with apache, or with other process, or whatever)

When I am blind about a problem, always worked for me to discard little pieces one at a time.

I give special atention to your case, I will use debian with apache2 in production server in a few days, finding a solution for you will be great for me too. I will keep working on your problem.

Right know, in my test server, with just 2 test sites with almost no traffic, my ram consumption has growth from 340mb to 1.4gb max in 2 days (with no swaping because I have 4gb ram).

I think that apache2 debian package is not prepared out of the box to host vhosts... we will see for your health and mine :P

Regards
Reply With Quote
Reply

Bookmarks

Tags
apache2, server, tuning

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.1.4 causes Apache to have too many open files gkovacs Installation/Configuration 29 27th February 2013 08:59
Whole server went down wxman General 25 28th September 2012 18:32
about: tuning apache2 Ovidiu HOWTO-Related Questions 26 2nd February 2011 12:28
ISPConfig 3 Security mnzava Installation/Configuration 8 8th March 2010 11:00
Swap usage issue MrM General 23 7th October 2009 10:52


All times are GMT +2. The time now is 11:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.