Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th January 2011, 06:20
WeaponX WeaponX is offline
Junior Member
 
Join Date: Dec 2010
Posts: 9
Thanks: 2
Thanked 0 Times in 0 Posts
Default vhost Default disabled and other sites showing with 404 error.

This is what is happening.
When i disable the vhost "default" site from sites-available, ispconfig site and mail site get a 404 error when going to the url.

So, when the vhost "default" site is enabled all other sites are working fine.
I have searched for a global config on apache and ispconfig, but no cigar.

Any help will be apreciated. Thanks in advanced.

My setup:
Code:
web:~# ls -la /etc/apache2/sites-available/
total 44
drwxr-xr-x 2 root root 4096 2011-01-09 22:13 .
drwxr-xr-x 7 root root 4096 2010-08-25 21:10 ..
-rw-r--r-- 1 root root 1014 2011-01-09 20:37 apps.vhost
-rw-r--r-- 1 root root  953 2011-01-09 20:55 default
-rw-r--r-- 1 root root  953 2011-01-09 20:50 default.bak
-rw-r--r-- 1 root root 7366 2010-04-19 14:55 default-ssl
-rw-r--r-- 1 root root 1055 2011-01-09 22:23 ispconfig.conf
-rw-r--r-- 1 root root 1598 2011-01-09 22:04 ispconfig.vhost
-rw-r--r-- 1 root root 1700 2011-01-09 22:24 mail.XXX.com.vhost
-rw-r--r-- 1 root root 1707 2011-01-09 22:13 mail.XXX.com.vhost.bak
------------------------------------------------------------------------------------
Code:
web:~# ls -la /etc/apache2/sites-enabled/
total 8
drwxr-xr-x 2 root root 4096 2011-01-09 20:59 .
drwxr-xr-x 7 root root 4096 2010-08-25 21:10 ..
lrwxrwxrwx 1 root root   39 2010-08-25 22:20 000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
lrwxrwxrwx 1 root root   43 2010-08-25 22:20 000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
lrwxrwxrwx 1 root root   44 2010-08-25 22:21 000-ispconfig.vhost -> /etc/apache2/sites-available/ispconfig.vhost
lrwxrwxrwx 1 root root   50 2011-01-08 23:31 mail.XXX.com.vhost -> /etc/apache2/sites-available/mail.XXX.com.vhost
Code:
web:~# cat /etc/apache2/sites-enabled/mail.XXX.com.vhost 
<Directory /var/www>
    AllowOverride None
    Order Allow,Deny
    Allow from all
</Directory>


<VirtualHost *:80>
      DocumentRoot /var/www/mail.XXX.com/web
  
    ServerName mail.XXX.com
    ServerAdmin webmaster@mail.XXX.com

    ErrorLog /var/log/ispconfig/httpd/mail.XXX.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html
	
    <Directory /var/www/mail.XXX.com/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        <Files ~ '.php[s3-6]{0,1}$'>
            Order allow,deny
            Deny from all
            Allow from none
        </Files>
    </Directory>
    <Directory /var/www/clients/client2/web5/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        <Files ~ '.php[s3-6]{0,1}$'>
            Order allow,deny
            Deny from all
            Allow from none
        </Files>
    </Directory>

    # cgi enabled
	<Directory /var/www/clients/client2/web5/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/www/clients/client2/web5/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web5 client2
    </IfModule>


</VirtualHost>

Code:
web:~# cat /etc/apache2/sites-available/default
<VirtualHost *:80>
	ServerAdmin webmaster@localhost
	
	DocumentRoot /var/www/
	<Directory />
		Options none FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options none FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2011, 13:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,808
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

The default site is a requirement in a ispconfig setup. So disabling it means to disable everal services.

So if you want to use ispconfig on that server, dont disable system requirements for ispconfig like the default vhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th December 2011, 21:54
keesje76 keesje76 is offline
Junior Member
 
Join Date: Jan 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I had a problem recent that looks a bit like this one. The "default" Vhost seems to block 1 site. This site had the domain the server itself had to host some general scripts and tools.
When I changed the FDN belonging to the public IP in /etc/hosts to a another domain the problem was gone.
So, dont try to host a site under the same domain as your server has, in my case it fails to server the content of the default Vhost.

Maybe its of use to someone searching for this.

Regards,

Kees
-------
Kopu Webshops
Reply With Quote
Reply

Bookmarks

Tags
apache, error 404, ispconfig3, vhost

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.