Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th January 2011, 19:20
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default Open website locally

I would like to be able to open the websites on the server locally.
The server is a development server and will not be made available on the internet, but I cant seem to figure out how to display a website.

I tried the following

http://ipadres/~domain.com
http://ipadres:8080/~domain.com

doesnt seem to work. Any suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 8th January 2011, 20:26
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default

With locally I actually mean from within the network.
Reply With Quote
  #3  
Old 9th January 2011, 11:52
autogun autogun is offline
Member
 
Join Date: Sep 2009
Posts: 69
Thanks: 9
Thanked 5 Times in 5 Posts
Default

This will do the trick - http://www.howtoforge.com/forums/sho...37&postcount=1

I have this working on a production server. This gives me the option give my customers access to their website without editing hosts file or purchasing domain/pointing domain to the server.

Domain ends up to be: www.<domain>.com/net/org.virt.<server domain>.com
Reply With Quote
  #4  
Old 10th January 2011, 00:27
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 39 Times in 33 Posts
 
Default

If you're only interested in viewing the site from one or two machines, it would be much simpler to open the hosts file on the local machine and add a line.

Hosts files is in a directory similar to
/system32/drivers/etc

On a windoze machine.

Add the name of the site you want to see followed by the ip address of the machine it is hosted on. There are example lines in that file hashed out.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem 100% CPU ispconfig_httpd -DSSL Captain Installation/Configuration 7 8th March 2010 21:50
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
open ports rayit General 6 18th January 2006 14:23


All times are GMT +2. The time now is 16:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.