#1  
Old 22nd June 2006, 07:07
snook snook is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default isp blocks port 25

ISPconfig is very cool and I have most of it working.

So, my isp blocks port 25 and I have got around this in the past by using the smtp redirect service with rollernet.us and port 2525 with another mail server.

I've added to /etc/postfix/master.cf

smtp inet n - n - - smtpd
2525 inet n - n - - smtpd

I can telnet to both 25 and 2525 and get the normal responses and postfix is running.

netstat -tap provides this:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address Stat e PID/Program name
tcp 0 0 *:imaps *:* LIST EN 1814/xinetd
tcp 0 0 *op3s *:* LIST EN 1814/xinetd
tcp 0 0 *:49507 *:* LIST EN 1529/rpc.statd
tcp 0 0 *:mysql *:* LIST EN 1908/mysqld
tcp 0 0 *op3 *:* LIST EN 1814/xinetd
tcp 0 0 *:imap *:* LIST EN 1814/xinetd
tcp 0 0 *:sunrpc *:* LIST EN 1511/portmap
tcp 0 0 *:81 *:* LIST EN 2156/ispconfig_http
tcp 0 0 192.168.1.2:domain *:* LIST EN 2418/named
tcp 0 0 hidden.dom:domain *:* LIST EN 2418/named
tcp 0 0 hidden.dom:ipp *:* LIST EN 1765/cupsd
tcp 0 0 hidden.dom:5335 *:* LIST EN 1747/mDNSResponder
tcp 0 0 *:smtp *:* LIST EN 3506/master
tcp 0 0 hidden.dom:rndc *:* LIST EN 2418/named
tcp 0 0 *:2525 *:* LIST EN 3506/master
tcp 0 0 *:http *:* LIST EN 2323/httpd
tcp 0 0 *:ssh *:* LIST EN 1805/sshd
tcp 0 0 localhost:rndc *:* LIST EN 2418/named
tcp 0 0 *:https *:* LIST EN 2323/httpd
tcp 0 148 ::ffff:192.168.1.2:ssh ::ffff:192.168.1.3:2522 ESTA BLISHED 5264/2
tcp 0 0 ::ffff:192.168.1.2:ssh ::ffff:192.168.1.7:54503 ESTA BLISHED 2792/sshd: snook[pr

There is an A record pointing to mail under the domain to the correct global IP.

The MX record points to mail.rollernet.us

However, when I try to point an email client to mail.domain.com or the IP address I get a mail relay access denied when trying to send.. I'm not sure if the issue is with the local ispconfig server or with rollernet. Or maybe both. When I send an email from an external account it disappears. No bounce and no received email.


I've trawled through the forums looking for the answer to this but haven't found it. Probably I've missed something obvious.
Reply With Quote
Sponsored Links
  #2  
Old 22nd June 2006, 10:27
lerra lerra is offline
Member
 
Join Date: Jan 2006
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you tell postfix to send all mail to rollernet.us? Please check there forum/docs, they should have examples!

Do you get login promt when you try to send mails? Elese you could add your local lan to the relaynetwork. If you dont get login promt you need to specify that authpam should be used for relaying.
Try to send with the webmail application too, check what mail.info/warn says in /var/log
Reply With Quote
  #3  
Old 22nd June 2006, 10:49
snook snook is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default can send

OK, have got a little further.

Can now send to external but not receiving anything.

So, if me@example.com (ISPC) sends to me2@xyz.com that works fine. If I reply from me2@xyz.com to that message it disappears. No bounce, no delivery. It's probably the rollernet thing. I'll keep checking.

Also, when I log in the client it does ask for a password which it accepts.

Thanks
Reply With Quote
  #4  
Old 23rd June 2006, 00:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Please make sure Maildir is disabled under Management -> Server -> Settings -> Email.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd June 2006, 05:43
snook snook is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Maildir

Hi Falko,

To disable the maildir should that be checked or unchecked? It's currently unchecked.

Thanks
Reply With Quote
  #6  
Old 23rd June 2006, 13:35
snook snook is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Webmail working

Thanks Leera,

Installed the webmail stuff and all the test messages were in there. Can send end to end now this way and need to spend some more time tweaking the pop side. Lack of knowledge really.

I'll post further when I have it figured.

Cheers,

Snook
Reply With Quote
  #7  
Old 24th June 2006, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

Quote:
Originally Posted by snook
To disable the maildir should that be checked or unchecked? It's currently unchecked.
Yes, it must be unchecked.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
isp blocks port 25 snook Installation/Configuration 1 21st June 2006 18:15
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Sequring TPS Fedora4 Hagforce HOWTO-Related Questions 17 28th March 2006 18:36
Duplicate virtual hosts bosei General 13 22nd December 2005 18:48
Moving Apache to another port DrAgOOn Installation/Configuration 2 16th September 2005 12:14


All times are GMT +2. The time now is 05:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.