Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th January 2011, 15:12
kaleddis kaleddis is offline
Junior Member
 
Join Date: Jan 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Resette ISPconfig user, cannot login anymore :'(

Hello,

Yesterday I resetted the ISPconfig user in PHPmyadmin, in order to get rid of a postfix error.
It resulted in that I couln't login anymore... With every user I try I get the following error: Error - Username or Password wrong.1

So, I looked up the original password of ISPconfig in config.inc.php, changed it back in phpmyamin, but the problem remains.

Tried everything now and it drives me crazy :'(
Anyone out there who has a clue what to do next?

Kindest regards,
Kaledis

UPDATE: Looked into the httpd logs and found the following error:

Warning: mysql_connect(): Access denied for user 'ISPConfig'@'localhost'

So, obviously the password for ISPConfig still isn't correct..
When I change the password in MySQL (By PHPmyamin) I fill in the MD5 hash, as found in the config, is this correct?
Is there another place than the sys_user table where I have to change this?

Hope you guys can help me. Newbie on a production server, aaahhhhhhh !

Last edited by kaleddis; 6th January 2011 at 17:15. Reason: Update
Reply With Quote
Sponsored Links
  #2  
Old 7th January 2011, 14:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you delete the user from the mysql.user table as well?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th January 2011, 16:10
kaleddis kaleddis is offline
Junior Member
 
Join Date: Jan 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up Solution

Hi Falko,

Do I did not, but in the meanwhile I have found the solution.
At first I copied / pasted the password from the config right into phpmyadmin.
Of course, that was not correct. So, later on, I put in the MD5 hash password.

But that didn't solve the problem.
It turned out that the ISPConfig user didn't have any rights anymore (???)
Also he didn't have any rights on the database.
So after I gave global rights and rights to the database everything started working again.

Big question is of course, what did change these rights in this user ???

Thanks for your reply!
Kaleddis
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
ISPconfig 3: can't send or receive messages zogthegreat Installation/Configuration 6 22nd May 2010 14:45
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47
Reload this Page ISPCONFIG 2.2.14 Debian etch user login chrisrob301 Installation/Configuration 12 11th July 2007 18:09


All times are GMT +2. The time now is 14:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.