Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th December 2010, 17:04
wontolla wontolla is offline
Member
 
Join Date: Jul 2008
Posts: 58
Thanks: 3
Thanked 0 Times in 0 Posts
Exclamation Ultra Slow server no connection or console

Hi my Ubuntu 8.04 LTS, perfect server guide, has been working like a charm except for a few minor troubles. Today, 24th, the mail is down users can receive but end (SMTP is down or very busy). The server is really slow, no ssh, no login, just like:

http://www.howtoforge.com/forums/showthread.php?t=50559

No idea if is a hacking because cannot see the logs but after reading the forum it seem so. I'd a big and expensive firewall so I cannot really know what´s happening.

So I'll probably need a way to move all data to another server, but there's no easy way to do that.

I'd moved the server to another room and rechecked, but still seems too slow, the last change I'd made is change MAXPERIP from 20 to 80 and MAXDAEMONS from 40 to 80. The server is a Dual Core with 2 GB RAM.

Any help?.

Update: I've disconnected the server from LAN/WAN is very slow at booting jutst before showing " Starting ISPConfig systemm..." and "/root/ispconfig/httpd/bin/apachectl startssl: httpd started" and after that. No user asked. Normally the server could boot in less than 5 mins now it takes several hours. The HDD led activity is really busy so I know that computer is really working.

Btw heavy CPU and RAM using, no process showed at top so it must be a Daemon, tried with imapd, postfix, it seems MySQL related because shows an error with mysql stop (ERROR 1045 (28000) : aCCESS DENIED FOR USER ROOT'@'LOCALHOST') and mysqld shows unable to lock ./ibdata1 error: 11... It could be hacked?

Last edited by wontolla; 24th December 2010 at 19:03.
Reply With Quote
Sponsored Links
  #2  
Old 27th December 2010, 10:24
wontolla wontolla is offline
Member
 
Join Date: Jul 2008
Posts: 58
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Still very slow, I'm going to change my server for remote hosting. Damn my server was really useful.

Any help?.
Reply With Quote
  #3  
Old 27th December 2010, 10:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

Quote:
Btw heavy CPU and RAM using, no process showed at top so it must be a Daemon
Daemons show up with top as well. If you have a high load but no processes show up, then you should scan your server with chkrootkit and rkhunter to rsure that It is not hacked.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 29th December 2010, 09:50
wontolla wontolla is offline
Member
 
Join Date: Jul 2008
Posts: 58
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Chkrootkit says I have 2 hidden process from ps command and a possible LKM Trojan.

I'll need to stop those process, surely they are wasting the CPU, to exstract all the info and make a new server.

RKHunter shows

warnings

/usr/sbin/adduser
/usr/sbin/groups
/usr/bin/ldd
/usr/bin/lwp-request
/bin/which

RKHunter shows no rootkit, just those warnings......

Last edited by wontolla; 29th December 2010 at 14:55.
Reply With Quote
  #5  
Old 29th December 2010, 16:23
wontolla wontolla is offline
Member
 
Join Date: Jul 2008
Posts: 58
Thanks: 3
Thanked 0 Times in 0 Posts
Default

The server is still very busy so I'm installing another server, which files should I copy to restore the emails?.
Reply With Quote
  #6  
Old 30th December 2010, 17:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You can use imapsync to restore your emails: http://www.howtoforge.com/how-to-mig...-with-imapsync
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 30th December 2010, 17:40
wontolla wontolla is offline
Member
 
Join Date: Jul 2008
Posts: 58
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Thanx, trouble is server 1 is down, I cannot make a backup less try to sync the data. I'm going extract the HDD and connect to another computer to read the files, but I need to know which ones.
Reply With Quote
  #8  
Old 31st December 2010, 14:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

If you use Maildir, the Maildir directories with all emails are in each user's homedir.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 3rd January 2011, 18:39
wontolla wontolla is offline
Member
 
Join Date: Jul 2008
Posts: 58
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I'm using the perfect server guide so no idea. I'd tried imapsync but I got rejected at destination server, strange but is a vmware virtual machine, I'll dig a real one and install ISPConfig 3 and retry.

Btw if I make a backup from ISPConfig 2, how do I restore it?, can I restore the backup in ISPConfig 3?

Last edited by wontolla; 3rd January 2011 at 18:47.
Reply With Quote
  #10  
Old 4th January 2011, 10:52
wontolla wontolla is offline
Member
 
Join Date: Jul 2008
Posts: 58
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Wow, server started to work, CPU is OK and everything works, I need to move all data to another server, BCK does not copy emails, so what now?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Need some Hints to "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" wahid HOWTO-Related Questions 10 25th August 2010 15:18
Stange mail problem The-Ghost Installation/Configuration 6 25th April 2010 19:59
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08


All times are GMT +2. The time now is 03:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.