Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th May 2011, 06:49
fishown fishown is offline
Junior Member
 
Join Date: May 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default document root, dosent work as expacted

Hello everyone,
I know this issue is minor, but I want to fix all the little bugs.
In php, whene i type "/some/thing.XXX"
It wont reach the file, only if ill add "." like this "./some/thing.XXX"
The document root function point to the web folder as it sould,
but the "/" not.

and ideas?
Reply With Quote
Sponsored Links
  #2  
Old 16th May 2011, 13:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

To what tutorial are you referring?

Do you use ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th May 2011, 15:49
fishown fishown is offline
Junior Member
 
Join Date: May 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

soory that I dident mentioned ....

Perfect server centOS 5.6
Reply With Quote
  #4  
Old 16th May 2011, 16:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

If you include a file in php with require() or include(), the website docroot is not relevant for php. So if you include a file from a local path, the path is either ./some/thing.XXX or some/thing.XXX. Paths thats tart with / have to be full paths, e.g. /var/www/www.yourdomain.com/web/some/thing.XXX
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 16th May 2011, 17:23
fishown fishown is offline
Junior Member
 
Join Date: May 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

but if I remmber currectly I used "/" as the root folder...
Reply With Quote
  #6  
Old 17th May 2011, 15:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What's the DocumentRoot setting from your virtual host? I doubt that it is "/".

Please try what Till suggested and leave out the "/" in the beginning of your PHP paths.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 17th May 2011, 16:44
fishown fishown is offline
Junior Member
 
Join Date: May 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

hi ther,
recently I moved my website to a newer server, so i get alot of not working code,
sinse all the codes user / infront of the pathes,
so i would like to know how to make the / as the document root please.
thank you
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quota Exceeded errors IKShadow Installation/Configuration 14 20th January 2011 17:39
/boot is 100% full Sohail Khawaja HOWTO-Related Questions 6 6th January 2010 21:32
automatic webmail link admins Installation/Configuration 16 22nd June 2009 17:42
Postfix email server problems Access denied 554 554 5.7.1 state 14 AceRimmer Server Operation 4 19th June 2008 15:36
Server Side Includes don't work PermaNoob General 7 1st May 2007 21:38


All times are GMT +2. The time now is 01:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.