#1  
Old 10th January 2011, 13:58
quinohe quinohe is offline
Junior Member
 
Join Date: Nov 2010
Posts: 8
Thanks: 1
Thanked 2 Times in 2 Posts
Default openqrm with lxc

There is something i need to ask before i can go any further with my server.
Although i completed the howto successfully.
The howto used is this one; http://www.howtoforge.com/how-to-ins...y-step-by-step
During the installation i get a warning:
Code:
WARNING: include path for php has changed!                          
                                                                        
      libphp-adodb is no longer installed in /usr/share/adodb. New        
      installation path is now /usr/share/php/adodb.                      
                                                                          
      Please update your php.ini file. Maybe you must also change your    
      web-server configuration.
Need i do something with this?
And if so, what is needed todo, this?
Code:
ln -s /usr/share/adodb /usr/share/php/adodb
?

When you need to login to mysql there is stated you use the password created in E6.2,
i think this must be E6.1.

Just to be sure, is this mysql code correct, and enough?

Code:
mysql> create database openqrm;
Query OK, 1 row affected (0.01 sec)

mysql> GRANT ALL PRIVILEGES ON `openqrm`.* TO 'root'@'localhost' IDENTIFIED BY 'passwrd' WITH GRANT OPTION ;
Query OK, 0 rows affected (0.01 sec)

mysql> flush privileges;
Query OK, 0 rows affected (0.01 sec)

mysql> quit
Bye
tail -f /var/log/messages
Code:
Jan 10 12:08:00 openqrm logger: openQRM-cmd-queu NOTICE : Running 5c42b1fd1dc22f49a426252baf3c74b0 : /usr/share/openqrm/bin/dbclient -K 10 -y -i /usr/share/openqrm/etc/dropbear/dropbear_rsa_host_key -p 1667 root@127.0.0.1 "/usr/share/openqrm/bin/openqrm-cmd sed -i -e 's/^OPENQRM_DATABASE_SERVER=.*/OPENQRM_DATABASE_SERVER=localhost/g' -e 's/^OPENQRM_DATABASE_NAME=.*/OPENQRM_DATABASE_NAME=openqrm/g' -e 's/^OPENQRM_DATABASE_USER=.*/OPENQRM_DATABASE_USER=root/g' -e 's/^OPENQRM_DATABASE_PASSWORD=.*/OPENQRM_DATABASE_PASSWORD=secret/g' /usr/share/openqrm/etc/openqrm-server.conf"
Jan 10 12:08:03 openqrm logger: openQRM engine: Running as root cmd : sed -i -e s/^OPENQRM_DATABASE_SERVER=.*/OPENQRM_DATABASE_SERVER=localhost/g -e s/^OPENQRM_DATABASE_NAME=.*/OPENQRM_DATABASE_NAME=openqrm/g -e s/^OPENQRM_DATABASE_USER=.*/OPENQRM_DATABASE_USER=root/g -e s/^OPENQRM_DATABASE_PASSWORD=.*/OPENQRM_DATABASE_PASSWORD=secret/g /usr/share/openqrm/etc/openqrm-server.conf
Jan 10 12:08:03 openqrm logger: 
Jan 10 12:08:04 openqrm logger: openQRM-cmd-queu NOTICE : Running 7a14a88ffd1df4e68349292467dc08a5 with custom cmd-timeout 60
Jan 10 12:08:04 openqrm logger: openQRM-cmd-queu NOTICE : Running 7a14a88ffd1df4e68349292467dc08a5 : /usr/share/openqrm/bin/dbclient -K 10 -y -i /usr/share/openqrm/etc/dropbear/dropbear_rsa_host_key -p 1667 root@127.0.0.1 "/usr/share/openqrm/bin/openqrm-cmd /usr/share/openqrm/bin/openqrm init_config"
Jan 10 12:08:08 openqrm logger: openQRM engine: Running as root cmd : /usr/share/openqrm/bin/openqrm init_config
Jan 10 12:08:10 openqrm openQRM init-config[28909]: Initialyzing the openQRM Database
Jan 10 12:08:14 openqrm openQRM init-config[29090]: ERROR: Initialyzing the openQRM Database failed !
Jan 10 12:08:14 openqrm logger: Initializing the openQRM-database ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES) Reloading configuration files for periodic command scheduler: cron.
Jan 10 12:14:45 openqrm nagios3: Auto-save of retention data completed successfully.
The login page for openqrm.localdomain works, but i get no further than step3,
where it's asking for used database and password.

Still in the process of learning, i really need some help!

Thanks in advance,
Quinohe

Last edited by quinohe; 11th January 2011 at 02:35.
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2011, 02:25
quinohe quinohe is offline
Junior Member
 
Join Date: Nov 2010
Posts: 8
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default workaround

Think i found something,
It is about the openqrm password for mysql.

I used a password looking a lot like this one: '89P@s$word'.
But when i use this one, it works: '89PasSword'
I can login to the website with the last one.

What i find out was that some characters are used in other ways,
it seems to be about quoting and escaping.
It took me all day to solve that puzzle!

But still don't know how all the characters are used,
it's a bit overwhelming this mysql
Guess i will figure it out in the end.

Still like to use a more secure passwrd, like the first one!
Didn't find a suitable solution, says i should quote '*' , and thats what i did.

So, now a have access to the website there is still something wrong.
When i try to enable a plug-in, for instance nagios, there is a message:
Code:
Timeout while enabling nagios3
In fact none of the plugins will enable.

edit--------------

Well figured this one out to.
When u are using a bridged setup, consider changing your openqrm server interface from eth0 into br0.
You do this by editing /usr/share/openqrm/etc/openqrm-server.conf.
You should do this before you execute 'make start'.

Everything is working now, all the plugins are working.
Took me some time, and answered all my own.

Hope this is of some use to someone else.

Quinohe

Last edited by quinohe; 12th January 2011 at 11:42.
Reply With Quote
The Following User Says Thank You to quinohe For This Useful Post:
falko (12th January 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking with LXC guest under Ubuntu (Hetzner EQ4 server) Seidr Installation/Configuration 1 18th November 2010 16:53
How to setup OpenQRM 4.7 with LXC Supprt in Debian Squeeze/Lenny zenny HOWTO-Related Questions 1 4th October 2010 14:46
OpenQRM Intergration with ISPC3 morraine Feature Requests 9 22nd August 2010 16:20
lxc networking question CSsab Server Operation 0 3rd June 2010 19:05
Xen + openQRM icmono Suggest HOWTO 1 19th January 2009 14:02


All times are GMT +2. The time now is 05:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.