Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th December 2010, 15:21
bambino bambino is offline
Junior Member
 
Join Date: Dec 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix can send mail in outlook

Hello,

I have set up a postfix server with virtual domains. When i test via telnet everything goes well i can send and receive messages. So far so good.

Now i have created a email account in outlook express and have marked "authorization is required". I can receive mails now in outlook but i am unable to send any mails.

When i check my log files i get this:

/var/log/messages

Code:
Dec 30 10:58:36 server postfix/smtpd[19060]: auxpropfunc error invalid parameter supplied
/var/log/maillog (my ip is my own ip adress)

Code:
Dec 30 10:58:36 server postfix/smtpd[19060]: warning: my-ip: hostname ip5651555b.speed.planet.nl verification failed: Name or service not known

Dec 30 15:58:36 server postfix/smtpd[19060]: connect from unknown[my-ip]
Dec 30 15:58:36 server postfix/smtpd[19060]: lost connection after UNKNOWN from unknown[my-ip]
Dec 30 15:58:36 server postfix/smtpd[19060]: disconnect from unknown[my-ip]
I have tried everything i can think of to solve this problem but after 1 week of trying i still have the same error and cant send mails via outlook.

This is my postfix main.cf (mydomain in my real file offcourse changed to my real domain)

Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = mail.mydomain.eu, localhost, localhost.localdomain
myhostname = mail.mydomain.eu
mynetworks = 127.0.0.0/8, 192.168.1.0/24
newaliases_path = /usr/bin/newaliases.postfix
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
receive_override_options = no_address_mappings
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
unknown_local_recipient_reject_code = 550
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_minimum_uid = 5000
virtual_uid_maps = static:5000
ps aux|grep sasl is showing:

Code:
root      4033  0.0  0.0   5688   704 ?        Ss   09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root      4034  0.0  0.0   5688   436 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root      4036  0.0  0.0   5688   424 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root      4037  0.0  0.0   5688   424 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root      4038  0.0  0.0   5688   424 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root     28010  0.0  0.0   4112   724 pts/0    S+   11:13   0:00 grep sasl
Im using port 25 for smtp which is open. i also tried changing to port 2525 and agina both work when i send and check mails via telnet but both dont let me send email via outlook

Anyone any suggestions what i can do to fix this problem ?

cheers

Robin

Last edited by bambino; 30th December 2010 at 15:26.
Reply With Quote
Sponsored Links
  #2  
Old 31st December 2010, 14:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Which tutorial exactly (URL) did you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st December 2010, 14:42
bambino bambino is offline
Junior Member
 
Join Date: Dec 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi there,

I dont have the url anymore but it was a tutorial including a setup of postfix with courier, clamav and spamassassin with virtual domains.

cheers

Robin
Reply With Quote
  #4  
Old 1st January 2011, 20:22
bambino bambino is offline
Junior Member
 
Join Date: Dec 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

hi, i solved the problem and am now able to send mails.

i changed smtpd_sasl_auth_enable = yes to no and placed my own ip in my networks.

cheers

Robin
Reply With Quote
Reply

Bookmarks

Tags
postfix email outlook

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 06:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.