#1  
Old 28th December 2010, 14:08
jacksmerv jacksmerv is offline
Member
 
Join Date: Dec 2010
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Default Virtual Hosts

Dear Guys,
I have tried installing ubuntu 10.10, cent OS and Now i have installed Debian 5 with ISPconfig 3 step by step followed the instructions. Everything goes fine. In the ISPsonfig panel i have first created the Client, DNS and Website. I have checked the vi /etc/apache2/sites-available/example.in.vhost , vi /etc/apache2/sites-enabled/example.in.vhost . Everything looks fine. After that if i try to browse the website i have created it shows the default web page for the root /var/www ie., "IT Works ! ". What is the problem. I am not a expert in Linux, I am struggling with this for the past 15 days. Is any step i am missing ? Is anybody there in this universe , Please help to sort out this issue. Thanks in advance.

Last edited by jacksmerv; 28th December 2010 at 15:03.
Reply With Quote
Sponsored Links
  #2  
Old 28th December 2010, 15:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please ensure that you access the website by domain name and not IP. You should also check if the domain that you want to use points with a dns A-Record to the IP address of the server and that you select "Auto subdomain: www" in the website settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
jacksmerv (29th December 2010)
  #3  
Old 28th December 2010, 15:34
jacksmerv jacksmerv is offline
Member
 
Join Date: Dec 2010
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Dear Till,
As you said i have checked the things . My website is pointed to this server. If i try to restart apache2 it gives me the warning like this. /etc/init.d/apache2 restart
Restarting web server: apache2[Tue Dec 28 09:30:46 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
... waiting .[Tue Dec 28 09:30:48 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts

is it related to anything ? You can browse indianwebdesigners.in and check please....
Reply With Quote
  #4  
Old 28th December 2010, 15:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Are there any jobs lsited in the jobqueue in the ispconfig monitor?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
jacksmerv (29th December 2010)
  #5  
Old 28th December 2010, 18:12
jacksmerv jacksmerv is offline
Member
 
Join Date: Dec 2010
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Default

no nothing in the que

ISPConfig Cron - Log

SIOCDELRT: No such process
SIOCADDRT: No such process
SIOCADDRT: No such process
SIOCADDRT: No such process
SIOCADDRT: No such process
SIOCADDRT: No such process
SIOCADDRT: No such process
[Tue Dec 28 07:11:02 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
[Tue Dec 28 07:11:04 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
[Tue Dec 28 07:11:06 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
[Tue Dec 28 07:11:08 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
[Tue Dec 28 09:29:01 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
[Tue Dec 28 09:29:03 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
[Tue Dec 28 09:31:01 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
[Tue Dec 28 09:31:03 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts

Server: Debweb.webdesignerschennai.com (Debian Lenny)
ISPConfig 3.0.3.1
State: ok (0 unknown, 0 info, 0 warning, 0 critical, 0 error)
ok:
The state of your Hard-Disk space is ok [More...]
Your virus protection is ok [More...]
Your Mail queue load is ok [More...]
Your Server load is ok [More...]
All needed services are online [More...]
Your system is up to date. [More...]
The System Log is O.K. [More...]

Last edited by jacksmerv; 28th December 2010 at 18:22.
Reply With Quote
  #6  
Old 28th December 2010, 18:54
jacksmerv jacksmerv is offline
Member
 
Join Date: Dec 2010
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Default

do i have to add the path in Apache Directives to activate my domains ?
Reply With Quote
  #7  
Old 28th December 2010, 19:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
do i have to add the path in Apache Directives to activate my domains ?
no.

Is the server behind a router?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
jacksmerv (29th December 2010)
  #8  
Old 29th December 2010, 04:58
jacksmerv jacksmerv is offline
Member
 
Join Date: Dec 2010
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Default

yes it is behind a watchguard firewall x550e
Reply With Quote
  #9  
Old 29th December 2010, 10:40
jacksmerv jacksmerv is offline
Member
 
Join Date: Dec 2010
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

Thanks Till,
I have connected my server without firewall and it is working fine. one thing is missing my webmail... It gives me 404 error. What could me the problem? please help ...

Another thing if i connect through my hardware firewall how should configure my ISPconfig according to that. please guide me. Thanks in advance.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual hosts Toucan Server Operation 2 15th December 2009 01:15
Fedora 11, ISPconfig and virtual hosts robyoko Installation/Configuration 9 23rd September 2009 18:09
Apache Virtual Hosts - I have never gotten this right. DazzyB Server Operation 2 24th December 2007 13:37
SSL for virtual hosts on one certificate rbartz Tips/Tricks/Mods 8 20th November 2007 17:59
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 17:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.